当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信飙升买点副图/选股预警 源码 测试图 主要有启动买入点、黑马买入点两个信号(无源码的请下载附件导入)

{资金通用}
A:=V*100/CAPITAL;
主力:=MA(A,4);
游资:=MA(A,8);
大户:=MA(A,16);
散户:=MA(A,32);

{资金额亿}
YUWEI:=MA(CLOSE,1)-MA(CLOSE,6);
线上:=YUWEI>0;
线下:=YUWEI<0;
线下绿柱:=YUWEI<0 AND YUWEI<REF(YUWEI,1);
线下红柱:=YUWEI<0 AND YUWEI>REF(YUWEI,1);
资金买:=CROSS(YUWEI,0);

{买点调一:钱袋子}
RSVQD:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
KQD:=SMA(RSVQD,3,1);
DQD:=SMA(KQD,3,1);
JQD:=((3 * KQD) - (2 * DQD));
VARBQD:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VARCQD:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VARDQD:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VAREQD:=(((VARBQD + (2 * VARCQD)) + (3 * VARDQD)) / 6);
VARFQD:=MA(VAREQD,3);
钱袋:=(CROSS(JQD,0) AND (VARFQD <= (0 - 7)));

{买点调一:黄底和蓝底}
PDTC:=((2)*(CLOSE) + HIGH + LOW + OPEN)/(5);
CCIDTC:=((PDTC - MA(PDTC,14))*(100))/((1.5)*(AVEDEV(PDTC,14)));
RSI1DTC:=((SMA(MAX(CLOSE - REF(CLOSE,1),0),6,1))/(SMA(ABS(CLOSE - REF(CLOSE,1)),6,1)))*(100);
黄底:=(CCIDTC < (-100));
蓝底:=(RSI1DTC < 25);

{买点调一:红底}
VAR1MMQZ:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100)/3;
红底:=VAR1MMQZ<-9 AND VAR1MMQZ> REF(VAR1MMQZ,1);
底:=黄底 OR 蓝底 OR 红底;

{买点调一:弱买}
多空平衡线:= EMA(EMA(EMA(HIGH,5),5),4);
弱势反弹线:= 多空平衡线*0.88;
弱买:=C<=弱势反弹线;


TT2TB:=DMA((((HIGH+LOW)+(CLOSE*2))/4.15),0.9);
TT1TB:=REF(EMA(TT2TB,3),1);
RSVTB:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KTB:=SMA(RSVTB,3,1);
DTB:=SMA(KTB,3,1);
JTB:=3*KTB-2*DTB;
{LCTB:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE-LCTB),0),3,1)/SMA(ABS((CLOSE-LCTB)),3,1))*100);}
买入箭头:=CROSS(CLOSE,TT1TB)AND JTB<55;

黑马1:=主力>=散户 AND REF(主力<散户,1) AND COUNT (线下,10)<=2 AND (CLOSE-REF(CLOSE,3))/REF(CLOSE,3)<=0.15;

通条件1:=主力>散户 AND 游资>散户 AND 大户<散户 AND REF(游资<散户,1);
通条件2:=主力>散户 AND 游资>散户 AND 大户>散户 AND REF(大户<散户,1) AND COUNT (游资<散户,3)<=1;
通条件:=通条件1 OR 通条件2;
肯定黑马资条:=COUNT (线下,10)<=1;
黑涨幅:=(CLOSE-REF(CLOSE,9))/REF(CLOSE,9)<=0.14;

肯定黑马:=通条件 AND COUNT (线下,10)<=1 AND 黑涨幅;

黑马2:=主力<散户 AND 游资>=散户 AND 大户<散户 AND REF(游资<散户,1) AND (CLOSE-REF(CLOSE,10))/REF(CLOSE,10)<=0.28 AND COUNT (线下,10)<=2;

资金买入:=资金买 AND COUNT (线下, 20)<=3 AND 黑涨幅;

小黑马:=游资>=散户 AND 主力>散户 AND 大户<散户 AND COUNT (线下,9)<=1 AND (CLOSE-REF(CLOSE,7))/REF(CLOSE,7)<=0.1;

启动前杀入:=主力>散户 AND 大户<散户 AND 游资<散户 AND REF(主力<散户,1) AND COUNT(线下,6)=0;
主力黑马:=主力>游资 AND 游资>=大户 AND 大户>散户 AND COUNT(线下,10)<=2 AND (CLOSE-REF(CLOSE,7))/REF(CLOSE,7)<=0.04 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=-0.05;
黑马最终启飞:=蓝底 AND COUNT(黑马1,14)>=1 AND COUNT(肯定黑马,14)>=1;
{有的潜在黑马股,连续12天至少有9天资金流入,为“潜在黑马”}
潜在黑马:=COUNT(线下,12)<=1 AND (CLOSE-REF(CLOSE,9))/REF(CLOSE,9)<=0.12;
大黑马:=COUNT(潜在黑马,6)>=5;
总黑马:=黑马1 OR 肯定黑马 OR 黑马2 OR 资金买入 OR 小黑马 OR 启动前杀入 OR 主力黑马 OR 黑马最终启飞 OR 潜在黑马 OR 大黑马;


量比:=V/REF(V,1);
涨幅:=REF(C,1)/REF(C,8);
振幅:=HHV(REF(C,1),12)/LLV(REF(C,1),12);
启动买入点:{COUNT(总黑马,20)>=1 AND }量比>=2.70 AND C>REF(C,1) AND COUNT(REF(C/O>=1.095,1),8)<1 AND 振幅<=1.10 AND C/O>=1 AND 涨幅>=0.9 AND COUNT(REF(C/O>=1.04,1),8)<1 AND COUNT(REF(C/O<=0.95,1),8)<1};
黑马买入点:COUNT(总黑马,20)>=1 AND 量比>=2.70 AND C>REF(C,1);
全仓买入点:=启动买入点 AND 黑马买入点;
DRAWTEXT(全仓买入点,0.5,'!全仓买入'),COLORWHITE;
 

通达信飙升买点副图/选股预警 源码  测试图 主要有启动买入点、黑马买入点两个信号


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号