当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信波段短线副图指标源码(无源码的请下载附件导入)

DRAWGBK(C>0, RGB(0,3,0),RGB(0,0,0),0,'11',0);

Q1:=C-REF(C,1);
 Q2:=100*EMA(EMA(Q1,6),6)/EMA(EMA(ABS(Q1),6),6);
 Q3:=CROSS(EMA(C,13),EMA(C,5));
 Q4:=CROSS(EMA(C,5),EMA(C,13));
 Z1:=L=LLV(L,BARSLAST(Q3)+1);
 Z2:=LLV(L,BARSLAST(Q3)+1);
 Z3:=H=HHV(H,BARSLAST(Q4)+1);
 Z4:=HHV(H,BARSLAST(Q4)+1);
 QA:DRAWLINE(Z1,Z2,Z3,Z4,0),COLOR00004D;
 
Y1:=H=HHV(H,BARSLAST(Q4)+1);
 Y2:=HHV(H,BARSLAST(Q4)+1);
 Y3:=L=LLV(L,BARSLAST(Q3)+1);
 Y4:=LLV(L,BARSLAST(Q3)+1);
 QB:DRAWLINE(Y1,Y2,Y3,Y4,0),COLOR00004D;
 X01:=LLV(Q2,2)=LLV(Q2,7);
 X2:=COUNT(Q2<0,2);
 X3:=CROSS(Q2,MA(Q2,2));
 X4:=REF(QB,1)<REF(QB,2);
 X5:=QA>REF(QB,1);
 买进:(X01 AND X2 AND X3) AND X4 AND X5,COLOR2F2FFF;
 TJ0:=IF(QA<REF(QA,1) AND QB=QA,1,0);
 TJ1:=IF(QB<REF(QB,1) AND QB=QA,1,0);
  持股:IF(QB<REF(QB,1) AND QB<QA,35,0),STICK,COLOR000085,LINETHICK7;
 STICKLINE(QB<REF(QB,1),0,35,2,0),COLOR6C6C00;
 买:IF(REF(TJ1,1)=0 AND TJ1>=1,100,0)STICK,COLOR0000FF;
DRAWICON(买>0,买,38);
卖:IF(REF(TJ0,1)=0 AND TJ0>=1,100,0)COLORFFFF15,STICK;
DRAWICON(卖>0,卖,39);
E:=CROSS(83,RSI);
减:STICKLINE( E,E,50,1,0),COLOR00FF00;
DRAWTEXT(E,54,'S'),COLOR00FF00;

VA1:=HHV(HIGH,9)-LLV(LOW,9);
VA2:=HHV(HIGH,9)-CLOSE;
VA3:=CLOSE-LLV(LOW,9);
VA4:=VA2/VA1*100-70;
VA5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VA6:=(CLOSE+HIGH+LOW)/3;
VA7:=SMA(VA3/VA1*100,3,1);
VA8:=LLV(LOW,34);
VA9:=SMA(VA7,3,1)-SMA(VA4,9,1);
VARA:=IF(VA9>100,VA9-100,0);
VARB:=HHV(HIGH,34);
VARC:=EMA((VA6-VA8)/(VARB-VA8)*100,13);
VARD:=EMA(0.667*REF(VARC,1)+0.333*VARC,2);
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=((VAR2)/(VAR1))*(100)-70;
VAR5:=((CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60)))*(100);
VAR6:=((2)*(CLOSE)+HIGH+LOW)/(4);
VAR7:=SMA(((VAR3)/(VAR1))*(100),3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF((VAR9>100),VAR9-100,0);
VAR11:=HHV(HIGH,34);
B1:=EMA(((VAR6-VAR8)/(VAR11-VAR8))*(100),8);
DRAWKLINE(EMA(B1,5),EMA(B1,5),B1+1,B1);
领先:EMA(B1,5)COLOR000000;
生命线:EMA(VARD,1)COLOR000000;
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
VV:=V1 AND V2 AND V3 AND V4;
A1:=EMA(CLOSE,8);
A2:=EMA(A1,20);
A3:=CROSS(A1,A2);
A4:=A1<EMA(CLOSE,120);
STICKLINE((A3 AND A4)OR(V1 AND V2 AND V3 AND V4),B1*1.03,B1*1.120,1,0),COLORYELLOW;
A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*
SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1),CIRCLEDOT ,COLORFF9900 ;
安全位:=20;
低位转强:IF(CROSS(A5,安全位),50,0),STICK,COLORMAGENTA,LINETHICK2;

开始拉升:IF(CROSS(VARC,生命线) AND VARC>VARD AND VARC<55 AND C>O,50,0),
COLORLIRED,POINTDOT;
A6:=LLV(C,500)=LLV(C,5) AND C/REF(C,1)>(1+9.8/100);
极地上涨:IF(A6,领先,0),COLORGREEN,LINETHICK2;
STICKLINE(开始拉升>0,15,开始拉升*1.01,1,0),COLORBLUE;
STICKLINE((开始拉升>0 AND 开始拉升<400) OR (极地上涨>0 AND 极地上涨<400)
OR (低位转强>0 AND 低位转强<400) OR (低位转强>0),30,开始拉升,1,0),COLORRED;
STICKLINE(开始拉升>0,15,开始拉升*0.6,3,0),COLORBLUE;
STICKLINE(开始拉升>0,15,开始拉升*0.4,3,0),COLOR00FF00;
STICKLINE(开始拉升>0,15,开始拉升*0.2,3,0),COLOR0099CC;
STICKLINE(低位转强>0,15,低位转强*1.01,1,0),COLORMAGENTA;
STICKLINE((低位转强>0)OR(极地上涨>0),15,低位转强*0.4,3,0),COLORYELLOW;
STICKLINE(低位转强>0,15,低位转强*0.2,3,0),COLORFFCC66;
STICKLINE(极地上涨>0,15,极地上涨*1.01,1,0),COLORYELLOW;
_红柱:IF("MACD.MACD">REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),
STICK,COLORRED;
绿柱:IF("MACD.MACD"<REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),
STICK,COLORYELLOW;
_抄底:ABS((CROSS("MACD.DIF","MACD.DEA")
&&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.50,COLORLIMAGENTA;
_DIF:"MACD.DIF",COLORWHITE;
_DEA:"MACD.DEA",COLORYELLOW;
__强度:IF(_DIF>_DEA,_DIF,DRAWNULL),COLORRED,LINETHICK2;
_强度:IF(_DEA<_DIF,_DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
DRAWTEXT(ABS(_抄底)>0,_抄底*1.20,'   抄底'),COLORYELLOW;
DRAWICON(ABS(_抄底)>0,_抄底*1.10,4);
DRAWICON(CROSS(_DIF,_DEA),_DEA,38);
DRAWICON(CROSS(_DEA,_DIF),_DEA,39);

最新:C,COLORFFFFFF,CIRCLEDOT,NODRAW;
 IF(C>=REF(C,1),C,DRAWNULL),COLORRED,CIRCLEDOT,NODRAW;
 AA10:=SUM(AMOUNT,BARSCOUNT(C))/SUM(VOL*100,BARSCOUNT(C));
 BB10:=BETWEEN(C/AA10,C+H,C-H);
 DRAWICON(ISLASTBAR AND C>REF(C,1),C,1);
 DRAWICON(ISLASTBAR AND C<REF(C,1),C,2);

通达信波段短线副图指标源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号