当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信波段启动信号副图无未来 源码(无源码的请下载附件导入)

我只看红色信号,灰色信号有个 FILTERX

{黄金柱}
M:=30;
N1:=15;
AJ:=HHV(H,M)=H;
AJT:=BARSLAST(AJ);
AJ1:=LLV(L,N1)=L;
AJ1T:=BARSLAST(AJ1);
TJ:=HHV(H,M)=H;
TJT:BARSLAST(TJ)NODRAW;
TJ1T:=BARSLAST(AJ1);
{STICKLINE((TJT=0,H,TJ1T=0) AND AJ1 AND FILTERX(AJ1,TJT+1) ,REF(L,TJ1T)
,REF(H,TJT),0,0)COLORBLUE,LINETHICK3;}
OUT:=STICKLINE((TJT=0,H,TJ1T=0) AND AJ1 AND FILTERX(AJ1,TJT+1) ,REF(L,TJ1T)
,REF(H,TJT),0,0),COLORBLUE,LINETHICK3;
STICKLINE(OUT>-100,100,80,4,0),COLORGRAY,LINETHICK2;{深灰色柱}

{DRAWTEXT(OUT,82,'----底'),COLORYELLOW;}

{SVAR1:="SM波段王.NOTEXTVBR4#DAY"=1;
VBR3:=SVAR1;
VBR4:=SVAR1;}
YK:"KDJ.K#MONTH" NODRAW;
YD:"KDJ.D#MONTH" NODRAW;
ZK:"KDJ.K#WEEK" NODRAW;
ZD:="KDJ.D#WEEK" NODRAW;
{YY:="三强引用.KK#MONTH" NODRAW;
ZZ:="三强引用.KK#WEEK" NODRAW;}
日买:="KDJ.K#DAY">"KDJ.D#DAY";
ZXG:=1;
YXG:=1; 
多共振:FILTER(CROSS(日买 AND ZXG AND YXG AND REF(ZK,1)<50,0.5),5)COLORYELLOW, NODRAW;
{XGH:STICKLINE(多共振=1,92,100,4,0)COLORLIRED;
DRAWTEXT(XGH,96,'底'),COLORCYAN;}

{KDJ日金}
日K:="KDJ.K#DAY"(9,3,3);{9/3/3}
日D:="KDJ.D#DAY"(9,3,3);
DRAWICON(日K>日D,0.1,32);
DRAWICON(日K<日D,0.1,2);
DRAWTEXT(ISLASTBAR=1,0.1,'日K');

日DIF:="MACD.DIF#DAY"(12,26,9);{12/26/9}
日DEA:="MACD.DEA#DAY"(12,26,9);
{DRAWICON(日DIF>日DEA,0.2.1,32);
DRAWICON(日DIF<日DEA,0.2,2);
DRAWTEXT(ISLASTBAR=1,0.2,'日M');
{RSI日}
日RSI:="RSI.RSI1#DAY"(5);{5}
{DRAWICON(日RSI>50,0.3,32);
DRAWICON(日RSI<50,0.3,2);
DRAWTEXT(ISLASTBAR=1,0.3,'日R');}

周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
DRAWICON(周K>周D,0.4,13);
DRAWICON(周K<周D,0.4,2);
DRAWTEXT(ISLASTBAR=1,0.4,'周K');
周DIF:="MACD.DIF#WEEK"(12,26,9);{12/26/9}
周DEA:="MACD.DEA#WEEK"(12,26,9);
DRAWICON(周DIF>周DEA,0.5,13);
DRAWICON(周DIF<周DEA,0.5,2);
DRAWTEXT(ISLASTBAR=1,0.5,'周M');
{RSI周}
周RSI:="RSI.RSI1#WEEK"(9);{9}
{DRAWICON(周RSI>50,0.6,13);
DRAWICON(周RSI<50,0.6,2);
DRAWTEXT(ISLASTBAR=1,0.6,'周R');}

{KDJ月金}
月K:="KDJ.K#MONTH"(9,3,3);
月D:="KDJ.D#MONTH"(9,3,3);
{DRAWICON(月K>月D,0.7,33);
DRAWICON(月K<月D,0.7,2);
DRAWTEXT(ISLASTBAR=1,0.7,'月K');}
{MACD月金}
月DIF:="MACD.DIF#MONTH"(12,26,9);{12/26/9}
月DEA:="MACD.DEA#MONTH"(12,26,9);
{DRAWICON(月DIF>月DEA,0.8,33);
DRAWICON(月DIF<月DEA,0.8,2);
DRAWTEXT(ISLASTBAR=1,0.8,'月M');}
{RSI月}
月RSI:="RSI.RSI1#MONTH"(9);{9}
{DRAWICON(月RSI>50,0.9,33);
DRAWICON(月RSI<50,0.9,2);
DRAWTEXT(ISLASTBAR=1,0.9,'月R');}

 

月RSI1:="RSI.RSI1#MONTH"(9),COLORWHITE;
A:=月RSI1>50;
首月R:=CROSS(A>REF(A,1),0.5),COLORLIGRAY,LINETHICK3;
STICKLINE(首月R,100,63,5,0),COLORLIGRAY,LINETHICK3;
{DRAWTEXT(首月R,70.11,'  --月振底'),COLORCYAN;}
月DIF1:="MACD.DIF#MONTH"(12,26,9)COLORYELLOW;
月DEA1:="MACD.DEA#MONTH"(12,26,9)COLORYELLOW;
AA:=月DIF1>月DEA1;
首月M:=CROSS(AA>REF(AA,1),0.5)COLORYELLOW;

{DRAWTEXT(首月M,86,'  --月共振'),COLORWHITE;}
月K1:="KDJ.K#MONTH"(9,3,3),COLORMAGENTA;
月D1:="KDJ.D#MONTH"(9,3,3),COLORMAGENTA;
AAA:=月K1>月D1;
首月K:=CROSS(AAA>REF(AAA,1),0.5),COLORMAGENTA,LINETHICK3;

周RSI1:="RSI.RSI1#WEEK"(9),COLORGREEN;
AAAA:=周RSI1>50;
首周R:=CROSS(AAAA>REF(AAAA,1),0.5),COLORRED,LINETHICK4;
STICKLINE(首周R,10.05,21,5,0),COLORRED,LINETHICK4;

通达信波段启动信号副图无未来 源码
 


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号