当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信短期量能评定副图指标公式源码(无源码的请下载附件导入)

通达信短期量能评定副图指标公式源码

VOL,VOLSTICK;
股价:=VOL;
短3:=XMA(XMA(股价,3),3),LINETHICK0,COLORWHITE;
短5:=XMA(XMA(股价,5),5),LINETHICK0,COLORWHITE;
短6:=XMA(XMA(股价,6),6),LINETHICK0,COLORWHITE;
短7:=XMA(XMA(股价,8),8),LINETHICK0,COLORWHITE;
短8:=XMA(XMA(股价,10),10),LINETHICK0,COLORWHITE;
短9:=XMA(XMA(股价,12),12),LINETHICK0,COLORWHITE;
短中:=(短7+短8+短9+短3+短5+短6)/6,LINETHICK0,COLORWHITE;
短顶:=短中*1.35,LINETHICK0,COLORGREEN;
短底:=短中*0.65,LINETHICK0,COLORGREEN;

中1:=XMA(XMA(股价,16),16),LINETHICK0,COLORWHITE;
中2:=XMA(XMA(股价,19),19),LINETHICK0,COLORWHITE;
中3:=XMA(XMA(股价,22),22),LINETHICK0,COLORWHITE;
中4:=XMA(XMA(股价,25),25),LINETHICK0,COLORWHITE;
中5:=XMA(XMA(股价,28),28),LINETHICK0,COLORWHITE;
中6:=XMA(XMA(股价,31),31),LINETHICK0,COLORWHITE;
中中2:=(中1+中2+中3+中4+中5+中6)/6,LINETHICK0,COLORGREEN;
中顶2:=中中2*1.4,LINETHICK0,COLORGREEN;
中底2:=中中2*0.6,LINETHICK0,COLORGREEN;

中40:=XMA(XMA(股价,40),40),LINETHICK0;
中50:=XMA(XMA(股价,50),50),LINETHICK0;
中60:=XMA(XMA(股价,60),60),LINETHICK0;
中中3:=(中40+中50+中60)/3,LINETHICK0,COLORWHITE;
中顶3:=中中3*1.5,LINETHICK0,COLORRED;
中底3:=中中3*0.5,LINETHICK0,COLORRED;

长90:=XMA(XMA(股价,90),90),LINETHICK0,COLORWHITE;
长120:=XMA(XMA(股价,120),120),LINETHICK0,COLORWHITE;
长150:=XMA(XMA(股价,150),150),LINETHICK0,COLORWHITE;
长中:=(长90+长120+长150)/3,LINETHICK0,COLORYELLOW;
长顶:=长中*1.3,LINETHICK1,COLORWHITE;
长顶顶:=长中*1.8,LINETHICK1,COLORRED;
长底:=长中*0.5,LINETHICK1,COLORYELLOW;

MA短中:=EMA(短中,10),LINETHICK0,COLORWHITE;
MA中中2:=EMA(中中2,10),LINETHICK0,COLORGREEN;

 

V2:=IF(CURRBARSCOUNT=1,VOL*240/FROMOPEN/REF(VOL,1)-1,VOL/REF(VOL,1)-1),NODRAW,COLORRED;
STICKLINE(V2>=1,0,VOL,2,0),COLORYELLOW;
VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,-1,-1),COLOR00C0C0;
VOLUME:=VOL,VOLSTICK;

{没问题}

大底VOL:=短底<中底2 AND 中底2<中底3 AND 中底3<长底 AND MA(C,18)>=MA(C,50),LINETHICK5,COLORRED;
中底VOL:=短底<中底2 AND 中底2>中底3 AND 中底2<长底,LINETHICK2,COLORGREEN;
小底VOL:=短底<中底2 AND 中底2<中底3 AND 中底2>长底,LINETHICK1,COLORYELLOW;

STICKLINE(中中2>MA中中2,0,VOL,3,0),COLORFF00FF;{画粉柱}
STICKLINE(短中>MA短中,0,VOL,3,0),COLORRED;
STICKLINE(中中2<MA中中2,0,VOL,3,0),COLORFFFF00;
STICKLINE(V=LLV(V,55) AND 股价<长底,0,VOL,3,0),COLORYELLOW;
NOTEXT攻击量:EMA(V,60),COLORYELLOW;DRAWRECTREL(0,40,90,270,RGB(178,34,34));
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)>=5 ,0,0.1,0,'    短期量能评定:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)>=5 ,0,0.1,0,'                                强'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)>=3 AND COUNT(V>EMA(V,60),7)<5,0,0.1,0,'    短期量能评定:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)>=3 AND COUNT(V>EMA(V,60),7)<5 ,0,0.1,0,'                                中'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)<3 ,0,0.1,0,'    短期量能评定:'),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1 AND COUNT(V>EMA(V,60),7)<3 ,0,0.1,0,'                                弱'),COLORGREEN;
 

通达信短期量能评定副图指标公式源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号