当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信决策曲线简洁版副图指标公式源码决策曲线简洁版(无源码的请下载附件导入)

通达信决策曲线简洁版副图指标公式源码

MA1:=MA(CLOSE,5);

MA2:=MA(CLOSE,10);

P01:=IF(MA1>MA2,2,IF(MA2>MA1,(-2),0));

MA3:=MA(CLOSE,3);

MA4:=MA(CLOSE,5);

P02:=IF(MA3>MA4,2,IF(MA4>MA3,(-2),0));

MA5:=MA(CLOSE,12);

MA6:=MA(CLOSE,50);

P03:=IF(MA5>MA6,2,IF(MA6>MA5,(-2),0));

RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;

K:=EMA(RSV,3);

D:=EMA(K,3);

P04:=IF(K>D,2,IF(D>K,(-2),0));

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

P05:=IF(DIF>DEA,2,IF(DEA>DIF,(-2),0));

TR2:=EMA(EMA(EMA(CLOSE,12),12),12);

TRIX:=(TR2-REF(TR2,1))/REF(TR2,1)*100;

MATRIX:=MA(TRIX,9);

P06:=IF(TRIX>MATRIX,2,IF(MATRIX>TRIX,(-2),0));

TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),7);

HD:=HIGH-REF(HIGH,1);

LD:=REF(LOW,1)-LOW;

DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),7);

DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),7);

PDI:=DMP*100/TR1;

MDI:=DMM*100/TR1;

ADX:=EMA(ABS(MDI-PDI)/(MDI+PDI)*100,7);

ADXR:=EMA(ADX,7);

P07:=IF(PDI>MDI AND ADX>PDI AND ADX>50,3,IF(PDI<MDI AND ADX>MDI AND ADX>50,(-3),0));

LC:=REF(CLOSE,1);

RSI1:=EMA(MAX(CLOSE-LC,0),5)/EMA(ABS(CLOSE-LC),5)*100;

P08:=IF(RSI1>80,2,IF(RSI1<20,(-2),0));

TYP:=(HIGH+LOW+CLOSE)/3;

CCI:=(TYP-MA(TYP,8))/(0.015*AVEDEV(TYP,8));

P09:=IF(CCI>180,2,IF(CCI<(-180),(-2),0));

WR1:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;

P10:=IF(WR1>80,2,IF(WR1<20,(-2),0));

OSC:=100*(CLOSE-MA(CLOSE,20));

P11:=IF(OSC>0,2,IF(OSC<0,(-2),0));

MOM:=CLOSE-REF(CLOSE,7);

P12:=IF(MOM>0,2,IF(MOM<0,(-2),0));

DPO:=CLOSE-REF(MA(CLOSE,11),11/2+1);

P13:=IF(DPO>0,1,IF(DPO<0,(-1),0));

MB:=MA(CLOSE,12);

R:=(CLOSE-MB)*(CLOSE-MB);

X1:=MA(R,12);

X2:=SQRT(X1);

D1:=1;

UPPERB:=MB+D1*X2;

LOWERB:=MB-D1*X2;

P14:=IF(CLOSE>UPPERB,2,IF(CLOSE<LOWERB,(-2),0));

BR:=SUM(MAX(0,HIGH-REF(CLOSE,1)),14)/SUM(MAX(0,REF(CLOSE,1)-LOW),14)*100;

AR:=SUM(HIGH-OPEN,14)/SUM(OPEN-LOW,14)*100;

P15:=IF(BR>350 OR AR>180,3,IF(BR<45 OR AR<45,(-3),0));

TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),14);

TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),14);

TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),14);

VR:=100*(TH*2+TQ)/(TL*2+TQ);

P16:=IF(VR>350,3,IF(VR<45,(-3),0));

WVAD:=SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,6)/10000;

P17:=IF(WVAD>0,1,IF(WVAD<0,(-1),0));

VOLUME:=MA(VOL,4)/VOL;

MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);

EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,4),4);

P18:=IF(EMV>0,1,IF(EMV<0,(-1),0));

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

MAOBV:=EMA(OBV,24);

P19:=IF(OBV>MAOBV,1,IF(OBV<MAOBV,(-1),0));

PVI:=AMV.AMV1;

MPVI:=EMA(PVI,24);

P20:=IF(PVI>MPVI,1,IF(PVI<MPVI,(-1),0));

NVI:=ZX.AV;

MNVI:=EMA(NVI,24);

P21:=IF(NVI>MNVI,2,IF(NVI<MNVI,(-2),0));

MASS:=SUM(MA(HIGH-LOW,9)/MA(MA(HIGH-LOW,9),9),25);

MA7:=MA(CLOSE,9);

P22:=IF(MA7>REF(MA7,1) AND MASS>26.5,2,IF(MA7<REF(MA7,1) AND MASS<26.5,(-2),0));

NUM:=ABS(HHV(HIGH,15)-LLV(LOW,15));

DEN:=SUM(ABS(CLOSE-REF(CLOSE,1)),15);

VHF:=IF(DEN=0,0,NUM/DEN);

VHF1:=EMA(VHF,240);

P23:=IF(VHF>VHF1,1,IF(VHF<VHF1,(-1),0));

PU:=MA(CLOSE,13);

CU:=MA(VOL,13);

PU1:=(PU-REF(PU,1))/REF(PU,1)*100;

CU1:=(CU-REF(CU,1))/REF(CU,1)*100;

逆时针曲线:=PU1+CU1;

P24:=IF(逆时针曲线>REF(逆时针曲线,1),1,IF(逆时针曲线<REF(逆时针曲线,1),(-1),0));

LC2:=REF(CLOSE,1);

AA:=ABS(HIGH-LC2);

BB:=ABS(LOW-LC2);

CC:=ABS(HIGH-REF(LOW,1));

DD:=ABS(LC2-REF(OPEN,1));

R2:=IF(AA>BB AND AA>CC,AA+BB/2+DD/4,IF(BB>CC AND BB>AA,BB+AA/2+DD/4,CC+DD/4));

X01:=CLOSE-LC2+(CLOSE-OPEN)/2+LC2-REF(OPEN,1);

SI:=16*X01/R2*MAX(AA,BB);

ASI:=SUM(SI,0);

MASI:=MA(ASI,6);

P25:=IF(CLOSE<HHV(CLOSE,13) AND ASI=HHV(ASI,13),1,IF(CLOSE>LLV(CLOSE,13) AND ASI=LLV(ASI,13),(-1),0));

BIAS1:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

P26:=IF(BIAS1>10,1,IF(BIAS1<(-10),(-1),0));

A:=VOL*CLOSE/10000;

IUV:=EXPMEMA(A,30);

MA6C:=EMA(IUV,6);

P27:=IF(IUV>MA6C,1,IF(IUV<MA6C,(-1),0));

N1:=30;

N2:=30;

MMM:=6;

RES1:=MA(CLOSE,N1);

RES2:=MA(AMOUNT,N2);

SOURCE1:=(AMOUNT/RES2-1)*100-(CLOSE/RES1-1)*100;

SOURCE2:=MA(SOURCE1,N2);

REF1:=REF(SOURCE2,1);

REF2:=REF(SOURCE1,N2);

IUSV:=(REF1*N2-REF2+SOURCE1)/N2;

EMA6B:=EMA(IUSV,MMM);

P28:=IF(IUSV>EMA6B,1,IF(IUSV<EMA6B,(-1),0));

决策曲线:=ROUND((P01+P02+P03+P04+P05+P06+P07+P08+P09+P10+P11+P12+P13+P14+P15+P16+P17+P18+P19+P20+P21+P22+P23+P24+P25+P26+P27+P28)/1.5+50);


 TDXSTEP286:STICKLINE(CLOSE>0,36,36,10,0),COLORLICYAN;

TDXSTEP287:STICKLINE(CLOSE>0,44,44,10,0),COLORLICYAN;

TDXSTEP288:STICKLINE(CLOSE>0,56,56,10,0),COLORLICYAN;

TDXSTEP289:STICKLINE(CLOSE>0,71,71,10,0),COLORLICYAN;

ER:=EXPMA(决策曲线,20);


决策曲线JC:决策曲线,COLORWHITE;


决策曲线JC强:IF(决策曲线>56,决策曲线,DRAWNULL),COLORRED;

通达信决策曲线简洁版副图指标公式源码决策曲线简洁版

通达信决策曲线简洁版副图指标公式源码决策曲线简洁版


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号