当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信唐能通主图/选股指标源码贴图(无源码的请下载附件导入)

{唐能通主图}
DRAWBAND(MA(C,20),RGB(90,0,0),MA(C,60),RGB(0,90,0));{牛熊变线}

变线:=EMA(MA(CLOSE,20),5),LINETHICK0;
 STICKLINE(C>=变线 AND C>=O,H,L,0,0),COLORRED;
 STICKLINE(C>=变线 AND C>=O,C,O,2.7,1),COLORRED;
 STICKLINE(C>变线 AND C<=O,H,L,0,1),COLORCYAN;
 STICKLINE(C>变线 AND C<=O,C,O,3,0),COLORCYAN;
 STICKLINE(C<变线 AND C<=O,H,L,0,1),COLORCYAN;
 STICKLINE(C<变线 AND C<=O,C,O,3,0),COLORCYAN;
 STICKLINE(C<变线 AND C<=O,H,L,0,1),COLORGREEN;
 STICKLINE(C<变线 AND C>O,H,L,0,1),COLORRED;
 STICKLINE(C<变线 AND C>O,C,O,3,1),COLORGRAY;
 STICKLINE(C<变线 AND C<=O,C,O,3,0),COLORGRAY;
 PM:MA(C,5),COLORWHITE,LINETHICK1;
 IF(PM<REF(PM,1),PM,DRAWNULL),COLORGREEN,POINTDOT;
 IF(PM>=REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
 IF(PM=REF(PM,1),PM,DRAWNULL),COLORRED,LINETHICK2;
 A:=MA(CLOSE,12)+ABS(MA(CLOSE,12)-REF(MA(CLOSE,12),1));
 B:=MA(CLOSE,12)+MA(CLOSE,12)-REF(MA(CLOSE,12),1);

分水岭:=IF(MA(CLOSE,12)<B,B,MA(CLOSE,12));
操作线:=分水岭-(EMA(C,3)-分水岭),COLORLIRED,LINETHICK2,DOTLINE;

AA:=CROSS(分水岭,操作线);
STICKLINE(AA,C,O,3,0),COLOR0000AA;
 STICKLINE(AA,C,O,2,0),COLOR0033CC;
 STICKLINE(AA,C,O,1,0),COLOR0055EE;
 STICKLINE(AA,C,O,0.3,0),COLOR0099FF;
 STICKLINE(AA,H,L,0,1),COLOR0099FF;
 RR:=CROSS((MA(VOL,5)),(MA(VOL,10))) AND MA(C,2)>=MA(C,4);
 STICKLINE(RR,C,O,3,0),COLOR0000AA;
 STICKLINE(RR,C,O,2,0),COLOR0033CC;
 STICKLINE(RR,C,O,1,0),COLOR0055EE;
 STICKLINE(RR,C,O,0.3,0),COLOR0099EE;
 STICKLINE(RR,H,L,0,1),COLOR0099FF;
 MA5:MA(CLOSE,5),NODRAW;
 MA10:MA(CLOSE,10),COLORYELLOW;
 MA20:MA(CLOSE,20),COLORMAGENTA,LINETHICK2;
 MA60:MA(CLOSE,60),COLORGREEN,LINETHICK2;
 MA120:MA(C,120),COLORRED;
 DRAWTEXT(CROSS(MA20,MA60),MA20,'牛'),COLORYELLOW,LINETHICK4;
 DRAWTEXT(CROSS(MA60,MA20),MA20,'熊'),COLORWHITE,LINETHICK2;
 {唐能通主图AAA}
 {突破买入}
N1:=5;
 N2:=7;
 N3:=11;
 EM1:=EMA(C,N1),COLORWHITE;
 EM2:=EMA(C,N2),COLORRED;
 EM3:=EMA(C,N3),COLORGREEN;

TJ:=BETWEEN(EM2,EM1,EM3);
 IF(MA(C,20)>REF(MA(C,20),1),MA(C,20),DRAWNULL)COLORRED,LINETHICK3;
立桩量:=FILTER(TJ=0,5);
价:REF(H,BARSLAST(立桩量)),NODRAW;
 STICKLINE(C,REF(H,BARSLAST(立桩量)),REF(H,BARSLAST(立桩量)),6,0),COLORGREEN;
 DRAWTEXT(C AND ISLASTBAR,价,'突破买入(立桩量价)'),COLORMAGENTA,DRAWABOVE;

{倍量 AND 突破前高}
SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);
 SR2:=FILTER(SR1,10);
 SR3:=BACKSET(SR2,10+1);
 HD:=FILTER(SR3,10);
前高:=REF(H,BARSLAST(HD));
倍量:=VOL/REF(VOL,1)>=1.9;
突破前高:=CROSS(C,前高);
DRAWICON(倍量 AND 突破前高,L*0.99,34);


月价托:=MA5>MA20 AND MA20>MA60 AND MA60>MA120 AND MA5>MA20 AND CROSS(MA10,MA20);
月蜘蛛:=MA5>MA10 AND MA10>MA20 AND CROSS(MA5,MA20)AND CROSS(MA10,MA20);
死蜘蛛:=MA5<MA10 AND MA10<MA20 AND CROSS(MA20,MA5)AND CROSS(MA20,MA10);
 DRAWTEXT(月蜘蛛,MA20-0.08,'金蜘蛛'),COLORMAGENTA;
 DRAWTEXT(死蜘蛛,MA20+0.20,'死蜘蛛'),COLORGREEN;

DRAWTEXT(月价托 ,MA20-0.12,'月价托'),COLORYELLOW;
 AA1:=BARSLAST(MA60>MA20 AND (MA20=MA10 OR MA20>MA10));
 BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);
 CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
芙蓉出水:=BB AND CC1,COLOR00FF00;
 DRAWTEXT(芙蓉出水,H+0.12,'芙蓉出水'),COLORFF00FF;
 STICKLINE(芙蓉出水,H,L,0.5,1),COLORFF00FF;
 STICKLINE(芙蓉出水,O,C,3,1),LINETHICK2,COLORFF00FF;
 MA1:=MA(CLOSE,5);
 MA2:=MA(CLOSE,10);
 MA3:=MA(CLOSE,20);
 ZJ:=AMOUNT/10000;
 TM:=V-MA(V,10);


 {压力一阳线高}
TY:=C;
 A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HHD:=FILTER(C1,10);
 A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LLD:=FILTER(C2,10);
前期高位:REF(C,BARSLAST(HHD)),COLOR00FF00,POINTDOT;{前期阳线实顶线}
STICKLINE(C,前期高位,前期高位,8,0),COLORYELLOW;
 DRAWTEXT(前期高位 AND ISLASTBAR,前期高位,'前期阳线实顶'),COLORYELLOW,DRAWABOVE;

通达信唐能通主图/选股指标源码贴图

通达信唐能通主图/选股指标源码贴图


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号