当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信黄金分割及分割区域选股公式主图 源码(无源码的请下载附件导入)

黄金分割及分割区域选股

附件所有公式不加密,里有
 黄金分割主图

风险区选股

低吸区选股

关注区选股

突破区选股

 黄金分割主图,源码是:

VAR1:=C>REF(C,1)AND C>REF(C,2);

VAR2:=REF(VAR1,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR3:=REF(VAR2,1)AND C>=REF(C,1)AND C<=REF(C,2);

VAR4:=REF(VAR3,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR5:=REF(VAR4,1)AND C>=REF(C,1)AND C<=REF(C,2);

VAR6:=REF(VAR5,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR7:=REF(VAR6,1)AND C>=REF(C,1)AND C<=REF(C,2);

VAR8:=REF(VAR7,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR9:=REF(VAR8,1)AND C>=REF(C,1)AND C<=REF(C,2);

VARA:=REF(VAR9,1)AND C<=REF(C,1)AND C>=REF(C,2);

VARB:=REF(VARA,1)AND C>=REF(C,1)AND C<=REF(C,2);

VARC:=REF(VARB,1)AND C<=REF(C,1)AND C>=REF(C,2);

VARD:=C<REF(C,1)AND C<REF(C,2);

VARE:=REF(VARD,1)AND C>=REF(C,1)AND C<=REF(C,2);

VARF:=REF(VARE,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR10:=REF(VARF,1)AND C>=REF(C,1)AND C<=REF(C,2);

VAR11:=REF(VAR10,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR12:=REF(VAR11,1)AND C>=REF(C,1)AND C<=REF(C,2);

VAR13:=REF(VAR12,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR14:=REF(VAR13,1)AND C>=REF(C,1)AND C<=REF(C,2);

VAR15:=REF(VAR14,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR16:=REF(VAR15,1)AND C>=REF(C,1)AND C<=REF(C,2);

VAR17:=REF(VAR16,1)AND C<=REF(C,1)AND C>=REF(C,2);

VAR18:=REF(VAR17,1)AND C>=REF(C,1)AND C<=REF(C,2);

VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;

VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;

BTSTS:=BARSLAST(VAR19);

红:=VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

VAR8 OR VAR9 OR VARA OR VARB OR VARC;

STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

VAR8 OR VAR9 OR VARA OR VARB OR VARC,C,REF(C,1),2,1)COLORRED;{红1}

STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR

VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,C,REF(C,1),2.1,0)COLORCYAN;{青色}

STICKLINE(VAR19,REF(C,1),REF(C,2),2.1,1),COLORYELLOW;{黄色}

STICKLINE(VAR1A,REF(C,1),REF(C,2),2.1,2)COLORCYAN;{青色}

STICKLINE(VAR19,REF(C,1),REF(C,2),2.1,0),COLORYELLOW;{黄色}

STICKLINE(VAR1A,REF(H,1),REF(C,2),2.1,0)COLORBLUE;{蓝色};

STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR

VAR8 OR VAR9 OR VARA OR VARB OR VARC AND

(C/REF(C,1)>1.0985 AND C=H),C,REF(C,1),1,0)COLORMAGENTA;{板红1};             

N:=120;

K:=BARSLAST(CURRBARSCOUNT=N);

GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));{高点}

DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));{低点}

KJ:=GD-DD;

GD4:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL);

高区:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLORRED,LINETHICK2;

低区:IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,LINETHICK2;

平衡:=IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;

低:IF(CURRBARSCOUNT<=N/2,DD,DRAWNULL),COLORFFFF00;

高:IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL),COLOR00FFFF;

支撑:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.191,DRAWNULL),COLOR00FFFF;

强势: IF(CURRBARSCOUNT<=N/2,DD+KJ*0.382,DRAWNULL),COLORFF00FF;

突破:IF(CURRBARSCOUNT<=N/2,DD+KJ/2,DRAWNULL),COLOR0000FF;

警示:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.618,DRAWNULL),COLOR00FFFF;

压力:IF(CURRBARSCOUNT<=N/2,DD+KJ*0.809,DRAWNULL),COLOR00FF00;

低涨:IF(CURRBARSCOUNT<=N/2,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;

天数:BARSLAST(L=DD),COLORCYAN,NODRAW;

顶点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST

(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,CROSSDOT;

低点:IF(CURRBARSCOUNT<=N/2, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST

(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,CROSSDOT;

STICKLINE(CCI>=200 AND H>=顶点,O,C,2,0),COLORBLUE;

STICKLINE(CCI<=100 AND L<=低点,O,C,2,0),COLORYELLOW;

STICKLINE(CURRBARSCOUNT=N,GD,DD,0,0),COLORGREEN;

STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,0),COLOR408080;

STICKLINE(CURRBARSCOUNT=1,GD,DD,0,0),COLORGREEN;

STICKLINE(CURRBARSCOUNT<=N/2,支撑,支撑,2,0),COLORFF00FF;

STICKLINE(CURRBARSCOUNT<=N/2,强势,强势,2,0),COLORFF00FF;

STICKLINE(CURRBARSCOUNT<=N/2,突破,突破,2,0),COLORABABAB;

STICKLINE(CURRBARSCOUNT<=N/2,警示,警示,2,0),COLOR00FFFF;

STICKLINE(CURRBARSCOUNT<=N/2,压力,压力,2,0),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=10,压力,'压力-0.809'),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=10,警示,'警示-0.618'),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=10,突破,'突破-0.500'),COLORFFFFFF;

DRAWTEXT(CURRBARSCOUNT=10,强势,'强势-0.382'),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=10,支撑,'支撑-0.191'),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.09,'【风险区】--高抛避险'),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.3,'【警示区】--逢高减仓'),COLOR0000FF;

DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.45,'【突破区】--主力拉升'),COLORFFFFFF;

DRAWTEXT(CURRBARSCOUNT=N/4+5,GD-KJ*0.55,'【拉升区】--强势畜锐'),COLORFFFF80;

DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/3,'【关注区】--逢低买入'),COLOR00FFFF;

DRAWTEXT(CURRBARSCOUNT=N/4+5,DD+KJ/10,'【低吸区】--大胆买入'),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=N/2+40,GD-KJ*0.25,'【拉升区】'),COLORRED;

DRAWTEXT(CURRBARSCOUNT=N/2+40,DD+KJ*0.25,'【持股区】'),COLORYELLOW;

第一防线:REFDATE(低,DATE),POINTDOT,COLORYELLOW,LINETHICK4;

第二防线:REFDATE(支撑,DATE),POINTDOT,COLORWHITE,LINETHICK4;

AHC1:=CLOSE*VOL;

AHC22:=EMA((EXPMA(AHC1,27)/EXPMA(VOL,27)+EXPMA(AHC1,54)/EXPMA(VOL,54)+EXPMA

(AHC1,108)/EXPMA(VOL,108)+EXPMA(AHC1,316)/EXPMA(VOL,316))/4,34);

上轨:=1.06*AHC22,COLOR40FF00,LINETHICK1;

下轨:=AHC22*0.94;

ZT:=REF(C,1)*1.1-C<0.01 AND H=C;

启爆:=CROSS(C,上轨) OR CROSS(C,下轨) AND ZT;

DRAWTEXT(启爆,L,'启爆'),COLORCYAN;

STICKLINE(启爆,C,O,3,1),COLORWHITE;

STICKLINE(启爆,C,O,1,0),COLORRED;
通达信黄金分割及分割区域选股公式主图 源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号