当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信黑马趋势主升浪绝技副图指标公式源码贴图 无未来(无源码的请下载附件导入)

M:=7;
 EMA13:=EMA(C,13);
 EMA30:EMA(C,30),COLORFFCCCC;
 HJ_1:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
 HJ_2:=SMA(SMA(HJ_1,3,1),3,1)/28.57;
 HJ_3:=EMA(HJ_2,5);
 HJ_4:=3*HJ_2-2*HJ_3;
 HJ_5:=CROSS(HJ_4,HJ_2) AND HJ_2<2.1 AND CLOSE>OPEN;
 EMA60:EMA(C,60),COLORFF00FF;
 EMA90:EMA(C,90),COLORYELLOW;
 STICKLINE(HJ_5,82,0,0.005,0),COLORRED;
 DRAWICON(HJ_5>0,85,13),COLORYELLOW;
 EMA120:EMA(C,120),COLORFFCC66;
 EMA250:EMA(C,250),COLORBLUE;
 HJ_6:=CROSS(HJ_4,HJ_2) AND HJ_2<2.1 AND CLOSE>OPEN;
 HJ_7:=(2*CLOSE+HIGH+LOW)/4;
 HJ_8:=LLV(LOW,13);
 A1:3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,
 1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);
黑马线:EMA(A1,5),LINETHICK2,COLOR6600FF;
 HJ_9:=HHV(HIGH,13);
 HJ_10:=EMA((HJ_7-HJ_8)/(HJ_9-HJ_8)*100,13);
 F1:=EMA30-EMA60<130/1000 AND EMA30-EMA90<230/1000 AND EMA30-EMA120<330/1000;
 F2:=EMA60-EMA30<130/1000 AND EMA60-EMA90<230/1000 AND EMA60-EMA120<330/1000;
 HJ_11:=EMA(0.667*REF(HJ_10,1)+0.333*HJ_10,2);
 HJ_12:=HJ_10;
 F3:=EMA90-EMA30<130/1000 AND EMA90-EMA60<230/1000 AND EMA90-EMA120<330/1000;
 F4:=EMA120-EMA30<130/1000 AND EMA120-EMA60<230/1000 AND EMA120-EMA90<330/1000;
 F5:=EMA30-EMA60<100/1000 AND EMA30-EMA90<200/1000;
 STICKLINE(HJ_10>HJ_11,HJ_10,HJ_11,3,0),COLOR0055AA;
 STICKLINE(HJ_10>HJ_11,HJ_10,HJ_11,2.8,0),COLOR0066BB;
 STICKLINE(HJ_10>HJ_11,HJ_10,HJ_11,2.5,0),COLOR0077CC;
 A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
 A3:=EMA(C,5);
 STICKLINE(HJ_10>HJ_11,HJ_10,HJ_11,2.2,0),COLOR0088DD;
 STICKLINE(HJ_10>HJ_11,HJ_10,HJ_11,1.7,0),COLOR0099EE;
 STICKLINE(HJ_10>HJ_11,HJ_10,HJ_11,1.2,0),COLOR00AAFF;
 FF1:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA30,EMA60);
 FF2:=F1 AND F2 AND F3 AND F4 AND CROSS(EMA(C,13),EMA30);
 FF3:=F5 AND C>EMA250 AND CROSS(EMA30,EMA60);
 STICKLINE(HJ_10>HJ_11,HJ_10,HJ_11,0.7,0),COLOR00CCFF;
 STICKLINE(HJ_10>HJ_11,HJ_10,HJ_11,0.2,0),COLORYELLOW;
 STICKLINE(HJ_10<=HJ_11,HJ_10,HJ_11,3,0),COLOR990099;
 STICKLINE(HJ_10<=HJ_11,HJ_10,HJ_11,2.8,0),COLOR990088;
 STICKLINE(HJ_10<=HJ_11,HJ_10,HJ_11,2.5,0),COLOR990077;
 G1:=EMA60-EMA90<220/1000 AND EMA60-EMA120<320/1000 AND EMA60-EMA250<420/1000;
 G2:=EMA90-EMA30<220/1000 AND EMA90-EMA60<320/1000 AND EMA90-EMA250<420/1000;
 STICKLINE(HJ_10<=HJ_11,HJ_10,HJ_11,2.2,0),COLOR990066;
 STICKLINE(HJ_10<=HJ_11,HJ_10,HJ_11,1.7,0),COLOR990055;
 STICKLINE(HJ_10<=HJ_11,HJ_10,HJ_11,1.2,0),COLORBB00BB;
 STICKLINE(HJ_10<=HJ_11,HJ_10,HJ_11,0.7,0),COLORDD00DD;
 STICKLINE(HJ_10<=HJ_11,HJ_10,HJ_11,0.2,0),COLORMAGENTA;
 G3:=EMA120-EMA60<220/1000 AND EMA120-EMA90<320/1000 AND EMA120-EMA250<420/1000;
 G4:=EMA250-EMA60<220/1000 AND EMA250-EMA90<320/1000 AND EMA250-EMA120<420/1000;
 DRAWTEXT(HJ_6,78,5),COLORCYAN;
 HJ_13:=10;
 GG1:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA13,EMA30);
 GG2:=G1 AND G2 AND G3 AND G4 AND CROSS(EMA30,EMA60);
底部区域:20,COLORLIRED;
中轨:50,COLORYELLOW;
高位:80,COLORLIBLUE;
启动:EMA(0.382*REF(HJ_10,2)+0.618*HJ_10,6),COLORRED;
 A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线:(MA(3*SMA(A4,6,1)-2*SMA(SMA(A4,5,1),5,1),2)),LINETHICK2,COLORYELLOW;
 IF(启动>REF(启动,1),启动,DRAWNULL),COLORRED,LINETHICK4;
 IF(启动<REF(启动,1),启动,DRAWNULL),COLORLIBLUE,LINETHICK2;
 DRAWICON(FF1 OR FF2 OR FF3 OR GG1 OR GG2,L-0.1,9);
 VAR1:=EMA(SMA((CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100,8,1),3);
买入:IF(CROSS(4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,
 5,1)-3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,
 1),3,1),8),58,0),STICK,COLORYELLOW,LINETHICK3;
 A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
 STICKLINE(买入,50,0,3.5,0),COLORGREEN;
 STICKLINE(买入,50,0,3.4,0),COLORGREEN;
 STICKLINE(买入,50,0,3.1,0),COLORGREEN;
 STICKLINE(VAR1>20 AND VAR1<80,VAR1,VAR1,10,1),COLORRED;
 STICKLINE(VAR1<REF(VAR1,1),VAR1,VAR1,10,1),COLORFFCC66;
 STICKLINE(买入,50,0,2.8,0),COLOR009900;
 STICKLINE(买入,50,0,2.5,0),COLOR009900;
 STICKLINE(买入,50,0,2,0),COLOR009900;
 STICKLINE(买入,50,0,1.5,0),COLOR00BB00;
 STICKLINE(VAR1>80,VAR1,VAR1,8,1),COLOR00FF00;
 STICKLINE(VAR1<20,VAR1,VAR1,8,1),COLORYELLOW;
 STICKLINE(买入,50,0,0.9,0),COLOR00DD00;
 STICKLINE(买入,50,0,0.3,0),COLORGREEN;
 STICKLINE(买入,50,0,0.05,0),COLORYELLOW;
 DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A2<0,7),黑马线,'跑'),COLOR00FF00;
 www.gszx.com.cnCLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
 DRAWTEXT(CROSS(A1,黑马线)AND 黑马线<A5,黑马线,'黑马');
DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,5,'大黑马');
DRAWICON(买入>0,58,34),COLORYELLOW;
 DRAWTEXT(买入,45,2),COLOR66FFCC;
主升浪:IF(WINNER(C*0.9)*100-V/CAPITAL*100>=25,10,0),COLORYELLOW,POINTDOT;
 STICKLINE(主升浪,10,0,1,1),COLORYELLOW;
 HJ_14:=REF(CLOSE,1);
 HJ_15:=SMA(MAX(CLOSE-HJ_14,0),6,1)/SMA(ABS(CLOSE-HJ_14),6,1)*100;
 HJ_16:=CROSS(70,HJ_15)*70;
底部:(A2<-10 AND A2>REF(A2,1))*25,COLORRED;
 DRAWICON(底部 AND A3>REF(A3,1),25,4);
 DRAWTEXT(HJ_16,80,3),COLORRED;
 DRAWTEXT_FIX(1,0.61,0.9,1,4),COLORRED;
通达信黑马趋势主升浪绝技副图指标公式源码贴图 无未来


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号