当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信超级MACD副图指标 源码(无源码的请下载附件导入)

优化后的超级MACD指标看的更清楚

 超级MACD指标
{MACD}
 DIF:EMA(CLOSE,6)-EMA(CLOSE,19),,NODRAW;
 DEA:EMA(DIF,9),NODRAW;
 MACD:2*(DIF-DEA),COLORSTICK;
 STICKLINE(MACD>0,MACD,0,0.5,0),COLORRED;
 STICKLINE(MACD<0,MACD,0,0.5,0),COLORGREEN;
 STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLORWHITE;
 STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.5,0),COLORFF00FF;
 FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
 FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
 FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
 FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;
 FH5:=FH1 AND FH2 AND MACD<0.10;
 VV:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30)
 AND DIF>DEA AND MACD>REF(MACD,1) AND DIF>0 AND DEA>0 AND
 MA(VOL,5)>MA(VOL,34) AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1);
佛手:IF(VV,1,0),NODRAW;
 {二次起动}
X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));
 X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0+1)=X0+1));{回}
X2:=COUNT(MACD<REF(MACD,1),X1+1)=X1+1 AND COUNT(MACD<0,X1+1)<=2;
 X3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);
 STICKLINE(X1=0 AND MACD>0,MACD,0,2,0),COLORDCDC00;{MACD缩头}
STICKLINE(X3,MACD,0,2,0),COLOR0854FF;{二次起动};
DRAWICON(佛手,-0.15,11);
二次翻红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;
低买:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;
加油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;
 DRAWICON(二次翻红,-0.05,1);
 DRAWTEXT(二次翻红,-0.15,'↖翻红'),COLORRED;
 DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低买'),COLORFF00FF;
 DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖加油'),COLORYELLOW;
 XG:二次翻红 OR 低买 OR 加油,NODRAW;
 YLZC:=IF(CLOSE=INDEXC,(INDEXC+INDEXH+INDEXL+INDEXO)/4,AMOUNT/(VOL+0.01)/100);
阻价:=IF(CLOSE=INDEXC,YLZC+INDEXC-INDEXL,YLZC+(CLOSE-LOW));
支价:=IF(CLOSE=INDEXC,INDEXL+INDEXC-YLZC,LOW+(CLOSE-YLZC));
今压:REF(阻价,1),LINETHICK0,COLORAA11BB,NODRAW;
今撑:REF(支价,1),LINETHICK0,COLOR009900,NODRAW;
明压:阻价,LINETHICK0,NODRAW;
明撑:支价,LINETHICK0,NODRAW;
 DIFF:DIF,COLORRED,LINETHICK2;
 DDEA:DEA,COLORYELLOW,LINETHICK2;


通达信超级MACD副图指标 源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号