当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是MACD将死不死优化(源码,副图及选股预警,通达信)无未来(无源码的请下载附件导入)

MACD将死不死优化(源码,副图选股预警通达信)无未来

自己使用的MACD指标经过优化后将MACD指标将死不死买入信号写出预警公式,与喜欢的有缘人分享,指标发出预警信号后,要筛选其中的强势板块中的强势股操作,零下金叉的信号要结合其他因素综合判断后再操作,不少人拿到选股指标选出股票后不假思索的就操作,结果不赚钱就埋怨,写指标的人骗人或者说指标不准;殊不知你啥也不懂,盲目的操作那是在赌博。不要迷信指标的成功率!!!成功率95%的指标,你买到那5%,照样赔钱,你连续15次都赔钱,你还相信那95%吗?所以说预警出信号后一定要筛选,开句玩笑,煮米饭还有淘米呢,吃鱼还要去鱼鳞呢。
需要注意的是免费的软件在计算MACD指标是参数值只取0.01,所以有的个股选出来后附图没有提示,用眼睛判断就可以了。

 


{将死不死}

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2;
NH:=REF(DIF,3)>=REF(DIF,2) AND REF(DIF,2)>=REF(DIF,1) AND DIF>REF(DIF,1)*1.1;
NH1:=ABS((REF(DIF,1)-REF(DEA,1))/REF(DIF,1))<=0.2;
DT:=REF(DIF,2)>REF(DEA,2) AND REF(DIF,1)>=REF(DEA,1) AND DIF>DEA;
NLZ:=MACD>REF(MACD,1) AND DIF>0;
NLZ1:=MACD>REF(MACD,1) AND DIF<0;
将死不死1:=(NH1 AND NH AND DT AND NLZ);
将死不死0:=(NH1 AND NH AND DT AND NLZ1);
将死不死:将死不死1 OR 将死不死0;


{MACD副图}
DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED,LINETHICK2;
DEA:EMA(DIF,9),COLORBLUE,LINETHICK2;
MACD:(DIF-DEA)*2,COLORSTICK,COLORMAGENTA;
STICKLINE(((MACD<REF(MACD,1)) AND (MACD>0)),0,MACD,0.05,0),COLORLIBLUE,LINETHICK2;
STICKLINE(((MACD>REF(MACD,1)) AND (MACD<0)),0,MACD,0.05,0),COLORFF00FF,LINETHICK2;
DRAWICON(CROSS(DIF,DEA),DIF+0.025,1);
DRAWICON(CROSS(DEA,DIF),DIF+0.025,2);
NH:=REF(DIF,3)>=REF(DIF,2) AND REF(DIF,2)>=REF(DIF,1) AND DIF>REF(DIF,1)*1.1;
NH1:=ABS((REF(DIF,1)-REF(DEA,1))/REF(DIF,1))<=0.2;
DT:=REF(DIF,2)>REF(DEA,2) AND REF(DIF,1)>=REF(DEA,1) AND DIF>DEA;
NLZ:=MACD>REF(MACD,1) AND DIF>0;
NLZ1:=MACD>REF(MACD,1) AND DIF<0;
将死不死1:=(NH1 AND NH AND DT AND NLZ);
将死不死0:=(NH1 AND NH AND DT AND NLZ1);
将死不死:将死不死1 OR 将死不死0,NODRAW;
DRAWTEXT(将死不死,DIF,'不死')LINETHICK5,COLORBLUE;
DRAWICON(将死不死,DEA-0.01,38);
DRAWICON(将死不死,DEA-0.03,38);

 

MACD将死不死优化(源码,副图及选股预警,通达信)无未来

 

MACD将死不死优化(源码,副图及选股预警,通达信)无未来


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号