当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信双龙出海主图指标不加密(无源码的请下载附件导入)

V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

V2:=(1-7/100)*(DMA(CLOSE,V1));
 V3:=(1+7/100)*(DMA(CLOSE,V1));
 V5:=MA((LOW+HIGH+CLOSE)/3,5);
托:REFDATE(V2,DATE),LINETHICK2,COLORCC66FF;
压:REFDATE(V3,DATE),LINETHICK2,COLORGREEN;
 VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
 VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
 VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
 VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
 VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR
 VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
 DRAWICON(VAR19,L*0.98,38),COLORYELLOW;
 VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR
 VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
 DRAWICON(VAR1A,H*1.01,39),COLOR00FF00{98FD};
 MA3:MA(C,3);
 MA5:MA(C,5),COLORWHITE;
 MA10:=MA(C,10),NODRAW;
 MA30:MA(C,34),NODRAW;
五日乖离率:=(C-MA5)/MA5*100;
 BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;
 IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORRED;
 BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
 IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK1,COLORGREEN;
 DD5:=MA5<REF(MA5,1);
 IF(DD5,MA5,DRAWNULL),COLOR00FF00;
 X:=(3*C+L+O+H)/6;
海平面:(20*X+19*REF(X,1)+18*REF(X,2)+17*REF(X,3)+16*REF(X,4)+15*REF(X,5)+14*REF(X,6)
 +13*REF(X,7)+12*REF(X,8)+11*REF(X,9)+10*REF(X,10)+9*REF(X,11)+8*REF(X,12)
 +7*REF(X,13)+6*REF(X,14)+5*REF(X,15)+4*REF(X,16)+3*REF(X,17)+2*REF(X,18)+
 REF(X,20))/210,COLORFFFF00,LINETHICK2;
 {用法:黄托底买进,绿压顶买出。}
DD:=海平面<REF(海平面,1);
 IF(DD,海平面,DRAWNULL),COLORBLUE,LINETHICK2;
 A:=(MA5>海平面);
IF(A,海平面,DRAWNULL),COLORYELLOW,POINTDOT;
 A1:=(MA5<海平面);
IF(A1,海平面,DRAWNULL),COLORWHITE;
 A2:=3*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5)-2*EMA((C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*100,5);
 A4:=(HHV(H,34)-C)/(HHV(H,34)-LLV(L,34))*100;
 A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
 A6:=EMA(A5,9);
 A7:=(A5<-0.1 AND A5>A6);
龙王:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;
 CYS:=(EMA((CLOSE-V2)/V2,1)*100);
 AA:=CYS;
 MIDD:=MA(CYS,20);
 CC:=MIDD+0.85*STD(CYS,10);
 TM6:=AA>CC;
 IF(TM6,MA5,DRAWNULL),COLORRED,LINETHICK1;
 A0:=(L+H+C*2)/4;
工作:=EMA(A0,14)COLORYELLOW,LINETHICK1;
度假:=EMA(A0,25)COLORYELLOW,LINETHICK1;
 A1X:=(工作-REF(工作,1))/REF(工作,1)*100;
 A2X:=(度假-REF(度假,1))/REF(度假,1)*100;
 G:=BARSLAST(CROSS(A1X,0));
 {KDJ}
 RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
 K:=SMA(RSV,3,1);
 D:=SMA(K,3,1);
 J:=3*K-2*D;
金叉:=CROSS(J,D);
死叉:=CROSS(D,J);
买1:=(VAR14 OR VAR15) AND VAR11;
买2:=(VAR14 OR VAR15) AND VAR4;
买3:=(VAR14 OR VAR15) AND VAR2;
买4:=(VAR2 AND VAR11) OR (VAR4 AND VAR11);
买5:=(金叉 AND VAR4) OR (金叉 AND VAR2) OR (金叉 AND VAR11);
 {涨停}
STICKLINE(CLOSE>REF(CLOSE,1)*1.0985 AND CLOSE=HIGH,CLOSE,OPEN,4,-1),COLOR00FFFF;
 {跌停}
STICKLINE(CLOSE<REF(CLOSE,1)*0.9015 AND CLOSE=LOW,CLOSE,OPEN,4,-1),COLORGREEN;
 {蓝}
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF7700;
 STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;
 STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;
 STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.5,0),COLORCYAN;

通达信双龙出海主图指标不加密

通达信双龙出海主图指标不加密


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号