当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信主图价托量托副图源码(无源码的请下载附件导入)

 通达信主图价托量托副图源码

{公式在线提供:www.gszx.com.cn}

{刘剑价托主图源码}
 {M18  0  1000   18}
 {M30  0  1000   30}
 {M1   0  1000    5}
 {M2   0  1000    10}
 {M3   0  1000   20}
 {M4   0  1000    40}
 {M5   0   1000   60}
 {M6   0   1000   120}
 {M7   0   1000   250}
 
MA18:MA(CLOSE,M18);
 MA30:=MA(CLOSE,M30);
 MA1:=MA(CLOSE,M1);
 MA2:=MA(CLOSE,M2);
 MA3:=MA(CLOSE,M3);
 MA4:=MA(CLOSE,M4);
 MA5:=MA(CLOSE,M5);
 MA6:=MA(CLOSE,M6);
 MA7:=MA(CLOSE,M7);
 DTPL:=MA3>MA30 AND MA30>MA6;
 QSXS:=MA30>REF(MA30,1);
 BDGD:=C=HHV(CLOSE,10);
 GDSJ:=BARSLAST(BDGD);
 前高:=IF(GDSJ>0,REF(C,GDSJ),REF(C,GDSJ)),POINTDOT,COLOR00FF00,LINETHICK0;
 TP:=CROSS(C,REF(前高,1));
 突破:=TP AND COUNT(TP,5)=1,POINTDOT,COLORFF00FF,LINETHICK0;
 TPSJ:=BARSLAST(突破);
 HC:=CROSS(REF(前高,TPSJ+1),L) OR CROSS(REF(前高,TPSJ),C);
 回踩:=HC AND TPSJ>1,POINTDOT,COLOR00FF00,LINETHICK0;
 优选:=(HC AND TPSJ>1 AND DTPL AND QSXS)*2,POINTDOT,COLORYELLOW,LINETHICK0;
 {以下设置主图显示方式}
 STICKLINE(突破,(O+C)/2,(O+C)/2,4,1),COLORFF00FF;
 STICKLINE(突破,H,L,0,0),COLORFF00FF;
 DRAWTEXT(突破,L,'突破'),COLORFF00FF;
 DRAWTEXT(回踩,L,'回踩'),COLOR00FF00;
 DRAWICON(优选,L*0.98,1);
 AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
 AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
 AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
 BB1:=0;{公式在线提供:www.gszx.com}
 B1万元:=DVOL*DCLOSE/100;
 B1差:=B1万元-REF(B1万元,1);
 B2万元:=DVOL*DCLOSE/100;
 B2比:=B2万元/REF(B2万元,1);
 净流入万元:=(AAA2-AAA3-0.5*AAA4);
 PM:=MA(净流入万元,1);
 PMA:=PM/REF(PM,1)>1;
 PMB:=REF(PMA,1)<1 AND PMA;
密电:(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
 二日比:=密电/REF(密电,1);
 选股:PMB AND 密电>REF(密电,1) AND 二日比>1,COLORRED,NODRAW;
 DRAWNUMBER(选股=1 ,L,密电),COLORYELLOW;
 DRAWICON(选股,L*0.975,1);
 月价托:=MA1>MA3 AND MA1>MA2 AND CROSS(MA2,MA3),COLORYELLOW ;
 季价托:=MA3>MA5 AND MA3>MA4 AND CROSS(MA4,MA5),COLORLIMAGENTA ;
 短、长价托:=MA5>MA5 AND MA1>MA2 AND CROSS(MA2,MA5),COLORRED;
 DRAWTEXT(月价托,H+0.2,'月价托'),COLORYELLOW;
 STICKLINE(月价托,L,H,0.5,1), COLORYELLOW;
 STICKLINE(月价托,O,C,5,1),LINETHICK3, COLORYELLOW;
 DRAWTEXT(季价托,H+0.3,'季价托'),COLORWHITE;
 STICKLINE(季价托,L,H,0.5,1), COLORLIMAGENTA;
 STICKLINE(季价托,O,C,5,1),LINETHICK3, COLORLIMAGENTA;
 
{量托副图源码}
 MA5:=MA(CLOSE,5);
 MA10:=MA(CLOSE,10);
 MA20:=MA(CLOSE,20);
 MA40:=MA(CLOSE,40);
 MA60:=MA(C,60);
 MA120:=MA(C,120);
 MA250:=MA(C,250),COLORYELLOW;
 VOL1:=MA(VOL,5),COLORWHITE;
 VOL2:=MA(VOL,10),COLORYELLOW;
 VOL3:=MA(VOL,20),COLORFF00FF ;
 月量托:VOL1>=VOL3 AND CROSS(VOL2,VOL3) AND REF(VOL2,1)<REF(VOL3,1),COLORYELLOW;
 DRAWTEXT(月量托,L,'▲'),COLORYELLOW;
 DRAWTEXT(月量托,L*0.97,'月量托'),COLORYELLOW;
 STICKLINE(月量托,L,H,0.5,1), COLORYELLOW;
 STICKLINE(月量托,O,C,5,1),LINETHICK3, COLORYELLOW;
 AA:=BARSLAST(MA60>MA40 AND (MA40=MA20 OR MA40>MA20));
 BB:=REF(COUNT(C<MA60,AA)=AA,1);
 CC:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;
 芙蓉出水:BB AND CC,COLOR00FF00;
 DRAWTEXT(芙蓉出水,H*1.05,'★'),COLOR00FF00;
 DRAWTEXT(芙蓉出水,H*1.02,'芙蓉出水'),COLOR00FF00;
 STICKLINE(芙蓉出水,H,L,0.5,0),COLOR00FF00;
 STICKLINE(芙蓉出水,O,C,5,0),COLOR00FF00,LINETHICK2;
 VOL4:=MA(VOL,20),COLORWHITE;
 VOL5:=MA(VOL,40),COLORYELLOW;
 VOL6:=MA(VOL,60),COLORFF00FF ;
 季量托:VOL4>=VOL6 AND CROSS(VOL5,VOL6) AND REF(VOL5,1)<REF(VOL6,1),COLORWHITE;
 DRAWTEXT(季量托,L,'▲'),COLORWHITE;
 DRAWTEXT(季量托,L*0.97,'季量托'),COLORWHITE;
 STICKLINE(季量托,L,H,0.5,1), COLORWHITE;
 STICKLINE(季量托,O,C,5,1),LINETHICK3, COLORWHITE; 

价托主图 量托副图 源码
 





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 2009-2010 gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识