当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信高低区间指标副图源码测试图(无源码的请下载附件导入)

N:=120;
 N8:=STRCAT(CON2STR(YEAR,0), '年' );
Y8:=STRCAT(CON2STR(MONTH,0),' 月' );
 R8:=STRCAT(CON2STR(DAY,0),' 日' );
K:=BARSLAST(CURRBARSCOUNT=N);
 GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));
 DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));
 KJ:=GD-DD;
 SJ8:=STRCAT(STRCAT(N8,Y8), R8);
 GD4:=IF(CURRBARSCOUNT<=N/2,GD,DRAWNULL);
 DRAWBAND(GD4,RGB(0,0,250),DD+KJ/2,RGB(0,0,0));平衡:IF(CURRBARSCOUNT<=N,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
压力:IF(CURRBARSCOUNT<=N,GD-KJ*0.191,DRAWNULL),COLORFF00FF,NODRAW;
支撑:IF(CURRBARSCOUNT<=N,DD+KJ*0.191,DRAWNULL),COLOR00FF00,NODRAW;
低吸:IF(CURRBARSCOUNT<=N/2 AND CROSS(平衡,LOW),1,DRAWNULL),COLORFF8899,NODRAW;
低涨:IF(CURRBARSCOUNT<=N,(C/LLV(LOW,K)-1)*100,DRAWNULL),COLOR0000FF,NODRAW;
天:BARSLAST(L=DD),COLOR00FFFF,NODRAW;
 MA11:MA(CLOSE,5),COLORFFFFFF;
 MA21:MA(CLOSE,10),COLOR00FFFF;
 MA55:MA(C,20),COLORFF00FF;
 MA144:MA(C,144),COLORFF00FF;
 DRAWTEXT_FIX(C>0,0.5,0,0,SJ8),COLOR00FFFF;
高:IF(CURRBARSCOUNT<=N,GD,DRAWNULL),COLOR00FFFF,POINTDOT;
低:IF(CURRBARSCOUNT<=N,DD,DRAWNULL),COLOR00FF00,POINTDOT;
 STICKLINE(CURRBARSCOUNT=N,GD,DD,0,-1),COLORGREEN;
 STICKLINE(CURRBARSCOUNT=N/2,GD,DD,0,-1),COLORGREEN;
 STICKLINE(CURRBARSCOUNT=1,GD,DD,0,-1),COLORGREEN;
 STICKLINE(CURRBARSCOUNT<=N,平衡,平衡,3,-1),COLORWHITE;
 STICKLINE(CURRBARSCOUNT<=N/2,压力,压力,3,-1),COLORRED;
 STICKLINE(CURRBARSCOUNT<=N/2,支撑,支撑,3,-1),COLORGREEN;
 DRAWTEXT(CURRBARSCOUNT=1,压力,0.809),COLOR0000FF;
 DRAWTEXT(CURRBARSCOUNT=1,平衡,0.500),COLORFFFFFF;
 DRAWTEXT(CURRBARSCOUNT=1,支撑,0.191),COLOR00FFFF;
 DRAWTEXT(CURRBARSCOUNT=N/2+9,GD-KJ/12,'★ 强势区域—急拉减仓!'),COLORRED;
 DRAWTEXT(CURRBARSCOUNT=N/2+9,GD-KJ/3,'● 震荡整理—寻机低吸!'),COLORFFFF00;
 DRAWTEXT(CURRBARSCOUNT=N/2+9,DD+KJ/3,'◆ 反弹中轨—逢高休息!'),COLOR00FFFF;
 DRAWTEXT(CURRBARSCOUNT=N/2+9,DD+KJ/10,'■ 弱势区域—暂不参与!'),COLOR00FF00;
 DRAWTEXT(CURRBARSCOUNT=N,GD-KJ/12,'■ 目前K线天数:请看参数!'),COLOR0000FF;
 DRAWTEXT(CURRBARSCOUNT=N,压力,'■ 建议查阅K线:短线30天,中长线120天!'),COLORFF8899;
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
 TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
 DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
 DRAWRECTREL(0,CONST(950-(ABS(大宗进)*250/DAZHIV))-20,30,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));
 DRAWRECTREL(32,CONST(950-(ABS(大宗出)*250/DAZHIV))-20,62,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));{www.guhai.com.cn}
 DRAWRECTREL(92,CONST(950-(ABS(非大宗进)*250/DAZHIV))-20,122,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));
 DRAWRECTREL(124,CONST(950-(ABS(非大宗出)*250/DAZHIV))-20,154,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));
 DRAWTEXT_FIX(CURRBARSCOUNT=1,0.005,1,0,'主力 进出'),COLORMAGENTA;
 DRAWTEXT_FIX(CURRBARSCOUNT=1,0.097,1,0,'散户 进出'),COLORCYAN;


通达信高低区间指标副图源码测试图


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号