当前位置:→ 股票公式指标网 > 通达信公式 > 正文 

以下是通达信预测明天涨跌指标源码(无源码的请下载附件导入)

P1:=5;
 P2:=10;
 P3:=20;
 P4:=30;
 P5:=60;
 P6:=120;
 P7:=240;
 P8:=340;
 N:=4;
 WX:=MA(CLOSE,0);
 M1:=MA(CLOSE,P1);
 M2:=(MA(CLOSE,P2) * IF((N < 2),WX,1));
 M3:=(MA(CLOSE,P3) * IF((N < 3),WX,1));
 M4:=(MA(CLOSE,P4) * IF((N < 4),WX,1));
 M5:=(MA(CLOSE,P5) * IF((N < 5),WX,1));
 M6:=(MA(CLOSE,P6) * IF((N < 6),WX,1));
 M7:=(MA(CLOSE,P7) * IF((N < 7),WX,1));
 M8:=(MA(CLOSE,P8) * IF((N < 8),WX,1));
 C1:=REF(CLOSE,1);
 C2:=HHV(C1,2);
 C3:=LLV(C1,1);
 ET:=HHV(C1,2);
 ET1:=REF(ET,1);
 XB:=LLV(C1,1);
 XB1:=REF(XB,1);
 M:=BARSLAST(((CLOSE < XB) AND (C1 >= XB1)));
 M11:=REF(M,1);
 N9:=BARSLAST(((CLOSE > ET) AND (C1 <= ET1)));
 N1:=REF(N9,1);
 M21:=(BARSLAST((((M - N9) > 0) AND (M11 <= N1))) + 1);
 N2:=(BARSLAST((((N9 - M) > 0) AND (N1 <= M11))) + 1);
 ET2:=HHV(ET,M21);
 XB2:=LLV(XB,N2);
 A:=IF((((M - N9) > 0) AND (M11 <= N1)),1,IF((((N9 - M) > 0) AND (N1 <= M11)),0,2));
 H1:=IF(((M - N9) > 0),CLOSE,ET2);
 H2:=IF((A = 1),CLOSE,C2);
 H3:=IF(((M - N9) < 0),CLOSE,XB2);
 H4:=IF((A = 1),CLOSE,XB2);
 H5:=IF((((M - N9) > 0) OR (A = 1)),CLOSE,H3);
 H6:=REF(H5,1);
 H7:=REF(H5,2);
 H8:=(H5 > H6);
 H9:=(((H4 = REF(H4,1)) AND (REF(H4,1) < REF(H4,2))) AND (H5 > REF(H5,2)));
 H10:=(((H2 = REF(H2,1)) AND (H4 = REF(H4,1))) AND (H5 = REF(H5,2)));
 W:=((H8 OR H9) OR H10);
 T9:=((H5 < H6) AND (H5 < REF(H5,2)));
 T10:=((H4 = REF(H4,1)) AND (H5 < REF(H5,2)));
 T11:=((H3 > REF(H3,1)) AND (H5 < REF(H5,1)));
 T12:=((H5 = REF(H5,1)) AND (H3 = H4));
 T13:=((H2 = REF(H2,1)) AND (H2 = H5));
 TW:=((((T9 OR T10) OR T11) OR T12) OR T13);
 PK:=((AMOUNT * (((OPEN + CLOSE) + HIGH) + LOW)) / 4);
 PK1:=IF((VOL > 0),(PK / AMOUNT),((((OPEN + CLOSE) + HIGH) + LOW) / 4));
 BBP:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) * 100);
 STICKLINE((ISLASTBAR AND W),(H5 * 1.025),(H5 * 0.99),0.5,0),COLORFF8800;
 STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,8,0),COLOR102088;
 STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,7,0),COLOR102099;
 STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,6,0),COLOR1020AA;
 STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,5,0),COLOR1020BB;
 STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,4,0),COLOR1020CC;
 STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,3,0),COLOR1020DD;
 STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,2,0),COLOR1020EE;
 STICKLINE((ISLASTBAR AND W),(H5 * 1.02),H5,1,0),COLOR1020FF;
 DRAWTEXT((ISLASTBAR AND (BBP >= 96.5)),(H5 * 1.022),'明见\N 短高\N 龙头\N 除外'),COLORRED;
 DRAWTEXT((ISLASTBAR AND (BBP < 1)),((H5 + H4) / 1.96),'明见\N 短低\N 跌停\N 除外'),COLORGREEN;
 DRAWTEXT(((ISLASTBAR AND W) AND (BBP < 96.5)),(H5 * 1.022),'明日\N 看涨'),COLORYELLOW;
 DRAWTEXT(((ISLASTBAR AND TW) AND (BBP > 1)),((H5 + H4) / 2),'明日\N 看跌'),COLORGREEN;

通达信预测明天涨跌指标源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号