当前位置:→ 公式网 > 通达信公式 > 正文 

以下是趋势划线(源码 主图 趋势和黄金分割两套选股)(无源码的请下载附件导入)

趋势划线(源码 主图 趋势和黄金分割两套选股

指标构思
这套指标是先找出最近N周期(可自行修改周期)从左往右的远高点,再找到今天向右N周期的近高点。将两点连线后,对突破黄色趋势线和枚红色黄金分割618位置进行选股。
远高点和近高点水平画线不能进行选股,因为如果突破这两条线那么画线将重新画。
黄金618位置是近高点和近高点形成后产生的最低点进行分割。
附件分为主图信号画线和二套选股(趋势选股  黄金分割选股)

这套指标是先找出最近N周期(可自行修改周期)从左往右的远高点,再找到今天向右N周期的近高点。将两点连线后,对突破黄色趋势线和枚红色黄金分割618位置进行选股。
远高点和近高点水平画线不能进行选股,因为如果突破这两条线那么画线将重新画。
我这里参数设置为60日。
意思从左向右60天的高点为起点,从右向左60天内的高点为终点画趋势线。您可以自由设置N就可以改变画线
黄金618位置是近高点和近高点形成后产生的最低点进行分割。
指标只是参考,选股和参数还需要各自琢磨!!
{主图信号}

N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH);
LL:=CONST(REF(L,JD));
黄金线:IF(CURRBARSCOUNT<=CONST(JH)+1,(CONST(DH)-CONST(LL))*0.618+CONST(LL),DRAWNULL),DOTLINE,COLORMAGENTA;
IF(CURRBARSCOUNT<=CONST(JH)+1,CONST(DH),DRAWNULL),DOTLINE,COLORLIRED;
IF(CURRBARSCOUNT<=CONST(YH)+1,CONST(HH),DRAWNULL),DOTLINE,COLORYELLOW;
EXT1:DRAWLINE(QD,H,ZD,H,1),DOTLINE,COLORYELLOW;
STICKLINE(QD,H,L,0,0),COLORYELLOW;
STICKLINE(QD,C,O,2,0),COLORYELLOW;
STICKLINE(ZD,H,L,0,0),COLORLIRED;
STICKLINE(ZD,C,O,2,0),COLORLIRED;
DRAWTEXT(CURRBARSCOUNT=CONST(YH)+10,CONST(HH),VARCAT(VARCAT('远高价',VAR2STR(CONST(HH),2)),'元')),COLORYELLOW;
DRAWTEXT(ZD,H*1.02,VARCAT(VARCAT('近高价',VAR2STR(H,2)),'元')),COLORLIRED;
DRAWICON(CROSS(C,EXT1) AND CURRBARSCOUNT<CONST(JH)+1,L,1);
DRAWICON(CROSS(C,黄金线) AND CURRBARSCOUNT<CONST(JD)+1,L,25);


{突破黄金线选股}
N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH) ;
LL:=CONST(REF(L,JD));
黄金线:=IF(CURRBARSCOUNT<=CONST(JH)+1,(CONST(DH)-CONST(LL))*0.618+CONST(LL),DRAWNULL);
CROSS(C,黄金线) AND CURRBARSCOUNT<CONST(JD)+1;

 

{突破黄色趋势线选股}
N:=60;
JH:=HHVBARS(H,N);
YH:=BARSLAST(H=HHV(H,N));
QD:=CURRBARSCOUNT=CONST(YH)+1;
ZD:=CURRBARSCOUNT=CONST(JH)+1;
HH:=REF(H,YH);
DH:=REF(H,JH);
JD:=LLVBARS(L,JH) ;
LL:=CONST(REF(L,JD));
EXT1:=DRAWLINE(QD,H,ZD,H,1);
CROSS(C,EXT1) AND CURRBARSCOUNT<=CONST(JH)+1;

趋势划线(源码 主图 趋势和黄金分割两套选股)

趋势划线(源码 主图 趋势和黄金分割两套选股)


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号