当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信资金动能源码副图贴图以及选股公式(无源码的请下载附件导入)

{资金动能-副图}
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趋势:=(MA((C-HY1)*28,2))*0.1;
操盘4:STICKLINE(多空趋势>=0 AND 多空趋势>=REF(多空趋势,1),24,24+多空趋势,1.5,0),COLORRED;
减仓4:STICKLINE(多空趋势>=0 AND 多空趋势< REF(多空趋势,1),24,24+多空趋势,1.5,0), COLORYELLOW;
反弹4:STICKLINE(多空趋势<0 AND 多空趋势>=REF(多空趋势,1),24,22+多空趋势,1.5,0),COLORBLUE;
寻底4:STICKLINE(多空趋势<0 AND 多空趋势< REF(多空趋势,1),24,24+多空趋势,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(多空趋势>=0,22,22.3),'  多空'),COLORWHITE;
换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
成交量:V,COLORWHITE,NODRAW;
主力能量:(主力-均量)COLORMAGENTA,NODRAW;
大户能量:(大户-均量)COLORYELLOW,NODRAW;
中户能量:(中户-均量)COLORLIBLUE,NODRAW;
散户能量:(散户-均量)COLORBLUE,NODRAW;
操盘:STICKLINE(主力能量>=0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORRED;
减仓:STICKLINE(主力能量>=0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORYELLOW;
反弹:STICKLINE(主力能量<0 AND 主力能量>=REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORBLUE;
寻底:STICKLINE(主力能量<0 AND 主力能量< REF(主力能量,1),14.4,14.4+主力能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(主力能量>=0,14.4,14.6),'  机构'),COLORMAGENTA;

操盘1:STICKLINE(大户能量>=0 AND 大户能量>=REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORRED;
减仓1:STICKLINE(大户能量>=0 AND 大户能量< REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORYELLOW;
反弹1:STICKLINE(大户能量<0 AND 大户能量>=REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORBLUE;
寻底1:STICKLINE(大户能量<0 AND 大户能量< REF(大户能量,1),9.6,9.6+大户能量,1.5,0),COLORGREEN;
DRAWTEXT(ISLASTBAR=1,IF(大户能量>=0,9.6,9.8),'  大户'),COLORYELLOW;
JZ:=V/(ABS(主力能量)+ABS(大户能量)+ABS(中户能量)+ABS(散户能量));{4,9,17,34日换手偏离值均分成交量}
ZLCJ:=JZ*ABS(主力能量);{4日换手偏离均量值换算当日成交量}
DHCJ:=JZ*ABS(大户能量);{9日换手偏离均量值换算当日成交量}
ZHCJ:=JZ*ABS(中户能量);{17日换手偏离均量值换算当日成交量}
SHCJ:=JZ*ABS(散户能量);{34日换手偏离均量值换算当日成交量};
换手率:VOL/CAPITAL*100,LINETHICK0;
机构量:=ZLCJ,COLORMAGENTA,NODRAW;
大户量:=DHCJ,COLORYELLOW,NODRAW;
中户量:=ZHCJ,COLORLIBLUE,NODRAW;
散户量:=SHCJ,COLORBLUE,NODRAW;

{完}

附:如何提取其中的信息?下面代码是提取头天多空指标或机构指标显示为红色的代码。
提取头天的信号确定,不存在漂移,如果以当天的信号,存在不确定性,所以建议拿头天的信号做参考。
下面的代码你可以加入你的选股公式里面作为一个过滤的条件,也可以作为单独的选股公式,如果想作为一个选股公式最后一句这么写就行了。
ZJDN:多空量能 OR 主力量能;{不要加等号,意思就是输出结果的意思}

{头天资金动能多空指标或机构指标二者之一显示为红色的代码}
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趋势:=(MA((C-HY1)*28,2))*0.1;
多空量能:=REF(多空趋势,1)>=0 AND REF(多空趋势,1)>=REF(多空趋势,2);
换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:=主力-均量;
主力量能:=REF(主力能量,1)>=0 AND REF(主力能量,1)>=REF(主力能量,2);
ZJDN:=多空量能 OR 主力量能;
{OR就是多空量能和主力量能至少一个指标显示红色的意思,如果用AND连接就是要求两者同时为红的意思}

{头天资金动能指标里面:多空指标或机构指标二者之一显示为红色的选股公式}
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趋势:=(MA((C-HY1)*28,2))*0.1;
多空量能:=REF(多空趋势,1)>=0 AND REF(多空趋势,1)>=REF(多空趋势,2);
换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:=主力-均量;
主力量能:=REF(主力能量,1)>=0 AND REF(主力能量,1)>=REF(主力能量,2);
ZJDN:多空量能 OR 主力量能;


{当天资金动能指标里面:多空指标或机构指标二者之一显示为红色的选股公式}
V1:=DMA((((H+L)+(C*2))/4),0.9);
HY1:=REF(EMA(V1,3),1);
多空趋势:=(MA((C-HY1)*28,2))*0.1;
多空量能:=多空趋势>=0 AND 多空趋势>=REF(多空趋势,1);
换手:=V*100/CAPITAL;
主力:=MA(换手,4);
大户:=MA(换手,9);
中户:=MA(换手,17);
散户:=MA(换手,34);
均量:=(主力+大户+中户+散户)/4;
主力能量:=主力-均量;
主力量能:=主力能量>=0 AND 主力能量>=REF(主力能量,1);
ZJDN:多空量能 OR 主力量能;

通达信资金动能源码副图贴图以及选股公式

通达信资金动能源码副图贴图以及选股公式
 


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号