当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是四色图(源码 主图 通达信 贴图)(无源码的请下载附件导入)

四色图(源码 主图 通达信 贴图)

MA1:=EMA(C,12);
MA2:=EMA(C,50);
MA3:=EMA(C,34);
MA4:=EMA(C,7);
MA5:=EMA(C,20);
MA6:=EMA(C,10);
DIFF:=EMA(CLOSE,30)-EMA(CLOSE,120);
DEA:=EMA(DIFF,9);
M1:MA(CLOSE,5),COLORRED,LINETHICK;
M2:EMA(CLOSE,12),COLORRED,LINETHICK;
M3:EMA(CLOSE,50),COLORRED,LINETHICK;
X:=BARSLAST(REF(CROSS(C,MA(C,120)),1)) AND CROSS(MA(C,20),MA(C,120));
IF(M3<REF(M3,1),M3,DRAWNULL),COLORGREEN,LINETHICK;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,H ,L-0.01 ,0 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,H ,L-0.008 ,0 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,2.5 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,2 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,1 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,0 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,H ,L-0.008 ,0 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,2.5 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,2 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,1 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C>=MA2 AND DIFF>=DEA ,O ,C ,0 ,0 ),COLORYELLOW;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,H ,L-0.008 ,0 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C>=MA2 AND DIFF<DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,H ,L-0.008 ,0 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,3 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,2.5 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,2 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,1 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,0 ,0 ),COLORGREEN;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,H ,L-0.008 ,0 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,2.5 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,2 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,1 ,0 ),COLORYELLOW;
STICKLINE(C<MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,0 ,0 ),COLORYELLOW;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,H ,L-0.008 ,0 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,2.5 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,2 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,1 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF>=DEA ,O ,C ,0 ,0 ),COLORRED;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,H ,L-0.008 ,0 ,0 ),COLORMAGENTA;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,2.5 ,0 ),COLORMAGENTA;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,2 ,0 ),COLORMAGENTA;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,1 ,0 ),COLORMAGENTA;
STICKLINE(C>=MA1 AND C<MA2 AND DIFF<DEA ,O ,C ,0 ,0 ),COLORMAGENTA;
VOLUME:=MA(VOL,1)/VOL;
MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);
EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,9),9);
EMVA:=MA(EMV,14);
BB:=EMV-EMVA;
BIAS :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIASMA :=MA(BIAS,6);
CC:=BIAS-BIASMA;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
DD:=(K+D+J)/3;
KK:=J-DD;
DIFF2:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA2:=EMA(DIFF2,9);
SS:=DIFF2-DEA2;
AA:=MA(BB+CC+KK+SS,1)*0.01;

四色图(源码 主图 通达信 贴图)


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号