当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信超准短线及选股源码(无源码的请下载附件导入)

通达信指标超准短线及选股

VARX8:=IF(LLV(LOW,58),1,0);
 A9:= DATETODAY(DATE);DS:=IF(A9<9966,1,DRAWNULL);
筹码短期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,8)/(AMOUNT/VOL/100)/100));
筹码中期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100));
筹码长期:=DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,20)/(AMOUNT/VOL/100)/100));DIF:=EMA(EMA(CLOSE,18)-EMA(CLOSE,34),11);
 XSR:=1150501;XS:=IF(DATE<XSR,1,DRAWNULL);
 MACD:=EMA(EMA(DIF,11),11),COLOR58FF58;
 DEF:=2*(DIF-MACD),COLORFFFF00,LINETHICK0;
 MMS:=((100)*(EMA(EMA(MTM,6),6)))/(EMA(EMA(ABS(MTM),6),6));
 MMM:=((100)*(EMA(EMA(MTM,12),12)))/(EMA(EMA(ABS(MTM),12),12));
 MML:=((100)*(EMA(EMA(MTM,26),26)))/(EMA(EMA(ABS(MTM),26),26));
 VARR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
 VARR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
 VARR3:=(2*CLOSE+HIGH+LOW)/4;{70822.com}
 VARR4:=LLV(LOW,26);
 VARR5:=HHV(HIGH,34);
 VARR6:=EMA((VARR3-VARR4)/(VARR5-VARR4)*100,16);
 VARR7:=SMA((SMA(VARR2,3,1)+3),3,1),LINETHICK3;
 VARR8:=EMA(VARR6,7);
 VARR9:=SMA(VARR1,3,1);
 VARR10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
 VARR11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
 VARR12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
 VARR13:=(VARR10+VARR11+VARR12)/3;
 VARR14:=IF(VARR13<=-20,10,0);
 VARR15:=HHV(VARR14,10);
 VARR24:=LLV(LOW,36);
 VARR25:=HHV(HIGH,30);
 VARR26:=EMA((CLOSE-VARR24)/(VARR25-VARR24)*4,4)*25;
 VARB27:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100)/2+22)*1;
 VARB28:=(((CLOSE -(((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) / (((EMA(AMOUNT,13) /EMA(VOL,13)) / 100))) * 100);
 VARB29:=IF(A9<15366,1,DRAWNULL);
 AA05:=MA(C,5);
 AA30:=MA(C,30);
 MA05:=MA(C,5);
 MA10:=MA(C,13);
 MA30:=MA(C,34);
 BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;
 BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;
 BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1)*XS;
加速度5:=EMA((速度5-REF(速度5,1)),3)*VARB29;
五日乖离率:=(C-AA05)/AA05*VARB29*100*DS;
三拾日乖离率:=(C-MA30)/MA30*100*VARB29;
 MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10)*XS;
 STICKLINE(买入,(LOW)*(0.99000001),0,6,0)*XS*VARB29,COLORRED;
 VAR1:=EMA(HHV(HIGH,500),21);
 VAR2:=EMA(HHV(HIGH,250),21);
 VAR3:=EMA(HHV(HIGH,90),21);
 VAR4:=EMA(LLV(LOW,500),21);
 VAR5:=EMA(LLV(LOW,250),21);
 VAR6:=EMA(LLV(LOW,90),21);
 VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
 VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
 VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
 VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
 VARB:=REF(LOW,1);
 VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
 VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC/10),3);
 VARE:=LLV(LOW,30);
 VARF:=HHV(VARD,30);
 VAR10:=IF(MA(CLOSE,58),1,0);
 DRAWTEXT(A9>15298,LOW,"(CLOSE-LC)*VID;LONG := SUM(RC,0)2)))*100);RC := (CLOSE-LC)*VID;LONG := SUM(RC,0);
 DIFF := SMA(LONG,10,1);DEA := SMA(LONG,2
 0,1);LON : DIFF-DEA; (CLOSE-LC)*VID;LONG := SUM(RC,0)");

{
选股公式:

AA30:=MA(C,30);
 MA30:=MA(C,34);
 A9:= DATETODAY(DATE);DS:=IF(A9<9966,1,DRAWNULL);
 VARB29:=IF(A9<15366,1,DRAWNULL);
 AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*VARB29*100*DS;
三拾日乖离率:=(C-MA30)/MA30*100*VARB29;
 MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10)*XS;
 STICKLINE(买入,(LOW)*(0.99000001),0,6,0)*XS*VARB29,COLORRED;
 }
 

 


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号