当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信趋势大王主图源码 贴图(无源码的请下载附件导入)

MA7:=MA(H,7)*0.99,COLORMAGENTA;
空线:MA(C,25),COLORGREEN;
 AA:=空线>REF(空线,1);
多线:IF(AA,空线,DRAWNULL),COLORRED;
 N:=MA(CLOSE,34);
 F1:=REF(L,1)=LLV(L,30) AND REF(C>O*1.2,1) AND L>REF(L,1);
 F2:=BARSLAST(F1);
 F3:=COUNT(CROSS(C,空线),F2) AND AA AND CROSS(C,空线);
DRAWICON(F3,L,9);
 MA77:=H>MA7 AND O<MA7 AND MA7>REF(MA7,1) AND REF(MA7>REF(MA7,1),2) AND REF(MA7>空线,2) AND 空线>REF(空线,1) AND MA7>空线 AND O/空线<1.036 AND MA7/空线<1.036 AND DYNAINFO(4)!=0 ;
 STICKLINE(C>=N AND C>=O,C,O,2.8,0),COLORRED;
 STICKLINE(C>=N AND C>=O,H,L,0,0),COLORRED;
 STICKLINE(C>=N AND C<O,C,O,2.8,1),COLORRED;
 STICKLINE(C>=N AND C<O,O,H,0,0),COLORRED;
 STICKLINE(C>=N AND C<O,C,L,0,0),COLORRED;
 STICKLINE(C<N AND C>O,C,O,2.8,1),COLORFFFF00;
 STICKLINE(C<N AND C<=O,C,O,2.8,1),COLORFFFF00;
 STICKLINE(C<N AND C<=O,H,L,0,1),COLORFFFF00;
 STICKLINE(C<N AND C>O,C,H,0,1),COLORFFFF00;
 STICKLINE(C<N AND C>O,O,L,0,1),COLORFFFF00;
 AA1:=MA(C,5);
 BB1:=MA(C,15);
 A:=CROSS(AA1,BB1);
 STICKLINE(A AND C<N,HHV(H,4),HHV(H,4),50,1),COLORGREEN;
 DRAWTEXT(A AND C<N,HHV(H,4),'加做空'),COLORGREEN;
 STICKLINE(A AND C>=N,LLV(L,4),LLV(L,4),50,1),COLORMAGENTA;
 DRAWTEXT(A AND C>=N,LLV(L,4),'加做多'),COLORMAGENTA;
 X:=ATAN((MA(CLOSE,5)/REF(MA(CLOSE,5),1)-1)*100)*59.3;
 XX:=X>40;
 AF:=C/REF(C,1)>1.095;
 BB:=BARSLAST(AF);
 CC:=L<=(REF(H,BB)+REF(L,BB))/2*0.98;
 DD:=COUNT(CC,BB)=1 AND CC AND BB<10 AND C>L AND XX ;
 GG:=BARSLAST(DD);
 HH:=H>0.01*REF(L,GG)*N;
卖出:=COUNT(HH,GG)=1 AND HH AND GG<10;
 STICKLINE(AF,C,O,2,0),COLORMAGENTA;
 STICKLINE(DD,C,O,2,0),COLORBLUE;
 STICKLINE(卖出,C,O,2,0),COLORYELLOW;
 DRAWICON(DD,L,27);
 STICKLINE(DD,L,L,0,0),COLORGREEN;
 DRAWTEXT(DD,L,'▲伏击'),COLORGREEN;
 DRAWICON(卖出,H,26);
 STICKLINE(卖出,H,H,0,0),COLORYELLOW;
 DRAWTEXT(卖出,H,'$中枪'),COLORYELLOW;
 STICKLINE(MA77,C,O,3,0),COLORGREEN;
 SS:=BARSLAST(F3);
 S1:=COUNT(L<REF(C,SS),SS)=1 AND L<REF(C,SS) AND SS<5;
 {DRAWTEXT(S1,DYNAINFO(6)=REF(C,SS)*0.8,'-------------'),COLORYELLOW;}
 MA5:=MA(O,7)*0.96;
 AX:=REF(C<MA5,1) AND O<MA5 AND L<MA5 AND REF(MA(H,3),1)>REF(MA(H,3),2) AND MA(O,3)>MA(O,6);
 AO:=MA(O,7);
 A2:=MA(H,7);
 A3:=AO>REF(AO,1) AND REF(AO,1)<REF(AO,2);
 A4:=BARSLAST(A3);
 A5:=REF(C<AO,1) AND O<AO AND AO>REF(AO,1)*1.0019 AND REF(A2,1)> REF(A2,2)*1.009 ;
 AY:=COUNT(A5,A4)=1 AND A5 AND REF(MA(H,3),1)>REF(MA(H,3),2);
 A10:=AX OR AY;
 A11:=BARSLAST(A10);
 B10:=H>REF(O,A11)*1.05 OR REF(O,A11)/L>1.05 ;
 B11:=COUNT(B10,A11)=1 AND B10 AND A11>=1 AND A11<6;
买入:=FILTER(A10,2);
卖:=B11;
 STICKLINE(买入,(O+C)/2,O,2.3,0)COLORGREEN;
 STICKLINE(卖,(O+C)/2,C,2.3,0)COLORYELLOW;
 DRAWTEXT(买入,L,'C')COLORYELLOW;
 DRAWTEXT(卖,H,'C')COLORRED;
通达信趋势大王主图源码 贴图

通达信趋势大王主图源码 贴图


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号