当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信卷帘主图(公式源码贴图)(无源码的请下载附件导入)

通达信指标卷帘主图

VAR2:=EMA(SLOPE(EMA(CLOSE,20),10)*34+CLOSE,30);
VAR3:=EMA(VAR2,3);
VAR4:=EMA(VAR3,3);
VAR5:=EMA(VAR4,3);
VAR6:=EMA(VAR5,3);
VA7:=EMA(VAR6,3);
VAR7:=EMA(VA7,3);
VA8:=EMA(VAR7,3);
VAR8:=EMA(VA8,3);
VAR9:=EMA(VAR8,3);
VARA:=BARSLAST(CROSS(CLOSE,VAR9));
VARB:=BARSLAST(CROSS(VAR9,CLOSE));
卷帘操作: STICKLINE(CLOSE>VAR9 AND CLOSE>REF(CLOSE,VARA),REF(CLOSE,VARA),LOW*1,00,1),COLOR0000B0,LINETHICK0;
强: STICKLINE(CLOSE<VAR9 AND CLOSE<REF(CLOSE,VARB),REF(CLOSE,VARB),HIGH*1.00,0,1),COLOR00B000,LINETHICK0;
势: STICKLINE(CLOSE>VAR9 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),LOW*1.02,0,1),LINETHICK0;
冷: STICKLINE(CLOSE>VAR9 AND CLOSE<REF(CLOSE,VARA),REF(CLOSE,VARA),REF(CLOSE,VARA),6,1),COLORGREEN,LINETHICK0;
沉: STICKLINE(CLOSE<VAR9,REF(CLOSE,VARB),REF(CLOSE,VARB),16,0),COLORB3B3B3,LINETHICK2;
VAR10:STICKLINE(CLOSE>VAR9,REF(CLOSE,VARA),REF(CLOSE,VARA),16,0),COLORBLUE,LINETHICK2;
X5:HHV((REF(CLOSE,1)+REF(CLOSE,2)+REF(CLOSE,3)+REF(CLOSE,4))/4.00,5),COLORGREEN;
X10:HHV((REF(CLOSE,2)+REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5))/4.00,10),COLORYELLOW;
X20:HHV((REF(CLOSE,3)+REF(CLOSE,4)+REF(CLOSE,5)+REF(CLOSE,6))/4,20),COLORMAGENTA;
DRAWKLINE(H,O,L,C);
次买:=O+(C-O)/2 ,LINETHICK2,POINTDOT,STICK;
次卖:=C+(O-C)/2 ,COLORRED,POINTDOT,LINETHICK2,STICK;
上涨空间预测:=C+((H-L)/2)*2 ,POINTDOT,LINETHICK2,STICK;
下跌空间预测:=C-((H-L)/2)*2 ,POINTDOT,LINETHICK2,STICK;
PLOYLINE(次买 AND ISLASTBAR=1,次买),STICK,POINTDOT,COLORDDDDDD;
PLOYLINE(上涨空间预测 AND ISLASTBAR=1,上涨空间预测),STICK,POINTDOT,COLORDDDDDD;
PLOYLINE(下跌空间预测 AND ISLASTBAR=1,下跌空间预测),STICK,POINTDOT,COLORDDDDDD;
次1:=C*2-MA(REF(C,3),3){REF(C,3)};
次2:=REF(C,1)*2-MA(REF(C,4),4){REF(C,4)};
次3:=REF(C,2)*2-MA(REF(C,5),5){REF(C,5)};
PLOYLINE(C*2-MA(REF(C,3),3)AND ISLASTBAR=1,次1),STICK,COLORYELLOW,LINETHICK1,POINTDOT;
PLOYLINE(REF(C,1)*2-MA(REF(C,4),4)AND ISLASTBAR=1,次2),STICK,COLORYELLOW,LINETHICK1,POINTDOT;
PLOYLINE(REF(C,2)*2-MA(REF(C,5),5)AND ISLASTBAR=1,次3),STICK,COLORYELLOW,LINETHICK1,POINTDOT;
A1:=COST(95);
A2:=COST(5);
LY:=(A1-A2)*100/(A1+A2);
DRAWICON(LY>REF(LY,1), L*0.98,8);
VAR31:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR41:=IF(((CLOSE)/(REF(CLOSE,1))>1.03) AND ((HIGH)/(CLOSE)<1.01) AND (VAR31>0),91,0);
DRAWTEXT((VAR41>90),(LOW)*(0.94999998),'★加仓'),COLOR00FFFF;
DRAWTEXT((VAR41>90),(LOW)*(0.99000001),'★'),COLOR00FFFF;
VAR111:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR211:=REF(VAR111,1);
VAR311:=SMA(MAX(VAR111-VAR211,0),10,1)/SMA(ABS(VAR111-VAR211),10,1)*100;
HY311:=IF(COUNT(VAR311<20,5)>=1 AND COUNT(VAR111=LLV(VAR111,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);
DRAWTEXT(HY311,LOW,'▲买入'),COLORYELLOW;
VARR1:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;
DRAWICON(CROSS(82,VARR1),HIGH,2);
DRAWTEXT(CROSS(82,VARR1),HIGH,'▲风险↓'),COLORYELLOW;
EL1:=EMA(LOW,6);
EL2:=EMA(EMA(LOW,34)*1,02)-0.16;
DRAWICON(CROSS(EL1,EL2),EL1,10);
V1:=REF(C,1);
V2:=SMA(MAX(C-V1,0),6,1)/SMA(ABS(C-V1),6,1)*100;
DRAWICON(IF(CROSS(81,V2),1,0),H*1.01,11);
 
通达信卷帘主图(公式源码贴图)


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号