当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是有鱼寂寞(源码、副图、通达信、贴图)超级飓风眼之四(无源码的请下载附件导入)

有鱼寂寞(源码、副图通达信、贴图)超级飓风眼之四

凭多年在股市摸爬滚打经验,自认为本系列介绍给大家的主图指标模式属于高级指标组合。尽管个别指标有函数,但不影响研判买卖点使用。
对函数有鄙视情绪的朋友,要知道天下所有炒股指标几乎都有函数。因为函数是编辑源码中不可缺少的“调味剂”!
既使是均线也是由函数组成。不然均线与均线在盘中多头上叉,在交叉当天闭市和转天开盘你才能得到固定的交叉信号提示(分时省略不谈)。
以个人粗浅见解,其原因是函数时间限制、决定了信号固定时间。
时间的限制又分为两大特征:
1、是以小时函数界定信号出现时间。(指在当天尾市收盘时才能固定不变的信号,及在转天开盘一个小时内固定的信号。)比如说均线,走过即留下痕迹永不消失。
2、是按交易时间以天数界定信号出现时间。而这样带函数的信号,才是最让投资者头疼的指标。(在淘宝网上买了不少,买时看图很准很漂亮,到手后方知上当!比如像《黑马通道》那样的主图指标,股价飚上去8——9天,信号才在启动前的左侧区域出现。而《牛股集中营》附图也是信号飘移的让人心惊胆颤!
正因为上述两种客观情况,才让投资者把两种函数明显的信号混为一谈。让一些人谈函数变色,恨之入骨、退避三舍。股票交易要用真金白银啊!
其实在炒股软件中这样的函数编码几乎都有,可以说带占据了半壁江山。
上面说的是日线信号。而周线和月线又是从日线数据转化形成,这个转换过程如果没有函数是不行的!
单说日线中的EMA(平滑代码)在编程时就更多,你拿去检测会显示有未来函数,但如果在整套系统的源码条中,能够有源码组合对EMA制约,并有在所有源码条中起主导作用的编辑组合,有主次之分。那么EMA可以忽略,不会影响趋势和信号形成大的飘移。
而在XX:=EMA(DCLOSE,1)-EMA(DCLOSE,2);这组源码条中同时出现两个明显的函数代码,EMA属于函数影响较小的,而DCLOSE则有N天飘移现象。与《黑马通道》长达9天的飘移现象相比已经是很不错了。
《黑马通道》黄色K线信号经过9天拉升,信号才由飘移转为固定不变,而固定的条件是必须连续拉升或停止下跌!
直观看上去底部顶部反映很及时,按此图买卖世界上几乎没有输家。其实是一个美丽的陷阱!你现在看到的底部黄K形态,是在拉升9天时才固定不变的!

 

虽然在资本市场混迹多年,交易系统编程由学过编程的年轻人负责。我不懂编程,但这是我经过无数次修改指标后的理解和感悟。经过实战,觉得函数较轻的指标不是不能用,而是看你怎么用。
对于害怕函数的朋友,以我对未来函数的理解:函数有显性、隐性之分。显性在主图左下角显示。隐性函数只有检测才能知道。
还有更甚者喜欢搞自欺欺人的把戏,在全部源码条上方加上一条编码,故意隐藏主副图左下角提示的“用到未来函数。”
这是“秃子头上的虱子……。麻子不是麻子,坑人!”。
我不排斥函数,关键是此函数影响信号出现的时间,是不是出现在低位底部形成初期。喜欢在调整K线坑的左侧或坑里出现的信号,厌弃股价启动后从右侧向左侧飘移过来的信号! 而那些后知后觉的信号才是所有投资者应该摒弃的。使用这样的信号,后患无穷!
这次所讲带函数指标源码,已经过多年实战检验,是具有操盘指导意义的。今天大家看到的只是显性未来函数指标。现实中许多炒股指标,你不去检测根本就不知有未来函数。更不知道对研判买卖点的影响程度到底有多大!
有些人过去被函数吓怕——“一朝被蛇咬,十年怕井绳。”见到函数如“弓杯蛇影”其原因就是没有深入的探讨检验——函数的时间限制!
综上所述:指标中有无未来函数,只是相对不同的函数时间代码而言!

如果你不喜欢函数,请绕道。

如果想知道我是怎样使用函数指标,不妨借鉴学习 —— 超前的左侧交易研判方法。
同时也给喜欢研究指标的朋友们提供一个引用指标的思路,但要谨慎!一旦失误银子没了!

接下来介绍带显性函数的指标用法。
另外,请使用函数指标一定要先跟踪:信号是否当天固定、或股价小幅上涨时才固定,下跌时消失(“坑后上涨”就属于这样的函数指标,但它绝不会在股价大幅拉升后,出现向凹坑飘移现象)。所以对函数指标要观察模拟后再下褒贬结论!
下图中,虽然在源码组合中的个别信号源码有未来函数。但不仅不影响使用,反而会对股价未来趋势具有明确的提示作用,我把它归类为——左侧交易信号中的一种。

例图1:弘业股份(2018年9月26日后的走势)
请看下图启动坑:在前一讲中只谈到黄色起跑道的助涨作用。也许你会迷惑,例图信号出的及时,可是在众多信号中,又怎么区别那支股票拉升的概率最大呢?
现在我开始讲:除了符合启动技术条件和当时市场题材之外,还有一个辨别方法,就是我放在主图K线下方的粉色块。千万不要讨厌这个函数明显的粉色块,如果我把COLORMAGENTA粉色块改成COLORYELLOW黄色,应该称其为名副其实的——黄金坑!
这个黄金坑可不是胡乱叫的,首先它必须出现在下跌凹坑里(哪怕是小级别反弹也是如此)。它不像《黑马通道》那样,在拉升九天过程中,粉色块向“红色剪刀叉”风口信号左侧,过去时的下方飘移。
我想上面这段话不需要对这个带显性函数的指标“粉色块”再做过多解释。

 有鱼寂寞(源码、副图、通达信、贴图)超级飓风眼之四

不过,我仍然不放心。肯定有人会问:在一只股票的震荡趋势中,会出现N个大小凹坑,哪个才是“真龙天子”呢?
于是我又加了一个信号叫——“坑后上涨”。
当年为了这个指标在淘宝网花了近两千元!上当后本想删除,后来隔了一年多,再回头整理修改购买指标时觉得可以挖掘试试看,于是保留下来。

请看下图,例图2:张江高科(2018年10月后的走势)
在启动凹坑上出现的粉色柱也带有明显函数。与黄色块同属于一个显性函数指标。仅仅是一组源码孕育出的双胞胎而已。
如果哪位朋友有更好更准的左侧指标,可以自己替换掉。
经过检验,这个“坑后上涨”信号,相比一路见凹坑乱撒芝麻盐的黄色情种块,更要有的放矢,出现的概率更低!
记住下面的选股“取景框”吧,把它牢牢印在脑子里,别让它受到干扰而淡漠!
正所谓:“黄块经常见,‘坑后上涨’信号不常有!”

 有鱼寂寞(源码、副图、通达信、贴图)超级飓风眼之四

例图3:市北高新(2018年10月后的走势)
请注意,K线下方的黄色块是在下跌末期出现。在后面大幅拉升时,不跟随K线上移,可见飘移现象几乎可以忽略不计。
记住附图中的“有鱼徘徊”!
起个更贴近实战的好名字,会给你的研判带来自信和灵感!

 有鱼寂寞(源码、副图、通达信、贴图)超级飓风眼之四

例图4:风范股份(2018年12月18日后的走势)
看看,K线下的黄色块是在下坡挖坑诱空调整寻底时出现,并没有随K线上移,直接落在坑底。
多么耐人寻味的附图。

 有鱼寂寞(源码、副图、通达信、贴图)超级飓风眼之四

例图5:顺灏股份(2019年元月份走势)
发现没有?新简洁版主图的蓝咖啡杯位置有所左移。是为了增加左侧交易的实战效果!
多么有诱惑力的主图。相信不玩股票的人也会心动!
下面的黄色块可以随便换颜色,只要主图看着不刺眼舒服就行。
记住附图小寡妇“不甘寂寞”这根柱子,它与“有鱼徘徊”似姊妹花!

 有鱼寂寞(源码、副图、通达信、贴图)超级飓风眼之四

例图6:东方通信(2018年10月后的走势)
上涨途中每一个凹坑都有粉色块出现。“坑后上涨”信号只出现在底部区域。
请把附图背景粉红色窄条和白色宽条与上方主图比照,分析主副图之间的关系,为什么白色宽条要在上方主图K线下方位置出现?
拉升前60日均线与120日均线几乎粘合,上冲后下探低点受到年线支撑,继续上涨!

 有鱼寂寞(源码、副图、通达信、贴图)超级飓风眼之四

例图7:绿庭投资(2018年10月后的走势)
看过前几张例图,想必你已经知道为什么保留3条中长期均线的目的。
如果还是不懂,请把鼠标箭头放在三条均线上,它们会自动告诉你——当股价站上这3条均线上的重要趋势意义。
由此可见,加上几个字,代表了我对均线的深刻注释。在几条均线上也是动了心思的!

 

例图8:复旦复华(2018年10月后的走势)
注意到没有,看过几十个例图,是不是没有看到短期均线?
关于短期均线的小夹角助涨技术和理论,早已印在脑子里。那是我在1992年初给一些营业部做自营的学生们讲的内容。
(当5日即将上穿20日均线时,即将形成的5日、10日、20日均线之间形成的小夹角——短时助涨。10日即将上穿30日均线——波段助涨!当然还有细节区别。不深谈。)
很高兴现在还有人在电视上把均线小夹角技术当做招揽人的独门绝活。
现在我讲的是更超前、更简单、且更直观的左侧交易方法之“红色剪刀叉”技术。
给你技术又给你实战指标,让你借鉴完成建立一个独特的属于自己的交易系统。
均线小夹角技术可以让你获得短线反弹利润,蒙上了可以逮个大的。而“红色剪刀叉”技术,可以在掌握熟练之后,提前在左侧抓到即将拉升翻倍的飚股!
“学海无涯苦作舟”掌握熟练后,说不定将来有人会捧你、称你为——大师——股神!
这就是左侧交易之精髓,而且是无偿奉献!
怎么样,看过几期连载,你是否看出门道?是不是该认真琢磨每一句话?

 

{有鱼寂寞附图。不建议修改本附图源码!!!! }
A1X:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))
/(HHV(H,55)-LLV(L,55))*100,5,1);
潘金莲:=EMA(A1X,5),LINETHICK2,COLOR6600FF;
A2X:=(潘金莲-REF(潘金莲,1))/REF(潘金莲,1)*100;
A3X:=EMA(C,5);
A4X:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
王婆牵线:=(MA(3*SMA(A4X,6,1)-2*SMA(SMA(A4X,5,1),5,1),2)),LINETHICK2,COLORYELLOW;
A5X:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1)
,COLORF00FF0,LINETHICK2;
A1:="KD.K#DAY"(9,3,3);
A2:="KD.D#DAY"(9,3,3);
AA1:=(A1+A2)/2;
A3:="KD.K#WEEK"(9,3,3);
A4:="KD.D#WEEK"(9,3,3);
A5:="KD.K#MONTH"(9,3,3);
A6:="KD.D#MONTH"(9,3,3);
A7:="KDJ.J#WEEK"(9,3,3);
A8:="KD.K"(9,3,3);
A9:="KD.D"(9,3,3);
STICKLINE( A1>A2,2 ,2.5 ,5 ,0 ),COLORLIRED;
STICKLINE( A1<A2,2 ,3 ,5 ,0 ),COLORBLACK;
STICKLINE( A3>A4,2 ,0.5 ,5 ,0 ),COLORGRAY;
STICKLINE( C>0,0.5 ,0.5 ,5 ,0 ),COLOR555555;
STICKLINE( C>0,2 ,2,10 ,0 ),COLOR555555;
K:=A8*3/120;
D:=A9*3/120;
J:=A7*3/120;
AA2:=AA1*3/120;
DRAWBAND(A3*3/120,RGB(250,00,300),A4*3/120,RGB(00,250,300));
STICKLINE(K>D,K,D,5,1),COLORRED;
STICKLINE(K<=D,K,D,5,1),COLORLIGREEN;
OK:=REF(CLOSE,1);
鱼:=SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100;
RSI4:=SMA(鱼,7,1);
HH:=BARSLAST(鱼<=15)<5;
白绿线:=SMA(鱼,7,1);
深水鱼:=CROSS(鱼,RSI4) AND 白绿线>15 AND HH;{15}
BU:=深水鱼;
BB2:=IF(C>REF((6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/(6+5+4+3+2+1)
,1),1,IF(C<REF((6*L+5*REF(L,1)+4*REF(L,2)+3*REF(L,3)+2*REF(L,4)+1*REF(L,5))/(6+5+4+3+2+1)
,1),-1,0));
DD2:=BARSLAST(NOT(BB2=0));
BF:=IF(BB2=0,REF(BB2,DD2),BB2);
鱼跃龙门:BU,NODRAW,COLORRED;
止损:C<REF(O,BARSLAST(BU>0)) AND COUNT(C<REF(O,BARSLAST(BU>0)),BARSLAST(BU>0))
=1 AND IF(MA(CLOSE,1)>IF(BF=-1,MA(HIGH,1.01),MA(LOW,1.01)) ,1,-1)>0,NODRAW, COLORGREEN;{6}
区间:=COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止损,BARSLAST(BU>0)+1)
=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(BF=-1,MA(HIGH,1.01),MA(LOW,1.01))
 ,1,-1)), BARSLAST(BU>0)+1)=0,NODRAW,COLORLIMAGENTA;{COLOR696960;6}
鱼进龙门:(COUNT(BU,BARSLAST(BU)+1)=1 AND COUNT(止损,BARSLAST(BU>0)+1)
=0 AND COUNT(CROSS(0,IF(MA(CLOSE,1)>IF(BF=-1,MA(HIGH,1.01),MA(LOW,1.01)) ,1,-1)), BARSLAST(BU>0)
+1)=1 AND CROSS(0,IF(MA(CLOSE,1)>IF(BF=-1,MA(HIGH,1.01),MA(LOW,1.01)) ,1,-1)))
 OR 止损,NODRAW;
STICKLINE(鱼进龙门>0,0,4,3,0),COLORYELLOW;
DRAWTEXT(鱼进龙门,3.77,'←鱼跃龙门'),COLORMAGENTA;
RSVP:=(C-LLV(L,30))/(HHV(H,30)-LLV(L,30))*20-20;
KV:=SMA(RSVP,3,1);
DV:=SMA(KV,3,1);
JV:=3*KV-2*DV;
ZDZK1:=EMA(JV,6);
ZDZK2:=REF(ZDZK1,1);
凤:=IF(ZDZK1>=ZDZK2,ZDZK1+2,ZDZK2);
雉:=IF(ZDZK2-ZDZK1,ZDZK2,ZDZK1);
MTM:=C-REF(C,1);
龙:=30*EMA(EMA(MTM,50),50)/EMA(EMA(ABS(MTM),61),61);
凰:=MA(龙,6);
龙凤呈祥:=CROSS(凰<龙,0.13) AND 龙>凤 AND 凤>雉;
STICKLINE(龙凤呈祥,3,0,1,0),COLORWHITE;
DRAWTEXT(龙凤呈祥,3.02,' 龙凤呈祥'),COLORWHITE;
AA:=HHV(HIGH,25)-LLV(LOW,25);BB:=CLOSE-LLV(LOW,25);
CC:=AA/EMA(BB,5);
DD:=EMA(BB/AA*100,5);
EE:=CLOSE-LLV(LOW,10);
FF:=HHV(HIGH,25)-LLV(LOW,10);
王婆:=COUNT(CROSS(CC,DD),7)>0 AND REF(CC,2)<REF(CC,1) AND CC<REF(CC,1)
AND COUNT(COUNT(CROSS(CC,DD),7)>0 AND REF(CC,2)<REF(CC,1)
AND CC<REF(CC,1),5)=1 OR CROSS(EMA(EE/FF*4,4),0.3);
WVAR1V:=REF(CLOSE,1);
WVAR2V:=SMA(MAX(CLOSE-WVAR1V,0),7,1)/SMA(ABS(CLOSE-WVAR1V),7,1)*100;
X1:=FILTER(REF(WVAR2V,1)<20 AND WVAR2V>REF(WVAR2V,1),5);
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
X2:=CROSS(BIAS,乖离) AND 乖离<-9.5;
偷偷约会:=X1 OR X2;
VAR1V:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR2V:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR3V:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
VAR4V:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5V:=(VAR2V+2*VAR3V+3*VAR4V)/7;
VAR6V:=MA(VAR5V,1);
西门赴约:=VAR6V<=-8;
武大出摊:王婆 AND 偷偷约会 AND 西门赴约,COLORRED,NODRAW;
{STICKLINE(C>0,1.25,1.25,3,0),COLORYELLOW;{COLOR555555;}
STICKLINE(鱼跃龙门>0,0,3.8,4,0),COLORRED;{红色柱}
DRAWTEXT(鱼跃龙门,3.5,'★有鱼徘徊'),COLORYELLOW;
STICKLINE(CROSS(王婆牵线,0)AND 潘金莲<40,0,2.8,1,0),COLORGREEN;
STICKLINE(EXIST(机会来临,7) AND CROSS(A1X,潘金莲)AND 潘金莲<A5X AND 潘金莲<15,0,3,1,0)
,COLORBROWN;
DRAWTEXT(EXIST(机会来临,7) AND CROSS(A1X,潘金莲)AND 潘金莲<A5X AND 潘金莲<15,2.7,'←寂 寞 难 耐')
,COLORCYAN;
STICKLINE(武大出摊,2.08,0,4,0),COLORCYAN;{COLOR007FFF;}
DRAWTEXT(武大出摊,1.8,' ---最低买点'),COLORCYAN;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
虾将:=IF(CROSS(RSI,11),2,0),COLORWHITE,POINTDOT;
蟹兵:=STICKLINE(虾将,1.8,0,2,0),COLORWHITE;
STICKLINE(虾将,1.8,0,2,0),COLORWHITE;
DRAWTEXT(蟹兵,1.8,' ---蟹兵'),COLORYELLOW;
VAR7:=EMA(AMOUNT/VOL/100,3);
VAR8:=EMA(VAR7,88);
VAR9:=EMA(VAR7,88)*0.85;
VARA:=VAR9*0.87;
VARB:=LOW<VARA AND CLOSE>REF(CLOSE,1)*1.02;
白龙马:=STICKLINE(FILTER(VARB,6),2,0,2,0),COLORLIBLUE;
STICKLINE(FILTER(VARB,6),2,0,2,0),COLORLIBLUE;
DRAWTEXT(白龙马,1.6,' ---白龙马'),COLORWHITE;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VA4:=LLV(LOW,34);
VA5:=HHV(HIGH,34);
VA6:=EMA((VARF-VA4)/(VA5-VA4)*100,6);
VA7:=EMA(0.667*REF(VA6,1)+0.333*VA6,4);
凤尾鱼:=STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND
REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),1.5,0,3,0),COLORBLUE;
STICKLINE(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>0.3 AND COUNT(VA6>VA7,3) AND
REF(LOW,1)=LLV(LOW,120) AND CLOSE>OPEN,1,0),1.5,0,6,0),COLORBLUE;
DRAWTEXT(凤尾鱼,1.3,' ---定海神针'),COLORYELLOW;
DRAWTEXT(CROSS(王婆牵线,0)AND 潘金莲<40,2.3,'--凤尾鱼'),COLORWHITE;
 


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号