当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信伍德CCI指标公式(无源码的请下载附件导入)

M:=14;N:=6;Q:=20;
 MM:=IF(PERIOD=0,M,IF(PERIOD=1,M,IF(PERIOD=2,M,IF(PERIOD=3,M,IF(PERIOD=4,
 M,IF(PERIOD=5,Q,IF(PERIOD=6,Q,IF(PERIOD=7,Q,0))))))));
 AVG:=(HIGH+LOW+CLOSE)/3;
CCI:=(AVG-MA(AVG,MM))/(0.015*AVEDEV(AVG,MM));
 DIF:CCI-REF(CCI,1),LINETHICK0;
前差值:ABS(REF(CCI,1)-REF(CCI,2)),LINETHICK0;
差值20:IF(DIF>15 AND DIF<120,DIF,0),LINETHICK0;
 200,COLORFFFF00;
 -200,COLORFFFF00;
 100,COLORFFFF00;
 -100,COLORFFFF00;
 PI:=ATAN(1)*4;
 PERIODS:=30;
 HIGHHIGH:=HHV(HIGH,PERIODS);
 LOWLOW:=LLV(LOW,PERIODS);
 RANGEV:=25/(HIGHHIGH-LOWLOW)*LOWLOW;
 EMA34:=EMA(CLOSE,34);
 X1_EMA34:=0;
 X2_EMA34:=1;
 Y1_EMA34:=0;
 Y2_EMA34:=(REF(EMA34,1)-EMA34)/AVG*RANGEV;
 C_EMA34:=SQRT((X2_EMA34-X1_EMA34)*(X2_EMA34-X1_EMA34)+(Y2_EMA34-Y1_EMA34)*(Y2_EMA34-Y1_EMA34));
 ANGLE_EMA34V:=ROUND(ABS(180*ACOS((X2_EMA34-X1_EMA34)/C_EMA34)/PI));
 ANGLE_EMA34:=IF(Y2_EMA34>0,-ANGLE_EMA34V,ANGLE_EMA34V);
 LSMA25:=FORCAST(CLOSE,25);
 X1_LSMA25:=0;
 X2_LSMA25:=1;
 Y1_LSMA25:=0;
 Y2_LSMA25:=(REF(LSMA25,1)-LSMA25)/AVG*RANGEV;
 C_LSMA25:=SQRT((X2_LSMA25-X1_LSMA25)*(X2_LSMA25-X1_LSMA25)+(Y2_LSMA25-Y1_LSMA25)*(Y2_LSMA25-Y1_LSMA25));
 ANGLE_LSMA25V:=ROUND(ABS(180*ACOS((X2_LSMA25-X1_LSMA25)/C_LSMA25)/PI));
 ANGLE_LSMA25:=IF(Y2_LSMA25>0,-ANGLE_LSMA25V,ANGLE_LSMA25V);
 ARRAY:=CCI;
 HIGHBARS:=BARSLAST(NOT(ARRAY>0));
 LOWBARS:=BARSLAST(NOT(ARRAY<0));
 UPCONDITION:=BARSLAST(HIGHBARS>=6 AND SUM(ARRAY>100,5)>0);
 DNCONDITION:=BARSLAST(LOWBARS>=6 AND SUM(ARRAY<-100,5)>0);
 UPTREND:=ARRAY>0 AND UPCONDITION<DNCONDITION;
 DNTREND:=ARRAY<0 AND UPCONDITION>DNCONDITION;
 TRTREND:=HIGHBARS>=5 AND NOT(UPTREND) OR LOWBARS>=5 AND NOT(DNTREND);
 STICKLINE(UPTREND,0,CCI,3,0),COLORFF0000;
 STICKLINE(DNTREND,0,CCI,3,0),COLORFF00FF;
 STICKLINE(TRTREND,0,CCI,3,0),COLORFFFFF0;
 STICKLINE(NOT(UPTREND OR DNTREND OR TRTREND),0,CCI,3,0),COLOR808080;
 WCCI:CCI,COLORF00FF0,LINETHICK2;
 TCCI:(AVG-MA(AVG,N))/(0.015*AVEDEV(AVG,N));
 
 STICKLINE(ANGLE_EMA34>=5,-301,-321,8,0),COLORD0E040;
 STICKLINE(ANGLE_EMA34<5 AND ANGLE_EMA34>=3.57,-301,-321,8,0),COLORFF6400;
 STICKLINE(ANGLE_EMA34<3.57 AND ANGLE_EMA34>=2.14,-301,-321,8,0),COLOR98FB98;
 STICKLINE(ANGLE_EMA34<2.14 AND ANGLE_EMA34>=0.71,-301,-321,8,0),COLORFF00FF;
 STICKLINE(ANGLE_EMA34<0.71 AND ANGLE_EMA34>-0.71,-301,-321,8,0),COLORFFF00F;
 STICKLINE(ANGLE_EMA34<=-0.71 AND ANGLE_EMA34>-2.14,-301,-321,8,0),COLORE0FFFF;
 STICKLINE(ANGLE_EMA34<=-2.14 AND ANGLE_EMA34>-3.57,-301,-321,8,0),COLORA5FF00;
 STICKLINE(ANGLE_EMA34<=-3.57 AND ANGLE_EMA34>-5,-301,-321,8,0);
 STICKLINE(ANGLE_EMA34<=-5,-301,-321,8,0),COLOR8B0000;
 SW:=IF(ABS(ANGLE_EMA34)>=15 AND ABS(ANGLE_EMA34+ANGLE_LSMA25)>=50,IF(ANGLE_LSMA25>0,2,-2),IF(ABS(ANGLE_EMA34)>=0 AND (ANGLE_EMA34>=0 AND ANGLE_LSMA25>=0 OR ANGLE_EMA34<=0 AND ANGLE_LSMA25<=0) AND ABS(ANGLE_EMA34+ANGLE_LSMA25)>=5,IF(ANGLE_LSMA25>0,1,-1),0));
 STICKLINE(ABS(SW)=2,301,321,8,0),COLORFF0088;
 STICKLINE(ABS(SW)=1,301,321,8,0),COLORFFFF88;
 STICKLINE(ABS(SW)=0,301,321,8,0),COLORFF8800;
 IF(CLOSE>LSMA25,0,DRAWNULL),LINETHICK3,COLORFF0099;
 IF(CLOSE<LSMA25,0,DRAWNULL),LINETHICK3,COLORFF6666;
 IF(CLOSE=LSMA25,0,DRAWNULL),LINETHICK3,COLORFFFF66;
 DRAWICON(ABS(CCI)>=200,CCI,12);
 {TM:=IF(PERIOD=0,1,IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,240)))));
 ALERT1:=IF(PERIOD=0,10,IF(PERIOD=1,34,IF(PERIOD=2,100,IF(PERIOD=3,180,IF(PERIOD=4,300,600)))));}

通达信伍德CCI指标公式


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号