当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信圆形突破(源码主图贴图)(无源码的请下载附件导入)

DRAWGBK(C>O,RGB(60,0,0),RGB(0,0,0),1,2,1);
DRAWKLINE(H,O,L,C);
低天:=15;
高天:=5;
CURR:=CURRBARSCOUNT;
高低:=DRAWLINE(CURR=高天,H,CURR=低天,L,0);
低高:=DRAWLINE(CURR=低天,L,CURR=高天,H,0);
高低线:=IF(高天>低天,高低,低高);
{DRAWBAND(高低线,RGB(225,226,199),高低线,RGB(225,226,199));}
IF(CURR=高天,H,IF(CURR=低天,L,IF(CURR=ROUND((低天+高天)/2),高低线,DRAWNULL))),COLORAA00AA,CROSSDOT,LINETHICK3;
SH:=CONST(REF(H,BARSLAST(CURR=高天)));
SL:=CONST(REF(L,BARSLAST(CURR=低天)));
高低距:=SH-SL;
天距:=ABS(低天-高天);
PR:=ABS(低天-高天)/2+IF(高天>低天,低天,高天);
RN:(SH+SL)/2;
Y弧:=(SH*SL);{半径}
BX:=2*(SH*SL)/天距;
BY:=(SH*SL)/高低距;
XW:=IF(CURR<PR,PR-CURR,CURR-PR)*BX;
SY:=IF(XW<Y弧,SQRT(Y弧*Y弧-XW*XW),0)/BY;
Y震谱1:=IF(高天<低天,RN+SY,RN-SY),COLORRED;
Y震谱2:=IF(高天<低天,RN-SY,RN+SY),COLORRED;
高点:HHV(Y震谱1,10);
XW11:IF(REF(Y震谱1,1)<高点,高点,高点),COLORYELLOW;
{低点:LLV(Y震谱1,(SH*SL)*2);
XW112:IF(REF(Y震谱1,1)>Y震谱1,Y震谱1,低点);}


Y弧1:=(SH*SL)/2;{半径}
BX1:=2*(SH*SL)/天距;
BY1:=(SH*SL)/高低距;
XW1:=IF(CURR<PR,PR-CURR,CURR-PR)*BX1;
SY1:=IF(XW<Y弧,SQRT(Y弧1*Y弧1-XW1*XW1),0)/BY1;
Y震谱3:=IF(高天<低天,RN+SY1,RN-SY1),COLORRED;
Y震谱4:=IF(高天<低天,RN-SY1,RN+SY1),COLORRED;
高点1:HHV(Y震谱3,10),COLORBLUE;
XW111:IF(REF(Y震谱3,1)<高点1,高点1,高点1);
XG:=CROSS(C,高点) OR CROSS(C,高点1) AND V/REF(MA(V,5),1)>1.2;
DRAWTEXT(CURRBARSCOUNT<10 AND XG ,L,'▲圆弧突破'),COLORYELLOW;

通达信圆形突破(源码主图贴图)

通达信圆形突破(源码主图贴图)


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号