当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信抄底副图和选股源码(无源码的请下载附件导入)

{副图}

80,COLOR996699;

20,COLORGREEN;

10,COLORCC6633,LINETHICK2;

90,COLOR9966FF,LINETHICK2;

VAR1:=MA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);

VAR2:=(-100)*(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21));

VAR3:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);

中长线:VAR1+100,COLOR9900FF;

超短线:VAR2+100,COLORGREEN,LINETHICK2;

IF(超短线>=REF(超短线,1),超短线,DRAWNULL),COLORRED,LINETHICK2;

VAR4:=VAR3+100;

VAR5:=BARSLAST(CROSS(超短线,中长线))<3 AND 中长线<20;

VAR6:=REF(VAR4,1)>85 AND REF(超短线,1)>85 AND REF(中长线,1)>65 AND CROSS(中长线,超短线);

VAR7:=VAR4<REF(VAR4,1) AND REF(VAR4,1)>80 AND (REF(超短线,1)>95 OR REF(超短线,2)>95) AND 中长线>60 AND 超短线<83.5 AND 超短线<VAR4 AND 超短线<中长线+4;

VAR8:=FILTER(VAR7,4);

VAR9:=中长线<12 AND VAR4<8 AND (超短线<7.2 OR REF(超短线,1)<5) AND (VAR4>REF(VAR4,1) OR 超短线>REF(超短线,1)) OR (中长线<8 AND VAR4<7 AND 超短线<15 AND 超短线>REF(超短线,1)) OR (中长线<10 AND VAR4<7 AND 超短线<1);

VAR10:=50*(中长线<15 AND REF(中长线,1)<15 AND VAR4<18 AND 超短线>REF(超短线,1) AND CROSS(超短线,中长线) AND 超短线>VAR4 AND (REF(超短线,1)<5 OR REF(超短线,2)<5) AND (VAR4>=中长线 OR REF(超短线,1)<1));

VAR11:=中长线>REF(中长线,1) AND COUNT(LLV(中长线,120),5)<3 AND VAR5;

VAR12:=中长线<REF(中长线,1) AND REF(中长线,1)=HHV(中长线,120);

VAR13:=REF(超短线,1)=LLV(超短线,4);

建仓:VAR13 AND REF(VAR4,1)<20 AND CROSS(超短线,10) AND (中长线>REF(中长线,1) OR (CROSS(超短线,VAR4) AND CROSS(超短线,中长线)));

STICKLINE(建仓,0,25,1,0),COLORRED;

{公式名称: 抄底}

{选股}

VAR1:=DYNAINFO(8)>0;

VAR2:=NOT(NAMELIKE(131) OR NAMELIKE(132));

VAR3:=DYNAINFO(7)>5 AND DYNAINFO(7)<50 AND CAPITAL<30000000 AND VAR2;

VAR4:=MA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),19);

VAR5:=(-100)*(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21));

VAR6:=EMA((-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34)),4);

VAR7:=VAR4+100;

VAR8:=VAR5+100;

VAR9:=VAR6+100;

VAR10:=BARSLAST(CROSS(VAR8,VAR7))<3 AND VAR7<20;

VAR11:=REF(VAR9,1)>85 AND REF(VAR8,1)>85 AND REF(VAR7,1)>65 AND CROSS(VAR7,VAR8);

VAR12:=VAR9<REF(VAR9,1) AND REF(VAR9,1)>80 AND (REF(VAR8,1)>95 OR REF(VAR8,2)>95) AND VAR7>60 AND VAR8<83.5 AND VAR8<VAR9 AND VAR8<VAR7+4;

VAR13:=FILTER(VAR12,4);

VAR14:=VAR7<12 AND VAR9<8 AND (VAR8<7.2 OR REF(VAR8,1)<5) AND (VAR9>REF(VAR9,1) OR VAR8>REF(VAR8,1)) OR (VAR7<8 AND VAR9<7 AND VAR8<15 AND VAR8>REF(VAR8,1)) OR (VAR7<10 AND VAR9<7 AND VAR8<1);

VAR15:=50*(VAR7<15 AND REF(VAR7,1)<15 AND VAR9<18 AND VAR8>REF(VAR8,1) AND CROSS(VAR8,VAR7) AND VAR8>VAR9 AND (REF(VAR8,1)<5 OR REF(VAR8,2)<5) AND (VAR9>=VAR7 OR REF(VAR8,1)<1));

VAR16:=VAR7>REF(VAR7,1) AND COUNT(LLV(VAR7,120),5)<3 AND VAR10;

VAR17:=VAR7<REF(VAR7,1) AND REF(VAR7,1)=HHV(VAR7,120);

VAR18:=REF(VAR8,1)=LLV(VAR8,4);

建仓:VAR3 AND VAR18 AND REF(VAR9,1)<20 AND CROSS(VAR8,10) AND (VAR7>REF(VAR7,1) OR (CROSS(VAR8,VAR9) AND CROSS(VAR8,VAR7)));

通达信抄底副图和选股源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号