当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信五彩成交量公式 源码 贴图(无源码的请下载附件导入)

A:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,DRAWNULL)))));
 B:=FLOOR((FROMOPEN/A));
 {黄色色柱为盘中虚拟成交量}
万手:VOL/10000,LINETHICK0,NODRAW;
 AA:=IF(CURRBARSCOUNT=1,SUM(VOL,B)*A/FROMOPEN,DRAWNULL);
预测:STICKLINE(AA,0,AA,4,0),COLORYELLOW;
 {实盘画线}
 {STICKLINE(CURRBARSCOUNT=1,AA,0,2.5,0),COLORYELLOW};
 BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,
 BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主买:主动买/10000,COLORRED,NODRAW;
主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),
 IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));
主卖:-主动卖/10000,COLORGREEN,NODRAW;
差额:(主动买+主动卖)/10000,NODRAW;
 STICKLINE(CLOSE> REF(CLOSE,1),0,VOL,2.5,0),COLORLICYAN;
 STICKLINE(CLOSE< REF(CLOSE,1),0,VOL,2.5,0),COLORLIGREEN;
 STICKLINE(CLOSE= REF(CLOSE,1),0,VOL,2.5,0),COLORWHITE;
 {如果您还想用以前的假阴阳线,就把上面三行代码用大括号"()"括起来!}
 {并把下面四行代码的大括号"()"去掉!}
 {STICKLINE(C>-1,0,VOL,3,1),COLORRED;
 STICKLINE(C<O ,0,VOL,3,1),COLORFFFF00;
 STICKLINE(C=O AND C<REF(C,1),0,VOL,2,1),COLORFFFF00;
 STICKLINE(C=O AND C>REF(C,1),0,VOL,2,1),COLORRED;}
 STICKLINE(主动买>0,0,主动买,1,0),COLORRED;
 STICKLINE(主动卖<0,VOL,主动买,1,0),COLORBLUE;
 {STICKLINE(1,主动买-VOL,0,2,0),COLOR0FF000;}
 {持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORGREEN;}
 {持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORMAGENTA;}
五日: MA(V,5) COLORWHITE;

十日: MA(V,10) COLORYELLOW;
 {买盘:MA(主动买,5),LINETHICK2,COLOR00FFFF;
卖盘:MA(VOL-主动买,5),LINETHICK2,COLORFF00FF;};

通达信五彩成交量公式 源码 贴图


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号