当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信资金进出天量地量一目了然指标源码(无源码的请下载附件导入)

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
 MTIME:=MOD(FROMOPEN,TOTAL);
 CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
 VVOL:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
 STICKLINE(CURRBARSCOUNT=1,VVOL,0,-1,-1),COLOR00C0C0;

JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
主买:=QJ0*IF(C<O,MIN(CLOSE,OPEN)-LOW,ABS(JJ-MIN(CLOSE,OPEN)));
主卖:=QJ0*IF(C<O,(HIGH-JJ),(HIGH-MAX(OPEN,CLOSE)));
 V0:=VOL;
大单差:(主买-主卖),LINETHICK;

STICKLINE(大单差>=0,0,V0,3,0),COLOR2222CC;
 STICKLINE(大单差>=0,0,V0,2.5,0),COLOR3333DD;
 STICKLINE(大单差>=0,0,V0,2,0),COLOR4444DD;
 STICKLINE(大单差>=0,0,V0,1.5,0),COLOR5555EE;
 STICKLINE(大单差>=0,0,V0,1,0),COLOR6666EE;
 STICKLINE(大单差>=0,0,V0,0.5,0),COLOR9977EE;

STICKLINE(大单差<0,0,V0,3,0),COLORFF7700;
 STICKLINE(大单差<0,0,V0,2.5,0),COLORFF8811;
 STICKLINE(大单差<0,0,V0,2,0),COLORFFAA22;
 STICKLINE(大单差<0,0,V0,1.5,0),COLORFFBB33;
 STICKLINE(大单差<0,0,V0,1,0),COLORFFDD44;
 STICKLINE(大单差<0,0,V0,0.5,0),COLORFFFF55;

MA5:MA(VOL,5)*2;
 MA60:MA(VOL,60)*2;

AA:=SUMBARS(VOL,CAPITAL);
地量:IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),VOL<MA(VOL,AA)/3) ,LINETHICK0;
 STICKLINE(地量,VOL,0,1,0),COLORYELLOW;
天量:IF(CAPITAL=0,AMOUNT=HHV(AMOUNT,34),VOL>MA(VOL,AA)*3) ,LINETHICK0,COLORFF0000;
 STICKLINE(天量,VOL,0,1,0),COLORFF0000;

STICKLINE(大单差>0,0,大单差,2,0),COLOR102088;
 STICKLINE(大单差>0,0,大单差,1.5,0),COLOR1020BB;
 STICKLINE(大单差>0,0,大单差,1,0),COLOR1020DD;
 STICKLINE(大单差>0,0,大单差,0.5,0),COLOR1020EE;

STICKLINE(大单差<0,0,大单差,2,0),COLOR007700;
 STICKLINE(大单差<0,0,大单差,1.5,0),COLOR008800;
 STICKLINE(大单差<0,0,大单差,1,0),COLOR00AA00;
 STICKLINE(大单差<0,0,大单差,0.5,0),COLOR00CC00;
 BB:IF(CROSS(0.9,1/VOL*10000>0.01 AND "KDJ.J"<0),VOL*5,0) AND 大单差>0,LINETHICK0;
 STICKLINE(BB<0,0,100,1,0),COLORYELLOW,POINTDOT;

RSV:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
 K:=SMA(RSV,5,1);
 D:=SMA(K,3,1);
 J:=(3*K-2*D);
 M:=EMA(J,3);
 E:=EMA(M,3);
 A1:=BARSLAST(REF(CROSS(M,E),1));
底背离:=REF(L,A1+1)>L AND M>REF(M,A1+1) AND CROSS(M,E) AND M<20;
 B:底背离,LINETHICK0;
 

STICKLINE(B,0,100,1,0),COLOR00CC00;
 X:=LLV(J,2)=LLV(J,8);
 VAR1:=LLV(LOW,10);
 VAR2:=HHV(HIGH,25);
 VAR3:=100*EMA((CLOSE-VAR1)/(VAR2-VAR1),4);
下注:CROSS(J,REF(J+0.01,1)) AND X AND J<0,LINETHICK0;
 STICKLINE(下注,0,100,1,0),COLORRED,POINTDOT;
 DRAWTEXT(下注,0,'注'),COLORRED;
 S:=EMA((CLOSE-LLV(CLOSE,21))/(HHV(CLOSE,21)-LLV(CLOSE,21)),1);
 Y:=IF(S>0,MA(S,1),0);
庄:CROSS(Y,REF(Y+0.001,1)) AND J<0,LINETHICK0,COLORFF22AA;
 DRAWTEXT(庄,0,'买'),COLORFF22AA;
 STICKLINE(庄,0,100,1,0),COLORFF22AA;

通达信资金进出天量地量一目了然指标源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号