当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信牛股预警指标公式源码(无源码的请下载附件导入)

生命量能(空方趋势、机构做空能量、机构做多能量)-指标公式源码

{多方趋势:7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1),LINETHICK1,COLOR7F52AF;
空方趋势:EMA(MA(多方趋势,5),7),LINETHICK1,COLORA6B8C1;
STICKLINE(多方趋势>=空方趋势,多方趋势,空方趋势,3,0),COLOR7F52AF;
STICKLINE(多方趋势<空方趋势,多方趋势,空方趋势,3,0),COLORA6B8C1;
STICKLINE(多方趋势>78 AND 多方趋势>=空方趋势,多方趋势,78,5,0),COLORRED;
STICKLINE(空方趋势<=多方趋势,空方趋势,多方趋势,3,0),COLOR7F52AF;
STICKLINE(空方趋势>多方趋势,空方趋势,多方趋势,3,0),COLORA6B8C1;
STICKLINE(空方趋势<15 AND 空方趋势<=多方趋势,空方趋势,15,5,0),COLORBLUE;}
VAR886:=IF((YEAR >= 2050) AND (MONTH >= 1),0,1);
生命量能: EMA(100*(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N)),K)/2, STICK,COLORRED;
DRAWTEXT(生命量能>46,生命量能,'☆'),COLORYELLOW;
DRAWICON(生命量能<1,3,1),COLORYELLOW;
VAR1:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100*VAR886;
机构做空能量: SMA(VAR1,3,1),LINETHICK2,COLORGREEN;
VAR2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100*VAR886;
机构做多能量: SMA(VAR2,5,1)-8,LINETHICK2,COLORRED;
底部区域:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,28,0),COLORWHITE;
{多方趋势:7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1),LINETHICK1,COLOR7F52AF;
空方趋势:EMA(MA(多方趋势,5),7),LINETHICK1,COLORA6B8C1;
STICKLINE(多方趋势>=空方趋势,多方趋势,空方趋势,3,0),COLOR7F52AF;
STICKLINE(多方趋势<空方趋势,多方趋势,空方趋势,3,0),COLORA6B8C1;
STICKLINE(多方趋势>78 AND 多方趋势>=空方趋势,多方趋势,78,5,0),COLORRED;
STICKLINE(空方趋势<=多方趋势,空方趋势,多方趋势,3,0),COLOR7F52AF;
STICKLINE(空方趋势>多方趋势,空方趋势,多方趋势,3,0),COLORA6B8C1;
STICKLINE(空方趋势<15 AND 空方趋势<=多方趋势,空方趋势,15,5,0),COLORBLUE;}
V6:=CLOSE/REF(CLOSE,3)>=1.1;
V7:=BACKSET(V6,3);
买入:IF((V7 AND COUNT(V7,3)=1),30,0),COLORYELLOW,;
DRAWTEXT(买入,35,'买入'),,COLORYELLOW;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100*VAR886;
K:=SMA(RSV,3,1),COLORYELLOW;
D:=SMA(K,3,1),COLORWHITE,;
买:IF(D<25 AND CROSS(K,D) ,28,0)*VAR886,COLORMAGENTA,LINETHICK4,STICK;
卖:IF(D>75 AND CROSS(D,K) ,28,0)*VAR886,COLORGREEN,LINETHICK4,STICK;
STICKLINE(K>D,K,D,5,0),COLORFFFF50;
STICKLINE(D>K,K,D,5,0),COLOR0000FF;
{多方趋势:7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1),LINETHICK1,COLOR7F52AF;
空方趋势:EMA(MA(多方趋势,5),7),LINETHICK1,COLORA6B8C1;
STICKLINE(多方趋势>=空方趋势,多方趋势,空方趋势,3,0),COLOR7F52AF;
STICKLINE(多方趋势<空方趋势,多方趋势,空方趋势,3,0),COLORA6B8C1;
STICKLINE(多方趋势>78 AND 多方趋势>=空方趋势,多方趋势,78,5,0),COLORRED;
STICKLINE(空方趋势<=多方趋势,空方趋势,多方趋势,3,0),COLOR7F52AF;
STICKLINE(空方趋势>多方趋势,空方趋势,多方趋势,3,0),COLORA6B8C1;
STICKLINE(空方趋势<15 AND 空方趋势<=多方趋势,空方趋势,15,5,0),COLORBLUE;}
即将变盘: CROSS(机构做空能量,机构做多能量),COLORWHITE;
DRAWTEXT(即将变盘,机构做多能量,'★变盘'),COLORGRAY;
 

VAR88:=IF((YEAR >= 2050) AND (MONTH >= 1),0,1);
收益:(FINANCE(33)),COLORFFFF00;

通达信牛股预警指标公式源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号