当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信周K线副图显示指标公式(无源码的请下载附件导入)

先建一引用指标副图,名为:OCHL
ND1970:=(YEAR-1970)*365+INTPART((YEAR-1972)/4)-IF(INTPART(YEAR/4)=YEAR/4,1,0)+DAY+(MONTH-1)*30+IF(MONTH<=8,INTPART(MONTH/2),INTPART((MONTH-7)/2)+4)-IF(MONTH>2 AND INTPART(YEAR/4)=YEAR/4,1,IF(MONTH>2 AND NOT(INTPART(YEAR/4)=YEAR/4),2,0));
C1:C;
O1:REF(O,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1)));
H1:HHV(H,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1))+1);
L1:LLV(L,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1))+1);

 

再建一指标,名为:周K线副图,源码为:
WO1:="OCHL.O1#WEEK";
WC:="OCHL.C1#WEEK";
WH:="OCHL.H1#WEEK";
WL:="OCHL.L1#WEEK";
K1:=WO1=REF(WO1,1) AND WC=REF(WC,1) AND WH=REF(WH,1) AND WL=REF(WL,1);
K3:=REF(C,1)=DYNAINFO(3) AND O=DYNAINFO(4) AND C=DYNAINFO(7) AND H=DYNAINFO(5) AND L=DYNAINFO(6);
DD:=REF(BARSLAST(K1=0)+1,1),LINETHICK0;
DD1:=CROSS(BACKSET((K1=0 OR K3) AND DD=5,4),0.5),NODRAW;
DD2:=CROSS(BACKSET((K1=0 OR K3) AND (DD=4 OR DD=3),3),0.5),NODRAW;
DD3:=CROSS(BACKSET((K1=0 OR K3) AND DD<=2,2),0.5),LINETHICK0;
BK1:=DD1 OR DD2 OR DD3;
BK2:=CROSS(BACKSET(K1=0,2),0.5);
BK3:=CROSS(BACKSET(K1=0 AND REF(K1=0,1),2),0.5);
WO:IF(BARSLAST(K1=0)=0,O,REF(O,BARSLAST(K1=0))),NODRAW;
K0:=WC>WO OR (WC=WO AND WC>REF(WC,BARSLAST(K1=0)+1));
STICKLINE(K0 AND BK1,WH,WC,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND BK1,WO,WL,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND K1=0,WC,WO,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND (BK2 OR K3),WC,WO,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND ((K1 AND BK2=0 AND K3=0) OR BK3),WC,WC,8,1),COLORLIMAGENTA;
STICKLINE(K0 AND ((K1 AND BK2=0 AND K3=0) OR BK3),WO,WO,8,1),COLORLIMAGENTA;
STICKLINE(NOT(K0) AND BK1,WH,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND BK1,WC,WL,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND K1=0,WC,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND (BK2 OR K3),WC,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND ((K1 AND BK2=0 AND K3=0) OR BK3),WC,WC,8,1),COLORCYAN;
STICKLINE(NOT(K0) AND ((K1 AND BK2=0 AND K3=0) OR BK3),WO,WO,8,1),COLORCYAN;
MA1:MA(C,20),COLORWHITE;
MA2:MA(C,60),COLORYELLOW;
MA3:MA(C,120),COLORMAGENTA;

通达信周K线副图显示指标公式


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号