当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信MACD+KDJ金叉共振公式源码(无源码的请下载附件导入)

DIF:(EMA(CLOSE,6)-EMA(CLOSE,13))*100;

DEA:EMA(DIF,5);

MACD:(DIF-DEA)*2,COLORSTICK;

DRAWICON(CROSS(DIF,DEA),DEA,1);

DRAWICON(CROSS(DEA,DIF),DEA,2);

IF(DIF<DEA,DIF,DRAWNULL),COLORGREEN;

DD:=C=HHV(C,180);

EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;

CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;

顶背离:=(DD AND EE AND DEA< HHV(DEA,180))*DEA;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBROWN,LINETHICK2;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:SMA(RSV,9,3),COLORMAGENTA;

D:SMA(K,9,3),COLORBLUE;

J:3*K-2*D,COLORGRAY;

IF(J<D,J,DRAWNULL),COLORFFEE44;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

B1:=REF(C,A1+1)>C AND REF(DIF,A1+1)<DIF AND CROSS(DIF,DEA);

A22:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

B2:=REF(C,A22+1)>C AND REF("KDJ.K"(9,3,3),A22+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

DRAWTEXT(B1,DEA-0.20,'▲MACD底背'),COLORWHITE;

DRAWTEXT(B2,D-0.20,'●KDJ底背'),COLORYELLOW;

DJ:=CROSS(J,D) AND D<20;

DRAWTEXT(DJ,J-0.3,'低金叉'),COLORMAGENTA;

MDJ:=CROSS(DIF,DEA) AND DEA<0;

DRAWTEXT(MDJ,DEA-0.3,'低金叉'),COLORRED;

DRAWTEXT(CROSS(DEA,DIF),DIF+0.3,'死叉'),COLORCYAN;

DRAWTEXT(CROSS(D,J),J+0.3,'死叉'),COLORGREEN;

A:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);

DRAWICON(A,LOW*0.98,1);

B4:CROSS(DIF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

DRAWTEXT(B4,L-0.20,'★金叉共振'),COLOR0099FF;

DRAWICON(CROSS(K,D),D,1);

DRAWICON(CROSS(D,K),D,2);

BA:=DEA>REF(DEA,1);

BB:=SUM(BA,5)>=4;

BC:=C<O;

BD:=SUM(BC,5)>=2;

BXG:FILTER(BB AND BD AND J>REF(J,1) AND REF(J,1)<REF(J,2),3);

STICKLINE(BXG,HHV(J,60),HHV(J,60)-20,1,0),COLORRED;

SS:=EMA(C,11);

LL:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,5))/4;

AA:=(C-LLV(C,10))/(HHV(C,10)-LLV(C,10));

(CROSS(AA,0.05)-1);

通达信MACD+KDJ金叉共振公式源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号