当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信水下金股主图源码(无源码的请下载附件导入)

指标1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.091;

STICKLINE(指标1,CLOSE,OPEN+ABS(CLOSE-OPEN)*0.5,4,0),COLORBROWN;

STICKLINE(指标1,CLOSE,OPEN+ABS(CLOSE-OPEN)*0.5,3,0),COLOR00CACA;

STICKLINE(指标1,CLOSE,OPEN+ABS(CLOSE-OPEN)*0.5,2,0),COLOR00ECEC;

STICKLINE(指标1,CLOSE,OPEN+ABS(CLOSE-OPEN)*0.5,1,0),COLOR44FFFF;

STICKLINE(指标1,CLOSE,OPEN+ABS(CLOSE-OPEN)*0.5,0.5,0),COLORBDFFFF;

STICKLINE(指标1,CLOSE,OPEN+ABS(CLOSE-OPEN)*0.5,0.2,0),COLORD2FFFF;

STICKLINE(指标1,OPEN,OPEN+ABS(CLOSE-OPEN)*0.5,4,0),COLOR000080;

STICKLINE(指标1,OPEN,OPEN+ABS(CLOSE-OPEN)*0.5,3,0),COLOR0000AA;

STICKLINE(指标1,OPEN,OPEN+ABS(CLOSE-OPEN)*0.5,2,0),COLOR4040FF;

STICKLINE(指标1,OPEN,OPEN+ABS(CLOSE-OPEN)*0.5,1,0),COLOR5353FF;

STICKLINE(指标1,OPEN,OPEN+ABS(CLOSE-OPEN)*0.5,0.5,0),COLORB0B0FF;

STICKLINE(指标1,OPEN,OPEN+ABS(CLOSE-OPEN)*0.5,0.1,0),COLORE8E8FF;

指标2:=指标1 AND (CLOSE-OPEN)/OPEN>=0.05;

指标3:=BARSLAST(指标2);

指标4:=REF(OPEN,指标3)+(REF(CLOSE,指标3)-REF(OPEN,指标3))/2;

指标5:=REF(OPEN,指标3)+(REF(CLOSE,指标3)-REF(OPEN,指标3))*3/3;

指标6:=REF(OPEN,指标3)+(REF(CLOSE,指标3)-REF(OPEN,指标3))*0/3;

指标7:=ISLASTBAR AND COUNT(指标2,20)>=1 AND 指标4;

指标8:=指标7;

指标9:=2;

平台1:DRAWTEXT(指标8,REF(指标4,指标3),指标9),COLORBLUE;

DRAWTEXT(指标7 AND ISLASTBAR=1,REF(指标4,指标3),STRCAT(3,CON2STR(REF(指标4,指标3),2))),COLORYELLOW;

指标10:=ISLASTBAR AND COUNT(指标2,20)>=1 AND 指标5;

指标11:=指标10;

指标12:=4;

平台2:DRAWTEXT(指标11,REF(指标5,指标3),指标12),COLORBLUE;

DRAWTEXT(指标10 AND ISLASTBAR=1,REF(指标5,指标3),STRCAT(5,CON2STR(REF(指标5,指标3),2))),COLORYELLOW;

指标13:=ISLASTBAR AND COUNT(指标2,20)>=1 AND 指标6;

指标14:=指标13;

指标15:=2;

平台3:DRAWTEXT(指标14,REF(指标6,指标3),指标15),COLORBLUE;

DRAWTEXT(指标13 AND ISLASTBAR=1,REF(指标6,指标3),STRCAT(5,CON2STR(REF(指标6,指标3),2))),COLORYELLOW;

指标16:=(MA(VOL,5)+MA(VOL,10)+MA(VOL,20))/3;

指标17:=2;

指标18:=VOL>指标17*REF(指标16,1) AND VOL>指标17*HHV(REF(VOL,1),12);

指标19:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.09;

指标20:=指标18 AND 指标19 AND VOL>REF((MA(VOL,5)+MA(VOL,10)+MA(VOL,20))/3,1)*指标17;

指标21:=BARSLAST(指标20);

指标22:=指标20;

指标23:=2;

画线平台:DRAWTEXT(指标20,REF(CLOSE,指标21+1),指标23),COLORLIMAGENTA;

DRAWTEXT(指标20 AND ISLASTBAR=1,REF(CLOSE,指标21+1),STRCAT(5,CON2STR(REF(CLOSE,指标21),2))),COLOR800080;

指标24:=EMA(CLOSE,12)-EMA(CLOSE,26);

指标25:=EMA(指标24,9);

指标26:=BARSLAST(CROSS(指标24,指标25) AND 指标25<0 AND 指标24<0);

指标27:=CURRBARSCOUNT=CONST(指标26)+1;

指标28:=BARSLAST(指标27);

指标29:=FINDHIGHBARS(HIGH,BARSLAST(CROSS(指标25,指标24) AND 指标25>0)+1,指标26+1,1);

指标30:=CURRBARSCOUNT=CONST(指标29)+1;

指标31:=BARSLAST(指标30);

指标32:=COUNT(CROSS(指标24,指标25),指标31)=1;

BB:LLV(REF(LOW,2),指标31),DOTLINE,COLORMAGENTA;

指标33:=DRAWLINE(指标30,HIGH,ISLASTBAR,REF(HIGH,指标29),0);

指标34:=DRAWLINE(指标31=0,HIGH,指标28=0,LOW,0);

指标35:=BARSLAST(CROSS(指标24,指标25) AND 指标24<0 AND 指标25<0);

指标36:=指标24<0 AND 指标25<0 AND 指标25>REF(指标25,1) AND 指标24>指标25;

指标37:=LAST(指标36,指标35+1,0) AND 指标24>指标25;

指标38:=REF(指标25,指标35+1)<指标25 AND REF(LOW,指标35+1)>LOW AND CROSS(BB,LOW) AND COUNT(指标28=0,24)=1 AND 指标25<0 AND 指标24>指标25;

DRAWLINE(指标35=0,REF(LOW,指标35),指标38,LOW,0),COLORYELLOW,LINETHICK2;

MA5:MA(CLOSE,5);

指标39:=REFDATE(REF(CLOSE,指标21+1),DATE);

DRAWTEXT(指标38,BB,STRCAT(6,CON2STR(BB,2))),COLORYELLOW;

 通达信水下金股主图源码




关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号