当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是10年评测成功率80%——春秋守株待兔(副图、通达信、贴图)(无源码的请下载附件导入)

按下面的评测方式,可以测80%


 {买1}
买1:=IF(CROSS(3*SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100,5,1),3,1),10),38,0);
 {买2}
 BIAS1:=(C-MA(C,6))/MA(C,6)*100;
 BIAS2:=(C-MA(C,12))/MA(C,12)*100;
 BIAS3:=(C-MA(C,24))/MA(C,24)*100;
 BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离1:=MA(BIAS,3);
乖离:=CROSS(BIAS,乖离1) AND 乖离1<-9;
买2:=IF(CROSS(BIAS,乖离1) AND 乖离1<-9,18,0);
 {买3}
 TRJ:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),5);
 HD:=(HIGH - REF(HIGH,1));
 LD:=(REF(LOW,1) - LOW);
 DMP:=(SUM(IF(((HD > 0) AND (HD > LD)),HD,0),5) );
 DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),5);
神偷线:=(((DMP ) * 100) / TRJ);
辅助线:=((DMM * 100) / TRJ);
动向趋势线:=(MA(((ABS((辅助线 - 神偷线)) / (辅助线 + 神偷线)) * 100),3));
 ADXR:=((动向趋势线 + REF(动向趋势线,3)) / 2);
 VAR3:=MA(CLOSE,2);
 VAR7:=REF(VAR3,1);
强弱:=((SMA(MAX((VAR3 - VAR7),0),5,1) / SMA(ABS((VAR3 - VAR7)),5,1)) * 100);
 VAR31:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)-
 3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1);
 VAR32:=8;
CC3:=CROSS(VAR31,VAR32);
买3:=( IF(((动向趋势线 > 88) AND (神偷线 < 5.8)),68,0)) AND CC3;
 {买4}
 VAR1:=(CLOSE*2+HIGH+LOW)/4;
 SK:= EMA(VAR1,13)-EMA(VAR1,73);
 SD:= EMA(SK,2);
 V1:=(CROSS(SK,SD) AND SK<-0.04 AND (C-REF(C,1))/REF(C,1)>=0.03)
 OR (CROSS(SK,SD) AND SK<=-0.14 ) OR (CROSS(SK,SD) AND SK<=0.05
 AND (V/MA(V,5)>2 OR C/REF(C,1)>0.035));
买4:=V1;
 {买5}
 FX1:=MA(CLOSE,1);
 FX2:=(LOW+HIGH+CLOSE)/3;
 FX3:= MA(FX2,5);
 FX4:=LLV(FX3,10);
买5:=LLV((FX1<FX4),5);
 {买6}
 A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
 A4:=SMA(A3,3,1);
 A5:=SMA(A4,3,1);
 A6:=3*A4-2*A5;
 A7:=C-REF(C,1);
 A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
 MAI1:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
 AR1:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
 MAI2:=CROSS(AR1,REF(AR1+0.01,1)) AND LLV(AR1,2)=LLV(AR1,8) AND AR1<20;
买6:=MAI1 AND MAI2;
 {买7}
 AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
 BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
 AA10:=MA(C,10);
 AA20:=MA(C,20);
 BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
 AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
 BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击选股:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)
 AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
 MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买7:=IF(FILTER(MR,10),1,0);
 {买8}
 LC8:=REF(CLOSE,1);
 RSI5:=((SMA(MAX((CLOSE - LC8),0),5,1) / SMA(ABS((CLOSE - LC8)),5,1)) * 100);
 TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
 HD8:=(HIGH - REF(HIGH,1));
 LD8:=(REF(LOW,1) - LOW);
 DMP8:=SUM(IF(((HD8 > 0) AND (HD8 > LD8)),HD8,0),10);
 DMM8:=SUM(IF(((LD8 > 0) AND (LD8 > HD8)),LD8,0),10);
 PDI8:=((DMP8 * 100) / TR1);
 MDI8:=((DMM8 * 100) / TR1);
 ADX:=MA(((ABS((MDI8 - PDI8)) / (MDI8 + PDI8)) * 100),5);
 AV:=(RSI5 + ADX);
 DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
 WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
 NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
最佳买入选股:=IF(CROSS(最佳买入,0),1,0);
 VARM1:=SMA(最佳买入选股,3,1);
 VARM2:=SMA(VARM1,3,1);
 VARM3:=SMA(VARM2,3,1);
买8:=IF(CROSS(VARM2,VARM3) AND (VARM2<40),5,0*10000);
 {买9}
 AR1A:=3*SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1)-2*SMA(SMA((C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100,3,1),3,1);
短买:=CROSS(AR1A,REF(AR1A+0.01,1)) AND LLV(AR1A,2)=LLV(AR1A,8) AND AR1A<20;
买9:=短买;
 {买10}
 A17:=C-REF(C,1);
 A18:=100*EMA(EMA(A17,6),6)/EMA(EMA(ABS(A17),6),6);
买10:=(LLV(A18,2)=LLV(A18,7) AND COUNT(A18<0,2) AND CROSS(A18,MA(A18,2)));
 A999:=IF(买6+买9+(买8=5)>=2 AND 买7>0,100,0);
 A9999:=IF(A999>0,0,买7);
守株待兔:买6+买9+(买8=5)+A9999+A999+买10 >=100;

 


10年评测成功率80%——春秋守株待兔(副图、通达信、贴图)

10年评测成功率80%——春秋守株待兔(副图、通达信、贴图)

10年评测成功率80%——春秋守株待兔(副图、通达信、贴图)

10年评测成功率80%——春秋守株待兔(副图、通达信、贴图)





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号