当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信MACD看透主力T 副图指标(无源码的请下载附件导入)

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
 OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);
 OBV2:=EMA(OBV1,3)-MA(OBV1,9);
 OBV3:=EMA(IF(OBV2>0,OBV2,0),3);
 MAC3:=MA(C,3);
 SHORT:=12;LONG:=26;MID:=9;
 DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW ;
 DEA:EMA(DIF,MID)COLORFF9900 ;
 MACD:=(DIF-DEA)*2;
 STICKLINE(OBV3>REF(OBV3,1) AND MAC3>REF(MAC3,1),0,MACD,2,0),COLORYELLOW;
吸:=XLPL.NOTEXT吸;
拉:=XLPL.NOTEXT拉;
派:=XLPL.NOTEXT派;
落:=XLPL.NOTEXT落;
STICKLINE(吸,0,MACD,1,0),COLORLIRED;
 STICKLINE(拉,0,MACD,1,0),COLORRED;
 STICKLINE(派,0,MACD,1,0),COLORGREEN;
 STICKLINE(落,0,MACD,1,0),COLORWHITE;
入1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLORRED,LINETHICK2;
入2:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLOR00FF00,LINETHICK2;
低位金叉:=CROSS(DIF,DEA) AND DIF<-0.1;
 STICKLINE(低位金叉,0,0.08,6,0),COLORFF00FF;
 DRAWTEXT(低位金叉,0.5,' 低位金叉'),COLORWHITE;
 JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
 STICKLINE(二次金叉,0,0.06,6,0),COLORFFCC00;
 DRAWICON(二次金叉,DEA*0.9,1) ;
 DRAWTEXT(二次金叉,1,' 二次金叉'),COLORYELLOW;
 A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);
 STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;
 DRAWTEXT(底背离,1.5,' 底背离'),COLORFF00FF;
 A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);
 DRAWTEXT(低位金叉 AND 二次金叉 AND 底背离,2,'三全项'),COLOR0000FF,LINETHICK2;

通达信MACD看透主力T 副图指标




关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号