当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信2016好主图源码主图(无源码的请下载附件导入)

可以看到买卖力度、大单流入力度、资金流入力度、活跃度和饱和度,可能需要L2数据,是个好主图

超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
大宗进限制:=IF((超B+大B)=0,0,大宗进);
大宗出限制:=IF((超S+大S)=0,0,大宗出);
非大宗进限制:=IF(中B+小B=0,0,非大宗进);
非大宗出限制:=IF(中S+小S=0,0,非大宗出);
主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;
散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;
净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;
大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;
大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);
大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;
大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);
总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;
总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;
成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;
机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;
大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;
大单强度限制:=IF(大单强度=0,-100,大单强度);
大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;
超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;
超单强度限制:=IF(超单强度=0,-100,超单强度);
超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;

DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(940-(ABS(大宗进)*250/DAZHIV)),30,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(32,CONST(940-(ABS(大宗出)*250/DAZHIV)),62,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(70,CONST(940-(ABS(非大宗进)*250/DAZHIV)),100,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(102,CONST(940-(ABS(非大宗出)*250/DAZHIV)),132,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(138,CONST(950-(ABS(净流入)*250/DAZHIV))-20,175,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.033,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.07,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.101,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.138,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;
DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;
DRAWTEXT_FIX(1,0.072,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.135,0.99,0,'净流入:(万)'),COLORYELLOW;


主买A:=ACTINVOL,COLORRED,NODRAW;
主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;
主买:=主买A*100/(主买A+主卖A),NODRAW,COLORRED;
主卖:=主卖A*100/(主买A+主卖A),NODRAW,COLORGREEN;

大单买比:=LARGEINTRDVOL*100/(LARGEINTRDVOL+LARGEOUTTRDVOL);
大单卖比:=LARGEOUTTRDVOL*100/(LARGEINTRDVOL+LARGEOUTTRDVOL);
主力净买量:=(LARGEINTRDVOL-LARGEOUTTRDVOL),COLORYELLOW,NODRAW;
主动买卖差:=(ACTINVOL-ACTOUTVOL),COLORMAGENTA,NODRAW;
主力资金差:=((L2_AMO(0,0)+L2_AMO(1,0)-L2_AMO(0,1)-L2_AMO(1,1)))/10000,COLORCYAN,NODRAW;
主力买力度:=LARGEINTRDVOL*100/VOL;
主力卖力度:=LARGEOUTTRDVOL*100/VOL;
主买力度比:=主力买力度/(主力买力度+主力卖力度)*100,NODRAW;
主卖力度比:=主力卖力度/(主力买力度+主力卖力度)*100,NODRAW;
力度比限制:=IF((LARGEINTRDVOL+LARGEOUTTRDVOL)=0,0,大单买比);
JGV:=(L2_VOL(0,0) - L2_VOL(0,1))*VOL/100000000,COLORRED;
DHV:=(L2_VOL(1,0) - L2_VOL(1,1))*VOL/100000000,COLORFF00FF;
ZHV:=(L2_VOL(2,0) - L2_VOL(2,1))*VOL/100000000,COLOR00FFFF;
SHV:=(L2_VOL(3,0) - L2_VOL(3,1))*VOL/100000000,COLORFFFFFF;
NOTEXT大量动向:=MA((JGV+DHV),5),COLORYELLOW;
超级大量:=JGV,COLOR0000FF,NODRAW;
机构大量:=DHV,COLORMAGENTA,NODRAW;
大量博弈:=(JGV+DHV),COLORYELLOW,NODRAW;
小量博弈:=(ZHV+SHV),COLORWHITE,NODRAW;
大量资金比:=大量博弈/(ABS(JGV)+ABS(DHV)+ABS(ZHV)+ABS(SHV))*100,COLORYELLOW,NODRAW;
大量资金比限制:=IF(大量资金比=0,-100,大量资金比);
大量强度比:=IF(大量资金比>0,(大量资金比限制+100)/2,IF(大量资金比<0,100-ABS((大量资金比限制-100)/2),0)),COLORGREEN,NODRAW;
小量资金比:=小量博弈/(ABS(JGV)+ABS(DHV)+ABS(ZHV)+ABS(SHV))*100,COLORYELLOW,NODRAW;
小量强度比:=IF(小量资金比>=0,(小量资金比+100)/2,100-ABS((小量资金比-100)/2)),COLORCYAN,NODRAW;

MVR:=REF(MA(V,5),1);
FVR:=REF(V,1);
PVR:=(MVR+FVR)/2;
量能比:=V/(V+PVR)*100/FROMOPEN*240;

{量能饱和度}
SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));
【量能饱和】:=IF(SAT>1,1,SAT)*100,COLORYELLOW,NODRAW;
{活跃度}
LC:=REF(CLOSE,1);
RSI5:=(SMA(MAX(CLOSE-LC,0),3,1))/(SMA(ABS(CLOSE-LC),3,1))*100;
WR10:=(HHV(HIGH,3)-CLOSE)/(HHV(HIGH,3)-LLV(LOW,3))*100;
活跃度:=(RSI5-WR10),COLORFFFF00,LINETHICK1,NODRAW;
活跃度比:=IF(活跃度>=0,(活跃度+100)/2,100-ABS((活跃度-100)/2));

DRAWRECTREL(80,0,240,40,RGB(0,75,200));
DRAWRECTREL(80,0,160,40,RGB(0,250,50));
DRAWRECTREL(80,0,80+CONST(力度比限制*160/100),40,RGB(200,0,50));
DRAWTEXT_FIX(1,0.00,0.00,0,STRCAT(STRCAT('买卖力度比 ',CON2STR(大单买比,2)),'%买')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.33,0.00,0,STRCAT(STRCAT('',CON2STR(大单卖比,2)),'%卖')),COLORGREEN;}
DRAWRECTREL(80,50,240,90,RGB(0,100,0));
DRAWRECTREL(80,50,160,90,RGB(0,250,50));
DRAWRECTREL(80,50,80+CONST(大量强度比*160/100),90,RGB(175,50,250));
DRAWTEXT_FIX(1,0.00,0.05,0,STRCAT(STRCAT('大量强度比 ',CON2STR(大量强度比,2)),'%买')),COLORYELLOW;
DRAWRECTREL(330,0,490,40,RGB(0,75,200));
DRAWRECTREL(330,0,410,40,RGB(0,250,50));
DRAWRECTREL(330,0,330+CONST(主买*160/100),40,RGB(175,50,250));
DRAWTEXT_FIX(1,0.25,0.00,0,STRCAT(STRCAT('主动买卖比 ',CON2STR(主买,2)),' %')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.33,0.10,0,STRCAT(STRCAT('',CON2STR(主卖,2)),'%卖')),COLORGREEN;}
DRAWRECTREL(330,50,490,90,RGB(0,100,0));
DRAWRECTREL(330,50,410,90,RGB(0,250,50));
DRAWRECTREL(330,50,330+CONST(机构参与度*160/100),90,RGB(200,0,50));
DRAWTEXT_FIX(1,0.25,0.05,0,STRCAT(STRCAT('机构参与度 ',CON2STR(机构参与度,2)),' %')),COLORYELLOW;

DRAWRECTREL(580,0,740,40,RGB(0,100,0));
DRAWRECTREL(580,0,660,40,RGB(0,250,50));
DRAWRECTREL(580,0,580+CONST(大单流入限制*160/100),40,RGB(200,0,50));
DRAWTEXT_FIX(1,0.500,0.00,0,STRCAT(STRCAT('大单流入比 ',CON2STR(大单流入限制,2)),' %买')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.83,0.01,0,STRCAT(STRCAT('',CON2STR(大单流出限制,2)),' %卖')),COLORGREEN;}
DRAWRECTREL(580,50,740,90,RGB(0,200,250));
DRAWRECTREL(580,50,660,90,RGB(0,250,50));
DRAWRECTREL(580,50,580+CONST(大单强度比*160/100),90,RGB(175,50,250));
DRAWTEXT_FIX(1,0.500,0.05,0,STRCAT(STRCAT('大单强度比 ',CON2STR(大单强度比,2)),' %买')),COLORYELLOW;
DRAWRECTREL(830,0,990,40,RGB(0,100,0));
DRAWRECTREL(830,0,910,40,RGB(0,250,50));
DRAWRECTREL(830,0,830+CONST(总流入比*160/100),40,RGB(175,50,250));
DRAWTEXT_FIX(1,0.75,0.00,0,STRCAT(STRCAT('资金流入比 ',CON2STR(总流入比,2)),' %')),COLORYELLOW;
{DRAWTEXT_FIX(1,0.83,0.10,0,STRCAT(STRCAT('',CON2STR(总流出比,2)),' %卖')),COLORGREEN;}
DRAWRECTREL(830,50,990,90,RGB(0,200,250));
DRAWRECTREL(830,50,910,90,RGB(0,250,50));
DRAWRECTREL(830,50,830+CONST(量能比*160/100),90,RGB(200,0,50));
DRAWTEXT_FIX(1,0.75,0.05,0,STRCAT(STRCAT('资金量能比 ',CON2STR(量能比,2)),' %')),COLORYELLOW;

DRAWRECTREL(365,890,655,930,RGB(0,100,0));
DRAWRECTREL(365,890,510,930,RGB(0,200,50));
DRAWRECTREL(365,890,360+CONST(活跃度比*300/100),930,RGB(150,10,250));
DRAWTEXT_FIX(1,0.318,0.89,0,STRCAT(STRCAT('活跃度 ',CON2STR(活跃度比,2)),' %')),COLORYELLOW;
DRAWRECTREL(365,940,655,985,RGB(0,50,150));
DRAWRECTREL(365,940,510,985,RGB(0,200,50));
DRAWRECTREL(365,940,360+CONST(【量能饱和】*300/100),985,RGB(150,10,0));
DRAWTEXT_FIX(1,0.318,0.95,0,STRCAT(STRCAT('饱和度 ',CON2STR(【量能饱和】,2)),' %')),COLORYELLOW;
布林轨:(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4,COLORRED,LINETHICK2;
MA3:=MA(CLOSE,20),COLORMAGENTA,LINETHICK2;
DRAWBAND(布林轨,RGB(250,125,50),MA3,RGB(0,150,250));
MA1:MA(CLOSE,5),COLORWHITE;
MA2:MA(CLOSE,10),COLORYELLOW;
IF(布林轨<MA3 OR C<布林轨,布林轨,DRAWNULL),COLORBLUE,LINETHICK2;
涨势线:IF(布林轨>MA3,MA3,DRAWNULL),COLORMAGENTA,LINETHICK3;
跌势线:IF(布林轨<=MA3,MA3,DRAWNULL),COLORLIBLUE,LINETHICK2;
MA4:MA(CLOSE,60),COLORGREEN;
HLCO:=(C+H+L+O)/4;
MAHC:=MA((CLOSE*2+H)/3,5),COLOR0000FF;
MAHO:=MA((O*2+H)/3,5),COLOR00FF00;
MALC:=MA((C+L*2)/3,5),COLORFFFFFF;
MALO:=MA((O+L*2)/3,5),COLOR00FFFF;
CO:=O+(C-O)/2;
DRAWKLINE(H,O,L,C);
STICKLINE(MAHC>=MAHO,C,O,2.9,0),COLOR000099;
STICKLINE(MAHC>=MAHO,C,O,1.5,0),COLOR0000CC;
STICKLINE(MAHC>=MAHO,C,O,0.1,0),COLOR9966FF;
STICKLINE(MAHC<MAHO,C,O,2.9,0),COLOR999900;
STICKLINE(MAHC<MAHO,C,O,1.5,0),COLORCCCC00;
STICKLINE(MAHC<MAHO,C,O,0.1,0),COLORFFFF66;
STICKLINE(MAHC>=MAHO AND C<MAHO,CO,MAX(O,C),2.8,0),COLORMAGENTA;
{STICKLINE(LC>MAHC,CO,MAX(C,O),2.8,0),COLORRED;
STICKLINE(LC<MAHC,CO,MIN(C,O),2.8,0),COLORCYAN;}
STICKLINE(CROSS(MAHC,MAHO),C,O,2.8,0),COLORYELLOW;
STICKLINE(MAHC<MAHO AND (CROSS(C,MALO) OR CROSS(HLCO,MALO)),C,O,2.8,0),COLORWHITE;
STICKLINE(CROSS(MAHO,MAHC),C,O,2.8,0),COLORFF3300;
{STICKLINE(REF(C,1)<LC AND C>=LC AND CROSS(C,MAX(MAHC,MAHO)),CO,MIN(C,O),2.8,0),COLORYELLOW;}
{STICKLINE(REF(C,1)<LC AND C>=LC AND CROSS(C,MAHC) AND MAHC>MAHO,C,O,2.8,0),COLORYELLOW;}

倍量攻击:=V>REF(V,1)*2 AND (C>=O OR C>REF(C,1)),COLORRED,NODRAW;
STICKLINE(倍量攻击,C,O,0.5,0),COLOR0088FF;

角线:=(ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926);
角线MA:=MA(角线,5);
ANA:=PLOYLINE(CROSS(角线,角线MA),角线MA),COLORRED;
ANB:=PLOYLINE(CROSS(角线MA,角线),角线MA),COLORFF00FF ;
角买点:=CROSS(角线,角线MA) AND ((ANB>REF(ANB,1) AND ANB>ANA AND 角线MA<=0) OR ((角线MA<=-45 OR CROSS(角线MA,-45)) AND (ANB<-60 OR LLV("KDJ.J",3)<=-49) AND ANB>0)),COLORGREEN;
角起涨:=COUNT(CROSS(角线,角线MA),ANA<REF(ANA,5) AND ANB>REF(ANB,5));
角卖点:=(CROSS(角线MA,角线) AND (ANB>REF(ANB,1) OR ANA<REF(ANA,1)) AND ANB>ANA{AND ANB>0} AND 角线MA>0)*1;
角始跌:=COUNT(CROSS(角线MA,角线),ANA<REF(ANA,5) AND ANB>REF(ANB,5));
DRAWTEXT(倍量攻击,L,'VOL');
DRAWTEXT(CROSS(MAHO,MAHC) AND C<布林轨,H,'空仓'),COLORFFFF00;
DRAWTEXT(角买点,L,'角买'),COLORMAGENTA;
DRAWTEXT(角卖点,H,'角卖'),COLORGREEN;

通达信2016好主图源码主图

通达信2016好主图源码主图





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号