当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信十个指标合一副图指标(无源码的请下载附件导入)

通达信十个指标合一副图指标

源码

N:=8;ZF:=5;M:=3;N10:=9;P1:=3;P2:=3;

MA5 := MA(CLOSE,5);
MA10 := MA(CLOSE,10);
MA60 := MA(CLOSE,60);
PDAY1 := BARSLAST(CROSS(MA60,MA5));{5日均线下穿60日均线}
PDAY2 := BARSLAST(CROSS(MA60,MA10));{10日均线下穿60日均线,至此形成鸭颈部}
PDAY3 := BARSLAST(LOW=LLV(LOW,PDAY2));{形成头部,要反弹}
PDAY4 := BARSLAST(CROSS(MA5,MA10));{反弹后,5日均线和10日均线金叉}
PDAY5 := BARSLAST(CROSS(MA10,MA5));{反弹不久,5日均线和10日均线形成死叉,形成嘴部}
A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;
A2:= COUNT(CROSS(MA10,MA5),PDAY2)=1;

唐鸭头:A1 AND A2,COLORFFFF00;
DRAWTEXT(唐鸭头,0.8 , '唐鸭头'),COLORRED;
VAR1:=MA(CLOSE,5);
VAR2:=MA(CLOSE,10);
VAR3:=MA(CLOSE,60);
VAR4:=BARSLAST(CROSS(VAR1,VAR3));
VAR5:=BARSLAST(CROSS(VAR2,VAR3));
VAR6:=BARSLAST(HIGH=HHV(HIGH,VAR5));
VAR7:=BARSLAST(CROSS(VAR2,VAR1));
VAR8:=BARSLAST(CROSS(VAR1,VAR2));
VAR9:=VAR4>VAR5 AND VAR5>VAR6 AND VAR6>VAR7 AND VAR7>VAR8 AND VAR8<5;
VARA:=COUNT(CROSS(VAR2,VAR1),VAR5)=1;
老鸭头:VAR9 AND VARA  AND VAR3>REF(VAR3,1),COLORFF00FF;
DRAWTEXT(老鸭头 ,0.8 , '老鸭头'),COLORRED;
NA1:=MIN(MA(C,5),MA(C,10))>MA(C,60) AND CROSS(MA(C,5),MA(C,10));
NA2:=MIN(MA(C,5),MA(C,10))/MA(C,60)<1.05;
NA3:=COUNT(V<MA(V,10),10)>6;
青龙取水:NA1 AND NA2 AND NA3,COLOR00FF00,LINETHICK2;
DRAWTEXT(青龙取水 ,0.8 , '青龙取水'),COLORRED;
线:=MA(C,180)>REF(MA(C,180),2) AND COUNT(CROSS(MA(C,5),MA(C,180)),6)>=1 AND C/MA(C,180)>1.04,COLORBLUE;
穿180线:=MA(C,180)>REF(MA(C,180),2) AND COUNT(CROSS(MA(C,5),MA(C,180)),6)>=1 AND C/MA(C,180)>1.04,COLORBLUE;
DRAWTEXT(穿180线,0.8 , '180'),COLORBLUE;
VAR32:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR33:=SMA(SMA(VAR32,3,1),3,1)/28.57;
VAR34:=EMA(VAR33,5);
VAR35:=3*VAR33-2*VAR34;
绝买:CROSS(VAR35,VAR33) AND VAR33<2.1 AND C>O,COLORRED;
DRAWTEXT(绝买,0.9,'绝买'),COLORRED;
SS1:=(LOW+HIGH+CLOSE*2)/4;
SS2:= MA(SS1,4);
SS3:=HHV(SS2,10);
SS4:=MA(SS3,3);
SS5:=1.25*SS4-0.25*SS3;
XKKJ:=IF(SS5>SS3,SS3,SS5);
FF1:=LLV(SS2,10);
FF2:=MA(FF1,3);
FF3:=1.25*FF2-0.25*FF1;
DKKJ:=IF(FF3<FF1,FF1,FF3);
MA13:=MA(C,13);
ZDHM:=CROSS(C,DKKJ) AND CROSS(C,MA13) AND CROSS(C,XKKJ);
ZHM:=CROSS(C,MA13) AND CROSS(C,XKKJ);
的卢:ZDHM OR ZHM,COLORGREEN;
DRAWTEXT(的卢,0.5,'的卢'),COLORRED;
MA111:=MA(CLOSE,20);
MA112:=MA(CLOSE,40);
MA113:=MA(CLOSE,60);
A11:=OPEN<MA111 OR OPEN<MA112 OR OPEN<MA113,COLORRED;
A12:=C>MAX(MA111,MAX(MA112,MA113)),COLORRED;
A13:=V/MA(V,30)>1.2,COLORRED;
A14:=C/REF(C,1)>1.049,COLORRED;
芙蓉:A11 AND A12 AND A13 AND A14,COLORWHITE;
DRAWTEXT(芙蓉,0.3,'出水芙蓉'),COLORWHITE;
J:=(C*2+H+L)/4;
K:=(EMA(J,13) - EMA(J,21))*180;
D:=EMA(K,2);
KK:=(K-D);
DD:=-1*(K-D);
SS:=CROSS(KK,DD);
VARBB:=EMA(EMA(CLOSE,5),5);
LL:=(VARBB-REF(VARBB,1))/REF(VARBB,1)*1000;
MM:=CROSS(LL,0);
黄买蓝出:=SS  AND MM,COLORYELLOW;
DRAWTEXT(黄买蓝出,0.47,'黄买'),COLORRED;
RSV100:=(CLOSE-LLV(LOW,N10))/(HHV(HIGH,N10)-LLV(LOW,N10))*100;
K10:=SMA(RSV100,P1,1);
D10:=SMA(K10,P2,1);
J10:=3*K10-2*D10;
KDJ买点:=J10<0,COLOR0066FF;
DRAWTEXT(KDJ买点,0.6,'K买'),COLOR0066FF;
VAR201:=CLOSE-REF(CLOSE,1);
VAR202:=IF(CLOSE-REF(CLOSE,1)>=0,VAR201,0);
VAR203:=REF(CLOSE,1)-CLOSE;
VAR204:=IF(CLOSE-REF(CLOSE,1)<=0,VAR203,0);
VAR205:=SUM(VAR202,8)/SUM(VAR204,8);
VAR206:=1-1/(1+VAR205);
短线:= EMA(VAR206,3),COLORYELLOW;
VAR207:=LLV(LOW,50);
VAR208:=HHV(HIGH,50);
VAR209:=EMA(CLOSE,2);
中线:=EMA((VAR209-VAR207)/(VAR208-VAR207),8),COLOR00FF00;
 

通达信十个指标合一副图指标





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号