当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信 突破系列选股器给大家(无源码的请下载附件导入)

通达信 “突破系列”选股器给大家
1.平台整理突破
{NEW186 平台突破}
REG20:=SLOPE(C,20);
 REG10:=SLOPE(C,10);
 MID:=(C O)/2;
 MIDHIGH:=HHV(MID,6);
 MIDLOW:=LLV(MID,6);
 HIGHLOW:=(MIDHIGH-MIDLOW)/MIDLOW < 10/100;
 HIGH5V:=MA(C,5)>HHV(MA(C,5),10)*0.98;
 MA5BIG:=MA(C,5)-REF(MA(C,5),1) < 20/1000;
 MA5SMALL:=MA(C,5)-REF(MA(C,5),1) > -1*20/1000;

OK:=REG20>0.005 AND REG10>0.01 AND HIGHLOW AND HIGH5V AND
 MA5BIG AND MA5SMALL;
 A11:=REF(OK,1)=1 OR REF(OK,2)=1 OR REF(OK,3)=1;
 AA2:=MAX(O,C);
 A22:=C>HHV(REF(AA2,1),6);
 OKOK:(A11 AND A22);

2.五弯十突破
{NEW188 五弯十突破}
A1:=MA(C,5);
 B1:=MA(C,10);
 C1:=(A1-B1)/B1;
 D1:=C1>REF(C1,1) AND MA(C,5)>MA(C,10) AND MA(C,5)>REF(A1,1);
 E1:=C1
 F1:=MA(C,10)>REF(B1,1);
 G1:=VOL<=REF(VOL,1)*1.3;
 H1:=REF(SUM(D1,5),3)>=2 OR REF(SUM(D1,5),4)>=2 OR REF(SUM(D1,5),2)>=2;
 J1:=COUNT(A1=1;
 K20:=SLOPE(CLOSE,20)>0.0051;
 K10:=SLOPE(CLOSE,10)>0.01;

OK:=A1< REF(A1,3)*0.993;
 OKK:=SUM(E1,3)>=2 AND H1 AND SUM(F1,5)>=4 AND F1
 AND ABS(C1)<0.02 AND G1 AND J1 AND K20 AND K10 AND OK;

A11:=REF(OKK,1)=1 OR REF(OKK,2)=1 OR REF(OKK,3)=1;
 A22:= MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND C>HHV(REF(C,1),3);
 OKOK:(A11 AND A22);

3.回调突破
{NEW190 回调突破}
E:=(HHV(H,100)-LLV(L,100))/LLV(L,100)/6;
 A:=(H L C O)/4*(1 E);
 B:=(H L C O)/4*(1-E);
 F:=(H L C O)/4;

OKK:=BARSLAST(CROSS(MA(C,10),MA(C,5)));
 D2:=HHV(H,2)B AND (OKK > 2 ) AND (OKK < 8);
 D3:=HHV(H,3)B AND (OKK > 3 ) AND (OKK < 9);
 D4:=HHV(H,4)B AND (OKK > 4 ) AND (OKK < 10);
 D5:=HHV(H,5)B AND (OKK > 5 ) AND (OKK < 11);
 D6:=HHV(H,6)B AND (OKK > 6 ) AND (OKK < 12);
 D7:=HHV(H,7)B AND (OKK > 7 ) AND (OKK < 13);
 D8:=HHV(H,8)B AND (OKK > 8 ) AND (OKK < 14);
 D9:=HHV(H,9)B AND (OKK > 9 ) AND (OKK < 15);
 D10:=HHV(H,10)B AND (OKK > 10 ) AND (OKK < 16);
 D11:=HHV(H,11)B AND (OKK > 11 ) AND (OKK < 17);
 D12:=HHV(H,12)B AND (OKK > 12 ) AND (OKK < 18);

S15DOWN:=SLOPE(C,15) < -0.01;
 S15UP:=SLOPE(C,15) > -0.05;
 S30:=SLOPE(C,30) > 0.01;

OK:=(D2 OR D3 OR D4 OR D5 OR D6 OR D7 OR D8 OR D9 OR D10 OR D11 OR D12) AND
 S15DOWN AND S15UP AND S30;

{原公式此码缺失,本突破的源码为推测}
A11:=REF(OKK,1)=1 OR REF(OKK,2)=1 OR REF(OKK,3)=1;
 A22:= MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND C>HHV(REF(C,1),3);
 OKOK:(A11 AND A22);

4.稍长整理突破
{NEW184 稍长整理突破}
QSH1:=MA(C,10);
 QSH:=SLOPE(QSH1,2)>0.03;
 BA:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;
 GG:=BA
 CC:=MA(C,5);
 B1:=AMOUNT/V/100;
 B2:=(MAX(O,CC) H)/2;
 B3:=(MIN(O,CC) L)/2;
 A1:=(B1 B2 B3)/3;
 A3:=2*STD(A1,3)*100;
 TJ1:=COUNT(A3=1;
 TJ2:=COUNT(MA(CC,5)>=REF(MA(CC,5),1),5)>=3;
 TJ3:=REF(CC,5)>REF(CC,6)*1.03
 OR REF(CC,4)>REF(CC,5)*1.03
 OR REF(CC,4)>REF(CC,6)*1.05;
 TJ4:=COUNT(V=3;
 TJ5:=MA(C,7)>REF(MA(C,7),1) AND LLV(C,2)>REF(L,4) AND LLV(C,2)>REF(L,5);
 TJ6:=REF(SLOPE(MA(C,5),2)*100,2)>5 AND SLOPE(MA(C,5)*100,2)>4 AND
 MA(C,5)>REF(MA(C,5),1) AND MA(C,10)>REF(MA(C,10),1);
 OK:=TJ1 AND TJ2 AND TJ3 AND TJ4 AND TJ5 AND TJ6 AND C>MA(C,30) AND QSH AND GG;

A11:=REF(OK,1)=1 OR REF(OK,2)=1;
 A22:=C>HHV(REF(H,1),6);
 OKOK:(A11 AND A22);

5.回挡突破
{NEW180 回挡突破}
A1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
 A2:=(HIGH-LOW)/LOW;
 A3:=LOW>=REF(CLOSE,2);
 A4:=(CLOSE-REF(CLOSE,2))/REF(CLOSE,2)>0.035;
 A5:=MA(CLOSE,5);
 TJ:=REF(A1,1)>0.03 AND A1<0.03 AND A2A5 AND SLOPE(A5,2)>3/100;

T1:=REF(TJ,1)=1 OR REF(TJ,2)=1;
 T2:=CLOSE>HHV(REF(H,1),3);
 T1 AND T2;

6.短暂整理突破
{NEW182 短暂整理突破}
A1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1);
 A2:=(HIGH-LOW)/LOW;
 A3:=LOW>=REF(CLOSE,2);
 A4:=(CLOSE-REF(CLOSE,2))/REF(CLOSE,2)>0.035;
 A5:=MA(CLOSE,5);
 TJ:=REF(A1,1)>0.03 AND A1<0.03 AND A2A5 AND SLOPE(A5,2)>3/100;

QSH1:=MA(C,5);
 QSH:=SLOPE(QSH1,2)>0.015;
 BA:=(CLOSE-MA(C,5))/MA(C,5)*100;
 GG:=BA
 AA:=REF(TJ,1)=1;
 BB1:=MAX(C,O);
 BB2:=MIN(C,O);
 B1:=BB1REF(C,3);
 CC1:=(C-REF(C,1))/REF(C,1);
 C1:=CC1<0.03;
 CC:=AA AND B1 AND C1 AND QSH AND GG;
 D1:=REF(TJ,2)=1 AND REF(CC,1)=1;
 E1:=CC1<0.03 AND CC1
 EE:={D1 AND }E1 AND QSH AND GG;
 DZ:=CC OR EE;

A11:=REF(DZ,1)=1 OR REF(DZ,2)=1;
 A22:=C>HHV(REF(H,1),4);
 OK:(A11 AND A22);

通达信 突破系列选股器给大家





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号