当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信副图-水平布林线(图+源码)(无源码的请下载附件导入)

将布林线拉成水平方向,看的更加清楚,加上股价与布林中轨(20日均线)和5日均线之间的关系柱状线,股价运行状态一目了然。增加“安全”、“风险”和钱袋子标志(回踩布林中轨买进提示),具体效果自己去好好体验,收获一定不小。
 柱状线参考的MACD的原理,所以原码中就直接用的MACD1和MACD2代替,但其本质还是布林线。
 绝对原创,独此一家。

 
{布林中轨(20日均线)}
MA20:=MA(CLOSE,20);
MACD2:=2*(C-MA20);
{布林上下轨}
UPPER:=MA20+2*STD(CLOSE,20);
LOWER:=MA20-2*STD(CLOSE,20);
UP:2*(UPPER-MA20),DOTLINE;
LO:2*(LOWER-MA20),DOTLINE;
{收盘价与布林线关系(大于或小于布林中轨)}
STICKLINE(MACD2>0,0,MACD2,1.5,1),COLORMAGENTA;
STICKLINE(MACD2<0,0,MACD2,1.5,1),COLORCYAN;
{布林标注}
DRAWTEXT(CROSS(C,LOWER),LO,'↑安全');
DRAWTEXT(CROSS(UPPER,C),UP,'★风险'),COLORGREEN;
{5日均线}
MA5:=MA(CLOSE,5);
MACD1:2*(C-MA5),STICK;
{收盘价与5日均线关系(大于或小于5日均线)}
STICKLINE(MACD1>0,0,MACD1,0.5,0),COLOR0000DD;
STICKLINE(MACD1<0,0,MACD1,0.5,0),COLOR00BB00;

VAR1:=MACD2>REF(MACD2,1) AND REF(MACD2,1)<REF(MACD2,2) AND REF(MACD2,2)<REF(MACD2,3);{收盘价连续下跌两天反弹}
VAR2:=REF(MACD1,1)<0 AND MACD1>0;{收盘价上穿5日均线,也可以写成CROSS(C,MACD1);}
VAR3:=MA20>REF(MA20,1){20日均线向上};
DRAWICON(VAR1 AND VAR2 AND VAR3,0,9);{回踩买(钱袋标志)}

通达信副图-水平布林线(图+源码)





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号