当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是金牛三色K线源码附图(无源码的请下载附件导入)

{金牛三色K线}

 {主趋势线:EMA(EMA(C,10),10),COLORBLUE,LINETHICK3;
 B:=主趋势线<REF(主趋势线,1);
 IF(B-1,主趋势线,DRAWNULL)COLORRED,LINETHICK3;}
主趋势线:EMA(EMA(C,10),10),COLORRED,LINETHICK3;
 B:=主趋势线>REF(主趋势线,1);
 IF(B-1,主趋势线,DRAWNULL)COLORBLUE,LINETHICK3;
 {操盘线:EMA(EMA(C,5),5),COLORRED,LINETHICK2;
 Y:=操盘线>REF(操盘线,1);
 IF(Y-1,操盘线,DRAWNULL)COLORGREEN,LINETHICK2;}

AA:=EMA(C,5) > EMA(C,20);
 BB:=EMA(C,5) < EMA(C,20);
 CC:= EMA(C,5) > EMA(C,10);
 CC1:=EMA(C,5) < EMA(C,10);
 DD:=CLOSE<OPEN;


 STICKLINE(AA,H,L,0,0),COLORRED;
 STICKLINE(AA,O,C,3,1),COLORRED;
 STICKLINE(AA AND DD,O,C,3,0),COLORRED;
 STICKLINE(BB,H,L,0,0),COLORGREEN;
 STICKLINE(BB,O,C,3,1),COLORGREEN;

STICKLINE(BB AND DD,O,C,3,0),COLORGREEN;
 STICKLINE(BB AND CC,H,L,0,1),COLORWHITE;
 STICKLINE(BB AND CC,O,C,3,1),COLORWHITE;
 STICKLINE(BB AND CC AND DD,O,C,3,0),COLORWHITE;
 STICKLINE(AA AND CC1,H,L,0,0),COLORWHITE;
 STICKLINE(AA AND CC1,O,C,3,1),COLORWHITE;
 STICKLINE(AA AND CC1 AND DD,O,C,3,0),COLORWHITE;


 AAA:=CONST(HHV(C,90));
 {DRAWTEXT(T1=1 AND CURRBARSCOUNT=58,AAA,'智能分析:目前处于红色买区,上涨趋势良好,多单持有。'),COLORRED,LINETHICK4;}
 DRAWTEXT(C AND CURRBARSCOUNT=80 ,AAA, '红色K线做多,绿色K线做空,白色K线观望。 '),COLORYELLOW;

金牛三色K线源码附图





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 2009-2010 gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识