当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是神奇曲线-比K线更好用的曲线(无源码的请下载附件导入)

该曲线是由秀山腾龙老师根据歪歪虎老师推荐一根趋势曲线加以改编而成,谢谢两位老师!

歪歪虎老师的趋势曲线核心源码:
VAR6:=(CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100;
VAR7:SMA(VAR6,4,1);
VAR8:SMA(VAR7,2,1);

秀山腾龙老师改编后将其命名为神奇曲线,并进行了两天的盘中摸拟跟踪。
公式图片及介绍如下:
神奇曲线-比K线更好用的曲线
坐标位置90黄色横虚线:顶部线。
坐标位置10淡蓝色横虚线:底部线
坐标位置50淡蓝色跟黄色变色横虚线:短趋势变色线同时50也为长趋强弱分界
50以上红彩带:转强
50以下绿彩带:转弱

3月9号长短趋势共振跟踪股:

600260凯乐科技
选取思路:头天EMA7上穿EMA21,当天逆市上涨并伴随放量,但上有年线压力。检验新指标神奇线长短趋势共振跟踪今天表现:
神奇曲线-比K线更好用的曲线

600873五洲明珠
选取思路:相同
神奇曲线-比K线更好用的曲线
这只一开盘就给了一个打击。跳水下跌随后才拉升
3月9日长趋反身向上、头天短趋转点跟踪股

600798宁波海运
选取思路:下有均线及EMA7支撑,暂时还不会碰到年线。当天神奇线指标形态二考察跟踪

公式源码:
神奇曲线:通达信6.05、飞狐大智慧L2都有

通达信6.05:

趋势:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1),COLORYELLOW;
DRAWBAND(趋势,RGB(155,50,50),50,RGB(0,100,50));
转强:IF(趋势>50,趋势,DRAWNULL),COLORRED;
转弱:IF(趋势<50,趋势,DRAWNULL),COLORGREEN;
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
转点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(转点=1,50,50,2,0),COLORYELLOW;
STICKLINE(转点=0,50,50,2,0),COLORCYAN;
STICKLINE(C,90,90,1,0),COLORYELLOW;
STICKLINE(C,10,10,1,0),COLORCYAN;


大智慧L2:

DRAWGBKLAST(DATE>900101,STRIP(RGB(65,65,65),RGB(0,0,0),0));
趋势:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1);
PARTLINE(趋势,趋势>50),COLORRED,LAYER0;
PARTLINE(趋势,趋势<50),COLORGREEN,LAYER0;
FILLRGN(趋势,50,趋势>50,RGB(155,50,50));
FILLRGN(趋势,50,50>趋势,RGB(0,100,50));
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
转点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(转点=1,50,50,6,0),COLORYELLOW;
STICKLINE(转点=0,50,50,6,0),COLORCYAN;
顶部:90,DOTLINE,COLORYELLOW;
底部:10,DOTLINE,COLORCYAN;


飞狐:

趋势:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1);
FILLRGN(趋势>50,趋势,50),COLOR32329B;
FILLRGN(50>趋势,趋势,50),COLOR326400;
PARTLINE(趋势>50,趋势),COLORRED;
PARTLINE(趋势<50,趋势),COLORGREEN;
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
转点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(转点=1,50,50,6,0),COLORYELLOW;
STICKLINE(转点=0,50,50,6,0),COLORCYAN;
顶部:90,LINEDOT,COLORYELLOW;
底部:10,LINEDOT,COLORCYAN;
 

底部:10,DOTLINE,COLORCYAN;

 

乘风破浪2008老师加了根粗线:
趋势:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1),COLORRED;
DRAWBAND(趋势,RGB(155,50,50),50,RGB(0,100,50));
判断:SMA(趋势,3,1),COLORYELLOW;
转强:IF(趋势>50,趋势,DRAWNULL),COLORRED;
转弱:IF(趋势<50,趋势,DRAWNULL),COLORGREEN;
拉升:IF(判断>50 AND 趋势>判断,判断,DRAWNULL),COLORYELLOW,LINETHICK2;
建仓:IF(判断<50 AND 趋势>判断,判断,DRAWNULL),COLORLIMAGENTA;
出货:IF(判断>50 AND 趋势<判断,判断,DRAWNULL),COLORLIGREEN,LINETHICK2;
RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
转点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(转点=1,50,50,2,0),COLORYELLOW;
STICKLINE(转点=0,50,50,2,0),COLORCYAN;
STICKLINE(C,90,90,1,0),COLORYELLOW;
STICKLINE(C,10,10,1,0),COLORCYAN;
=============
飞狐
趋势:SMA(((CLOSE-LLV(LOW,28))/(HHV(HIGH,28)-LLV(LOW,28))*100),3,1),COLORRED,LINETHICK;
FILLRGN(趋势>50,趋势,50),COLOR32329B;
FILLRGN(50>趋势,趋势,50),COLORGRAY;
判断:SMA(趋势,3,1),COLORYELLOW;
PARTLINE(判断>50 AND 趋势>判断,判断),COLORYELLOW,LINETHICK2;
PARTLINE(判断<50 AND 趋势<=判断,判断),COLORBLUE,LINETHICK2;
PARTLINE(判断>50 AND 趋势<=判断,判断),COLORGREEN,LINETHICK2;
PARTLINE(判断<50 AND 趋势>判断,判断),COLOR1477ff,LINETHICK2;


RSV:=(CLOSE-LLV(CLOSE,9))/(HHV(CLOSE,9)-LLV(CLOSE,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
TYP:=(HIGH+LOW+CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));
DIFF:=EMA(CLOSE,2)-EMA(CLOSE,55);
DEA:=EMA(DIFF,6);
MACD:=2*(DIFF-DEA);
转点:=IF(K>D AND CCI>0 AND DIFF>DEA AND MACD>0,1,0);
STICKLINE(转点=1,50,50,6,0),COLORYELLOW;
STICKLINE(转点=0,50,50,6,0),COLORCYAN;
PARTLINE(c,90),LINEDOT,COLORYELLOW;
PARTLINE(c,10),LINEDOT,COLORCYAN;
神奇曲线-比K线更好用的曲线

 

 

 

神奇曲线-比K线更好用的曲线

 

600483福建南纺
选取思路:放量上穿两线并触及年线、当天神奇线指标形态二考察跟踪看今日能否突破年线
神奇曲线-比K线更好用的曲线
结果今天这只跌
以上这四只为我昨晚选出要摸拟跟踪的股。于今天早上七点半开盘前完成进行取图标注说明。

今天盘中摸拟实盘跟踪
第三种形态:头天短趋转点,今天长趋上穿50

 

 

002036宜科科技
选取思路:头一天EMA7上穿EMA21,今天盘中选股考察神奇线指标形态3
神奇曲线-比K线更好用的曲线

000619海螺型材(我印象中这只股应该叫海螺新材才对)

选取思路:跟宜科科技一样

神奇曲线-比K线更好用的曲线


第四种形态:触底反弹,盘中没搜出。按坐标10为底要到1月份才搜出股。今天本来有600540跟600231很接近底线。原本也是主要目的是考察这种形态来验证指标,过些天再把指标发出来。但大盘走反啦没跌下去。

另外盘中选股长短今天共振的股只有三只其中只有正邦科技是一开盘就能选出。而另外两只600572跟601872在涨幅达到5个点时才符合条件选出。正邦本来我自已没看好所以没跟踪这只。但这只涨得很好




关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号