当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是分时k线(源码)(无源码的请下载附件导入)

引用指标名称{FSKY}
预测量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,VOL);
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
今量:VOL;
昨量:REF(VOL,1);
前量:REF(VOL,2);
昨开:REF(O,1);
昨收:REF(C,1);
前开:REF(O,2);
前收:REF(C,2);
ZO:REF(O,1);
ZC:REF(C,1);
ZH:REF(H,1);
ZL:REF(L,1);
JO:REF(O,2);
JC:REF(C,2);
JH:REF(H,2);
JL:REF(L,2);
JO3:REF(O,3);
JC3:REF(C,3);
JH3:REF(H,3);
JL3:REF(L,3);
JO4:REF(O,4);
JC4:REF(C,4);
JH4:REF(H,4);
JL4:REF(L,4);
JO5:REF(O,5);
JC5:REF(C,5);
JH5:REF(H,5);
JL5:REF(L,5);
JO6:REF(O,6);
JC6:REF(C,6);
JH6:REF(H,6);
JL6:REF(L,6);
JO7:REF(O,7);
JC7:REF(C,7);
JH7:REF(H,7);
JL7:REF(L,7);
JO8:REF(O,8);
JC8:REF(C,8);
JH8:REF(H,8);
JL8:REF(L,8);
MA2:MA(C,2);
MA3:MA(C,3);
MA4:MA(C,4);
MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
MA60:MA(C,60);
上涨家数:INDEXADV;
下跌家数:INDEXDEC;

 

{分时K线}
D0:=HOUR=9 AND  MINUTE=30;
D1:=HOUR=9 AND  MINUTE=40;
D2:=HOUR=9 AND  MINUTE=50;
D3:=HOUR=10 AND MINUTE=0;
D4:=HOUR=10 AND  MINUTE=30;
D5:=HOUR=11 AND  MINUTE=0;
D6:=HOUR=13 AND MINUTE=0;
D7:=HOUR=13 AND  MINUTE=30;
D8:=HOUR=14 AND  MINUTE=0;
D9:=HOUR=14 AND MINUTE=30;
D10:=HOUR=14 AND  MINUTE=40;
D11:=HOUR=14 AND MINUTE=50;
D12:=HOUR=14 AND MINUTE=55;
D0D:=IF(D0=0,C,DRAWNULL);
D1D:=IF(D1=1,C,DRAWNULL);
D2D:=IF(D2=1,C,DRAWNULL);
D3D:=IF(D3=1,C,DRAWNULL);
D4D:=IF(D4=1,C,DRAWNULL);
D5D:=IF(D5=1,C,DRAWNULL);
D6D:=IF(D6=1,C,DRAWNULL);
D7D:=IF(D7=1,C,DRAWNULL);
D8D:=IF(D8=1,C,DRAWNULL);
D9D:=IF(D9=1,C,DRAWNULL);
D10D:=IF(D10=1,C,DRAWNULL);
D11D:=IF(D11=1,C,DRAWNULL);
D12D:=IF(D12=1,C,DRAWNULL);

 

时间:=TIME=100000;
N:=BARSLAST(时间);
常数:=CONST(IF(N=0,C,REF(C,N))),COLORGREEN,DOTLINE;
CS1:=CONST(IF(N,HHV(H,0),REF(HHV(H,0),N)));
CS2:=CONST(IF(N,LLV(L,0),REF(LLV(L,0),N)));
{STICKLINE(时间=1,CS1,CS2,-1,0),COLORGREEN;}


DA:=YEAR AND MONTH AND DAY;
AA1:=STRCAT(CON2STR(YEAR,0),'年');
AA2:=STRCAT(CON2STR(MONTH,0),'月');
AA3:=STRCAT(CON2STR(DAY,0),'日');
AA4:=STRCAT('【',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF

(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));
AA:=STRCAT(STRCAT(STRCAT(AA1,AA2),STRCAT(AA3,AA4)),'】');
DRAWTEXT_FIX(DA,0.85,0.01,0,AA),COLORWHITE;
{分时量}
预测量:="FSKY.预测量#DAY";
主买:="FSKY.主买#DAY";
前量:="FSKY.前量#DAY";
昨量:="FSKY.昨量#DAY";
今量:="FSKY.今量#DAY";
前总:=前量;
昨总:=昨量;
总:=今量,NODRAW;
BMM:=MAX(前总,昨总);
AMM:=IF(总/BMM>2,BMM*3,BMM);
MM:=500/AMM;
KP:=DYNAINFO(4);
ZX:=DYNAINFO(7);
A1:=IF(ZX>=KP,255,0);
A2:=IF(ZX>=KP,0,255);
A3:=IF(ZX>=KP,0,255);
{DRAWRECTREL(0,80,MM*预测量,110,RGB(90,90,90));
DRAWRECTREL(0,80,MM*今量,110,RGB(A1,A2,A3));
DRAWRECTREL(0,80,MM*主买,110,RGB(250,250,280));}
昨开:="FSKY.昨开#DAY";
昨收:="FSKY.昨收#DAY";
A4:=IF(昨收>=昨开,255,0);
A5:=IF(昨收>=昨开,0,255);
A6:=IF(昨收>=昨开,0,255);
{DRAWRECTREL(0,40,MM*昨量,70,RGB(A4,A5,A6));}
前开:="FSKY.前开#DAY";
前收:="FSKY.前收#DAY";
A7:=IF(前收>=前开,255,0);
A8:=IF(前收>=前开,0,255);
A9:=IF(前收>=前开,0,255);
{DRAWRECTREL(0,0,MM*前量,30,RGB(A7,A8,A9));}
{分时K线}

ZS:=DYNAINFO(3);
ZG:=DYNAINFO(5);
ZD:=DYNAINFO(6);
OP:=500-(KP/ZS-1)*4000;
CL:=500-(ZX/ZS-1)*4000;
HI:=500-(ZG/ZS-1)*4000;
LO:=500-(ZD/ZS-1)*4000;
N1:=IF(TIME>=130000 OR TIME<91500,360,860);
DRAWRECTREL(N1+4,OP,N1+8,HI,RGB(255,0,255));
DRAWRECTREL(N1+4,CL,N1+8,LO,RGB(0,128,0));
Q1:=IF(ZX>=KP,255,0);
Q2:=IF(ZX>=KP,0,255);
Q3:=IF(ZX>=KP,0,255);
DRAWRECTREL(N1-10,OP,N1+22,CL,RGB(Q1,Q2,Q3));
ZO:="FSKY.ZO#DAY";
ZC:="FSKY.ZC#DAY";
ZH:="FSKY.ZH#DAY";
ZL:="FSKY.ZL#DAY";
ZKP:=500-(ZO/ZS-1)*4000;
ZCP:=500-(ZC/ZS-1)*4000;
ZZG:=500-(ZH/ZS-1)*4000;
ZZD:=500-(ZL/ZS-1)*4000;
DRAWRECTREL(N1-36,ZKP,N1-32,ZZG,RGB(255,0,255));
DRAWRECTREL(N1-36,ZCP,N1-32,ZZD,RGB(0,128,0));
Q4:=IF(ZC>=ZO,255,0);
Q5:=IF(ZC>=ZO,0,255);
Q6:=IF(ZC>=ZO,0,255);
DRAWRECTREL(N1-49,ZKP,N1-17,ZCP,RGB(Q4,Q5,Q6));
JO:="FSKY.JO#DAY";
JC:="FSKY.JC#DAY";
JH:="FSKY.JH#DAY";
JL:="FSKY.JL#DAY";
ZZKP:=500-(JO/ZS-1)*4000;
ZZCP:=500-(JC/ZS-1)*4000;
ZZZG:=500-(JH/ZS-1)*4000;
ZZZD:=500-(JL/ZS-1)*4000;
DRAWRECTREL(N1-76,ZZKP,N1-72,ZZZG,RGB(255,0,255));
DRAWRECTREL(N1-76,ZZCP,N1-72,ZZZD,RGB(0,128,0));
Q7:=IF(JC>=JO,255,0);
Q8:=IF(JC>=JO,0,255);
Q9:=IF(JC>=JO,0,255);
DRAWRECTREL(N1-89,ZZKP,N1-57,ZZCP,RGB(Q7,Q8,Q9));
JO3:="FSKY.JO3#DAY";
JC3:="FSKY.JC3#DAY";
JH3:="FSKY.JH3#DAY";
JL3:="FSKY.JL3#DAY";
ZZKP3:=500-(JO3/ZS-1)*4000;
ZZCP3:=500-(JC3/ZS-1)*4000;
ZZZG3:=500-(JH3/ZS-1)*4000;
ZZZD3:=500-(JL3/ZS-1)*4000;
DRAWRECTREL(N1-116,ZZKP3,N1-112,ZZZG3,RGB(255,0,255));
DRAWRECTREL(N1-116,ZZCP3,N1-112,ZZZD3,RGB(0,128,0));
Q10:=IF(JC3>=JO3,255,0);
Q11:=IF(JC3>=JO3,0,255);
Q12:=IF(JC3>=JO3,0,255);
DRAWRECTREL(N1-129,ZZKP3,N1-97,ZZCP3,RGB(Q10,Q11,Q12));
JO4:="FSKY.JO4#DAY";
JC4:="FSKY.JC4#DAY";
JH4:="FSKY.JH4#DAY";
JL4:="FSKY.JL4#DAY";
ZZKP4:=500-(JO4/ZS-1)*4000;
ZZCP4:=500-(JC4/ZS-1)*4000;
ZZZG4:=500-(JH4/ZS-1)*4000;
ZZZD4:=500-(JL4/ZS-1)*4000;
DRAWRECTREL(N1-156,ZZKP4,N1-152,ZZZG4,RGB(255,0,255));
DRAWRECTREL(N1-156,ZZCP4,N1-152,ZZZD4,RGB(0,128,0));
Q13:=IF(JC4>=JO4,255,0);
Q14:=IF(JC4>=JO4,0,255);
Q15:=IF(JC4>=JO4,0,255);
DRAWRECTREL(N1-169,ZZKP4,N1-137,ZZCP4,RGB(Q13,Q14,Q15));
JO5:="FSKY.JO5#DAY";
JC5:="FSKY.JC5#DAY";
JH5:="FSKY.JH5#DAY";
JL5:="FSKY.JL5#DAY";
ZZKP5:=500-(JO5/ZS-1)*4000;
ZZCP5:=500-(JC5/ZS-1)*4000;
ZZZG5:=500-(JH5/ZS-1)*4000;
ZZZD5:=500-(JL5/ZS-1)*4000;
DRAWRECTREL(N1-196,ZZKP5,N1-192,ZZZG5,RGB(255,0,255));
DRAWRECTREL(N1-196,ZZCP5,N1-192,ZZZD5,RGB(0,128,0));
Q16:=IF(JC5>=JO5,255,0);
Q17:=IF(JC5>=JO5,0,255);
Q18:=IF(JC5>=JO5,0,255);
DRAWRECTREL(N1-209,ZZKP5,N1-177,ZZCP5,RGB(Q16,Q17,Q18));
JO6:="FSKY.JO6#DAY";
JC6:="FSKY.JC6#DAY";
JH6:="FSKY.JH6#DAY";
JL6:="FSKY.JL6#DAY";
ZZKP6:=500-(JO6/ZS-1)*4000;
ZZCP6:=500-(JC6/ZS-1)*4000;
ZZZG6:=500-(JH6/ZS-1)*4000;
ZZZD6:=500-(JL6/ZS-1)*4000;
DRAWRECTREL(N1-236,ZZKP6,N1-232,ZZZG6,RGB(255,0,255));
DRAWRECTREL(N1-236,ZZCP6,N1-232,ZZZD6,RGB(0,128,0));
Q19:=IF(JC6>=JO6,255,0);
Q20:=IF(JC6>=JO6,0,255);
Q21:=IF(JC6>=JO6,0,255);
DRAWRECTREL(N1-249,ZZKP6,N1-217,ZZCP6,RGB(Q19,Q20,Q21));
JO7:="FSKY.JO7#DAY";
JC7:="FSKY.JC7#DAY";
JH7:="FSKY.JH7#DAY";
JL7:="FSKY.JL7#DAY";
ZZKP7:=500-(JO7/ZS-1)*4000;
ZZCP7:=500-(JC7/ZS-1)*4000;
ZZZG7:=500-(JH7/ZS-1)*4000;
ZZZD7:=500-(JL7/ZS-1)*4000;
DRAWRECTREL(N1-276,ZZKP7,N1-272,ZZZG7,RGB(255,0,255));
DRAWRECTREL(N1-276,ZZCP7,N1-272,ZZZD7,RGB(0,128,0));
Q22:=IF(JC7>=JO7,255,0);
Q23:=IF(JC7>=JO7,0,255);
Q24:=IF(JC7>=JO7,0,255);
DRAWRECTREL(N1-289,ZZKP7,N1-257,ZZCP7,RGB(Q22,Q23,Q24));
JO8:="FSKY.JO8#DAY";
JC8:="FSKY.JC8#DAY";
JH8:="FSKY.JH8#DAY";
JL8:="FSKY.JL8#DAY";
ZZKP8:=500-(JO8/ZS-1)*4000;
ZZCP8:=500-(JC8/ZS-1)*4000;
ZZZG8:=500-(JH8/ZS-1)*4000;
ZZZD8:=500-(JL8/ZS-1)*4000;
DRAWRECTREL(N1-316,ZZKP8,N1-312,ZZZG8,RGB(255,0,255));
DRAWRECTREL(N1-316,ZZCP8,N1-312,ZZZD8,RGB(0,128,0));
Q25:=IF(JC8>=JO8,255,0);
Q26:=IF(JC8>=JO8,0,255);
Q27:=IF(JC8>=JO8,0,255);
DRAWRECTREL(N1-329,ZZKP8,N1-297,ZZCP8,RGB(Q25,Q26,Q27));
DRAWLINE(D0=0,D0D,D1=1,D1D,0),COLORBLUE,LINETHICK2;
DRAWLINE(D1=1,D1D,D2=1,D2D,0),COLORBLUE,LINETHICK2;
DRAWLINE(D2=1,D2D,D3=1,D3D,0),COLORBLUE,LINETHICK2;
DRAWLINE(D9=1,D9D,D10=1,D10D,0),COLORBLUE,LINETHICK2;
DRAWLINE(D10=1,D10D,D11=1,D11D,0),COLORBLUE,LINETHICK2;
DRAWLINE(D11=1,D11D,D12=1,D12D,0),COLORBLUE,LINETHICK2;

MA2:="FSKY.MA2#DAY";
MA3:="FSKY.MA3#DAY";
MA4:="FSKY.MA4#DAY";
MA5:="FSKY.MA5#DAY";
XMA5:=500-(MA5/ZS-1)*4000;
DRAWRECTREL(N1-3,XMA5-2,N1+15,XMA5+2,RGB(255,0,0));
MA10:="FSKY.MA10#DAY";
XMA10:=500-(MA10/ZS-1)*4000;
DRAWRECTREL(N1-10,XMA10-2,N1+25,XMA10+2,RGB(0,255,0));
MA20:="FSKY.MA20#DAY";
XMA20:=500-(MA20/ZS-1)*4000;
DRAWRECTREL(N1-20,XMA20-2,N1+35,XMA20+2,RGB(0,0,255));
MA60:="FSKY.MA60#DAY";
XMA60:=500-(MA60/ZS-1)*4000;
DRAWRECTREL(N1-30,XMA60-2,N1+45,XMA60+2,RGB(255,255,255));
分时k线(源码)




关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号