当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是老鸭头主图副图 选股 源码(无源码的请下载附件导入)

老鸭头 主图
MA5:MA(CLOSE,5),COLOR00FFFF;
 MA10:MA(CLOSE,10),COLORFF00FF;
 MA60:MA(CLOSE,60),COLOR00FF00;
 PDAY1:=BARSLAST(CROSS(MA5,MA60));{5日均线上穿60日均线}
PDAY2:=BARSLAST(CROSS(MA10,MA60));{10日均线上穿60日均线}
PDAY3:=BARSLAST((HIGH=HHV(HIGH,PDAY2)));{形成头部要下跌}
PDAY4:=BARSLAST(CROSS(MA10,MA5));{下跌后,5日均线与10日均线形成死叉}
PDAY5:=BARSLAST(CROSS(MA5,MA10));{回落不久后,5日均线与10日均线形成金叉}
A1:=(PDAY1>PDAY2) AND (PDAY2>PDAY3) AND (PDAY3>PDAY4) AND (PDAY4>PDAY5) AND (PDAY5<5);
 A2:=(COUNT(CROSS(MA10,MA5),PDAY2)=1);
 AA:=IF(A1 AND A2 AND (MA(CLOSE,5)>=MA(CLOSE,10)) AND (MA(CLOSE,10)>MA(CLOSE,60)),10,0);
 BB:=FILTER(A1 AND A2 AND (MA(CLOSE,5)>=MA(CLOSE,10)) AND (MA(CLOSE,10)>MA(CLOSE,60)),5);
老鸭头:IF(AA AND BB,1,0),COLOR00FF00;
 DRAWICON(AA AND BB,LOW,1),COLORFFFF00;
 DRAWTEXT(AA AND BB,(LOW)*(0.98),'老鸭头'),COLOR00FFFF;

老鸭头副图
Var1:=MA(CLOSE,5);
 Var2:=MA(CLOSE,10);
 Var3:=MA(CLOSE,60);
 Var4:=BARSLAST(CROSS(Var1,Var3));
 Var5:=BARSLAST(CROSS(Var2,Var3));
 Var6:=BARSLAST(HIGH=HHV(HIGH,Var5));
 Var7:=BARSLAST(CROSS(Var2,Var1));
 Var8:=BARSLAST(CROSS(Var1,Var2));
 Var9:=Var4>Var5 AND Var5>Var6 AND Var6>Var7 AND Var7>Var8 AND Var8<5;
 VarA:=COUNT(CROSS(Var2,Var1),Var5)=1;
老鸭头:Var9 AND VarA and Var3>ref(Var3,1);
 DRAWICON( Var9 AND VarA and Var3>ref(Var3,1),1.1,1);

老鸭头选股
MA5 := MA(CLOSE,5);
 MA10 := MA(CLOSE,10);
 MA60 := MA(CLOSE,60);
 PDAY1 := BARSLAST(CROSS(MA5,MA60));
 PDAY2 := BARSLAST(CROSS(MA10,MA60));
 PDAY3 := BARSLAST(HIGH=HHV(HIGH,PDAY2));
 PDAY4 := BARSLAST(CROSS(MA10,MA5));
 PDAY5 := BARSLAST(CROSS(MA5,MA10));
 A1:= PDAY1>PDAY2 AND PDAY2>PDAY3 AND PDAY3>PDAY4 AND PDAY4>PDAY5 AND PDAY5<5;
 A2:= COUNT(CROSS(MA10,MA5),PDAY2)=1;
 A1 AND A2;

老鸭头主图副图 选股 源码





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 2009-2010 gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识