当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信RSI自动画线指标公式(无源码的请下载附件导入)

HIGHN:=5;
 LC :=REF(C,1);
 RSI1:SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100,COLORRED,LINETHICK1;
 LOWN:=HIGHN;
 AA:=REF(RSI1,HIGHN)=HHV(RSI1,2*HIGHN+1);
 QY:=BACKSET(AA,HIGHN+1);
 CC:=FILTER(QY,HIGHN) AND RSI1=HHV(RSI1,HIGHN+1);
 DRAWICON(CC,RSI1*1.02,2);
 DDD:=BARSLAST(CC);
 GDTS:=IF(CC,CURRBARSCOUNT,0);
 DINGBU:=IF(DDD,REF(RSI1,DDD),RSI1);{顶部}
DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);
 DINGBU1:=REF(DINGBU,DDD+1);
 GDCS1:=CONST(DINGBUTS);
 DINGBUTS1:=REF(DINGBUTS,DDD+1);
 GDCS2:=CONST(DINGBUTS1);
 DINGBU2:=REF(DINGBU1,DDD+1);
 MM:=IF(CURRBARSCOUNT>GDCS2,0,1);
高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,RSI1,CURRBARSCOUNT=GDCS1,RSI1,1) COLORGREEN,LINETHICK1;
 DRAWLINE(CURRBARSCOUNT=GDCS2,RSI1,ISLASTBAR,REF(RSI1,GDCS2-1),1),COLORBLUE;
 DRAWLINE(CURRBARSCOUNT=GDCS1,RSI1,ISLASTBAR,REF(RSI1,GDCS1-1),1),COLORCYAN;
 AA1:=REF(RSI1,LOWN)=LLV(RSI1,2*LOWN+1);
 QY1:=BACKSET(AA1,LOWN+1);
 CC1:=FILTER(QY1,LOWN) AND RSI1=LLV(RSI1,LOWN+1);
介入:DRAWICON(CC1,RSI1*0.98,1);
 DD1:=BARSLAST(CC1);
 DDTS:=IF(CC1,CURRBARSCOUNT,0);
 YDB:=IF(DD1,REF(RSI1,DD1),RSI1);
 DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);
 DDCS1:=CONST(DDTS1);
 ZDB:=REF(YDB,DD1+1);
 DDTS2:=REF(DDTS1,DD1+1);
 DDCS2:=CONST(DDTS2);
低点支撑:DRAWLINE(CURRBARSCOUNT=DDCS2,RSI1,CURRBARSCOUNT=DDCS1,RSI1,1) COLORRED,LINETHICK1;
 DRAWLINE(CURRBARSCOUNT=DDCS1,RSI1,ISLASTBAR,REF(RSI1,DDCS1-1),1),COLORMAGENTA;
 DRAWLINE(CURRBARSCOUNT=DDCS2,RSI1,ISLASTBAR,REF(RSI1,DDCS2-1),1),COLORYELLOW;
 80;
 20;
 

通达信RSI自动画线指标公式





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号