当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是最强分时通道主图喜欢的拿走(无源码的请下载附件导入)

本分时指标源码全来自论坛,在这里特别鸣谢 会心分时主图原创作者!由于时间原因大盘用主图就不发了!

分别建两个公式,务必将第一个公式名设成 fsyy;
公式一-------fsyy--------------------------------------------------------------------------------------------
 

ZO:REF(O,1);
ZC:REF(C,1);
ZH:REF(H,1);
ZL:REF(L,1);
JO:REF(O,2);
JC:REF(C,2);
JH:REF(H,2);
JL:REF(L,2);
JO3:REF(O,3);
JC3:REF(C,3);
JH3:REF(H,3);
JL3:REF(L,3);
JO4:REF(O,4);
JC4:REF(C,4);
JH4:REF(H,4);
JL4:REF(L,4);
JO5:REF(O,5);
JC5:REF(C,5);
JH5:REF(H,5);
JL5:REF(L,5);
JO6:REF(O,6);
JC6:REF(C,6);
JH6:REF(H,6);
JL6:REF(L,6);
JO7:REF(O,7);
JC7:REF(C,7);
JH7:REF(H,7);
JL7:REF(L,7);
JO8:REF(O,8);
JC8:REF(C,8);
JH8:REF(H,8);
JL8:REF(L,8);
JO9:REF(O,9);
JC9:REF(C,9);
JH9:REF(H,9);
JL9:REF(L,9);
MA5:MA(C,5);
MA10:MA(C,10);
MA20:MA(C,20);
MA60:MA(C,60);
比:=240/FROMOPEN;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,买盘1,买盘2);
卖盘:=IF(ISLASTBAR AND PERIOD=5 AND C<300,卖盘1,卖盘2);
今量:(ACTINVOL+ACTOUTVOL);
差:(ACTINVOL-ACTOUTVOL);
主买:ACTINVOL;
昨量:REF(VOL,1);
昨主:REF(主买,1);
昨差:REF(差,1);
前量:REF(VOL,2);
前主:REF(主买,2);
前差:REF(差,2);
前4:REF(VOL,3);
主4:REF(主买,3);
差4:REF(差,3);
前5:REF(VOL,4);
主5:REF(主买,4);
差5:REF(差,4);
总5:=今量+昨量+前量+前4+前5;
总差:=差+昨差+前差+差4+差5;
一纯%:差/今量*100;
三纯%:(差+昨差+前差)/(今量+昨量+前量)*100;
五纯%:总差/总5*100;
十纯%:SUM(差,10)/SUM(今量,10)*100;
上涨家数:INDEXADV;
下跌家数:INDEXDEC;
净买:(LARGEINTRDVOL-LARGEOUTTRDVOL)*(AMO/V/100)/100,NODRAW;
大买:LARGEINTRDVOL*(AMO/V/100)/100,COLORRED,NODRAW;
大卖:LARGEOUTTRDVOL*(AMO/V/100)/100,COLORGREEN,NODRAW;
动向:(LARGEINTRDVOL-LARGEOUTTRDVOL)*10000/FINANCE(7);
三日:COUNT(动向>0,3);
五日:COUNT(动向>0,5);
十日:COUNT(动向>0,10);
 

公式二-----分时通道---------------------------------------------------------------------------------------

突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,10)-突破)/突破*100;
多方:=IF(A1X>=0,REF(EMA(C,10),BARSLAST(CROSS(A1X,0))+1),DRAWNULL);
空方:=IF(A1X<0,REF(EMA(C,10),BARSLAST(CROSS(0,A1X))+1),DRAWNULL);
STICKLINE(A1X>=0,多方,突破,0,0),COLOR000099;
STICKLINE(A1X<0,空方,突破,0,0),COLOR00CC66;
 

{分时看盘}
主买:="FSYY.主买#DAY";
前量:="FSYY.前量#DAY";
前主:="FSYY.前主#DAY";
昨量:="FSYY.昨量#DAY";
昨主:="FSYY.昨主#DAY";
今量:="FSYY.今量#DAY";
前4:="FSYY.前4#DAY";
主4:="FSYY.主4#DAY";
前5:="FSYY.前5#DAY";
主5:="FSYY.主5#DAY";
前总:=前量;
昨总:=昨量;
总:=今量,NODRAW;
BMM:=MAX(前总,昨总);
AMM:=IF(总/BMM>2,BMM*3,BMM);
MM:=500/AMM;
KP:=DYNAINFO(4);
ZX:=DYNAINFO(7);
A1:=IF(ZX>=KP,255,0);
A2:=IF(ZX>=KP,0,255);
A3:=IF(ZX>=KP,0,255);
DRAWRECTREL(0,210,MM*今量,240,RGB(A1,A2,A3));
DRAWRECTREL(0,210,MM*主买,240,RGB(250,00,250));
ZO:="FSYY.ZO#DAY";
ZC:="FSYY.ZC#DAY";
A4:=IF(ZC>=ZO,255,0);
A5:=IF(ZC>=ZO,0,255);
A6:=IF(ZC>=ZO,0,255);
DRAWRECTREL(0,170,MM*昨量,200,RGB(A4,A5,A6));
DRAWRECTREL(0,170,MM*昨主,200,RGB(250,00,250));
JO:="FSYY.JO#DAY";
JC:="FSYY.JC#DAY";
A7:=IF(JC>=JO,255,0);
A8:=IF(JC>=JO,0,255);
A9:=IF(JC>=JO,0,255);
DRAWRECTREL(0,130,MM*前量,160,RGB(A7,A8,A9));
DRAWRECTREL(0,130,MM*前主,160,RGB(250,00,250));
JO3:="FSYY.JO3#DAY";
JC3:="FSYY.JC3#DAY";
A10:=IF(JC3>=JO3,255,0);
A11:=IF(JC3>=JO3,0,255);
A12:=IF(JC3>=JO3,0,255);
DRAWRECTREL(0,90,MM*前4,120,RGB(A10,A11,A12));
DRAWRECTREL(0,90,MM*主4,120,RGB(250,00,250));
JO4:="FSYY.JO4#DAY";
JC4:="FSYY.JC4#DAY";
A13:=IF(JC4>=JO4,255,0);
A14:=IF(JC4>=JO4,0,255);
A15:=IF(JC4>=JO4,0,255);
DRAWRECTREL(0,50,MM*前5,80,RGB(A13,A14,A15));
DRAWRECTREL(0,50,MM*主5,80,RGB(250,00,250));
{分时K}
ZS:=DYNAINFO(3);
ZG:=DYNAINFO(5);
ZD:=DYNAINFO(6);
OP:=500-(KP/ZS-1)*1200;
CL:=500-(ZX/ZS-1)*1200;
HI:=500-(ZG/ZS-1)*1200;
LO:=500-(ZD/ZS-1)*1200;
N1:=IF(HOUR>=13,860,860);
Z1:=IF(ZX>=KP,255,0);
Z2:=IF(ZX>=KP,0,255);
Z3:=IF(ZX>=KP,0,255);
DRAWRECTREL(N1+35,HI,N1+35,LO,RGB(Z1,Z2,Z3));
Q1:=IF(ZX>=KP,255,0);
Q2:=IF(ZX>=KP,0,255);
Q3:=IF(ZX>=KP,0,255);
DRAWRECTREL(N1+25,OP,N1+45,CL,RGB(Q1,Q2,Q3));
ZH:="FSYY.ZH#DAY";
ZL:="FSYY.ZL#DAY";
ZKP:=500-(ZO/ZS-1)*1200;
ZCP:=500-(ZC/ZS-1)*1200;
ZZG:=500-(ZH/ZS-1)*1200;
ZZD:=500-(ZL/ZS-1)*1200;
Z4:=IF(ZC>=ZO,255,0);
Z5:=IF(ZC>=ZO,0,255);
Z6:=IF(ZC>=ZO,0,255);
DRAWRECTREL(N1+5,ZZG,N1+5,ZZD,RGB(Z4,Z5,Z6));
Q4:=IF(ZC>=ZO,255,0);
Q5:=IF(ZC>=ZO,0,255);
Q6:=IF(ZC>=ZO,0,255);
DRAWRECTREL(N1-5,ZKP,N1+15,ZCP,RGB(Q4,Q5,Q6));
JH:="FSYY.JH#DAY";
JL:="FSYY.JL#DAY";
ZZKP:=500-(JO/ZS-1)*1200;
ZZCP:=500-(JC/ZS-1)*1200;
ZZZG:=500-(JH/ZS-1)*1200;
ZZZD:=500-(JL/ZS-1)*1200;
Z7:=IF(JC>=JO,255,0);
Z8:=IF(JC>=JO,0,255);
Z9:=IF(JC>=JO,0,255);
DRAWRECTREL(N1-25,ZZZG,N1-25,ZZZD,RGB(Z7,Z8,Z9));
Q7:=IF(JC>=JO,255,0);
Q8:=IF(JC>=JO,0,255);
Q9:=IF(JC>=JO,0,255);
DRAWRECTREL(N1-35,ZZKP,N1-15,ZZCP,RGB(Q7,Q8,Q9));
JH3:="FSYY.JH3#DAY";
JL3:="FSYY.JL3#DAY";
ZZKP3:=500-(JO3/ZS-1)*1200;
ZZCP3:=500-(JC3/ZS-1)*1200;
ZZZG3:=500-(JH3/ZS-1)*1200;
ZZZD3:=500-(JL3/ZS-1)*1200;
Z10:=IF(JC3>=JO3,255,0);
Z11:=IF(JC3>=JO3,0,255);
Z12:=IF(JC3>=JO3,0,255);
DRAWRECTREL(N1-55,ZZZG3,N1-55,ZZZD3,RGB(Z10,Z11,Z12));
Q10:=IF(JC3>=JO3,255,0);
Q11:=IF(JC3>=JO3,0,255);
Q12:=IF(JC3>=JO3,0,255);
DRAWRECTREL(N1-65,ZZKP3,N1-45,ZZCP3,RGB(Q10,Q11,Q12));
JH4:="FSYY.JH4#DAY";
JL4:="FSYY.JL4#DAY";
ZZKP4:=500-(JO4/ZS-1)*1200;
ZZCP4:=500-(JC4/ZS-1)*1200;
ZZZG4:=500-(JH4/ZS-1)*1200;
ZZZD4:=500-(JL4/ZS-1)*1200;
Z13:=IF(JC4>=JO4,255,0);
Z14:=IF(JC4>=JO4,0,255);
Z15:=IF(JC4>=JO4,0,255);
DRAWRECTREL(N1-85,ZZZG4,N1-85,ZZZD4,RGB(Z13,Z14,Z15));
Q13:=IF(JC4>=JO4,255,0);
Q14:=IF(JC4>=JO4,0,255);
Q15:=IF(JC4>=JO4,0,255);
DRAWRECTREL(N1-95,ZZKP4,N1-75,ZZCP4,RGB(Q13,Q14,Q15));
JO5:="FSYY.JO5#DAY";
JC5:="FSYY.JC5#DAY";
JH5:="FSYY.JH5#DAY";
JL5:="FSYY.JL5#DAY";
ZZKP5:=500-(JO5/ZS-1)*1200;
ZZCP5:=500-(JC5/ZS-1)*1200;
ZZZG5:=500-(JH5/ZS-1)*1200;
ZZZD5:=500-(JL5/ZS-1)*1200;
Z16:=IF(JC5>=JO5,255,0);
Z17:=IF(JC5>=JO5,0,255);
Z18:=IF(JC5>=JO5,0,255);
DRAWRECTREL(N1-115,ZZZG5,N1-115,ZZZD5,RGB(Z16,Z17,Z18));
Q16:=IF(JC5>=JO5,255,0);
Q17:=IF(JC5>=JO5,0,255);
Q18:=IF(JC5>=JO5,0,255);
DRAWRECTREL(N1-125,ZZKP5,N1-105,ZZCP5,RGB(Q16,Q17,Q18));
JO6:="FSYY.JO6#DAY";
JC6:="FSYY.JC6#DAY";
JH6:="FSYY.JH6#DAY";
JL6:="FSYY.JL6#DAY";
ZZKP6:=500-(JO6/ZS-1)*1200;
ZZCP6:=500-(JC6/ZS-1)*1200;
ZZZG6:=500-(JH6/ZS-1)*1200;
ZZZD6:=500-(JL6/ZS-1)*1200;
Z19:=IF(JC6>=JO6,255,0);
Z20:=IF(JC6>=JO6,0,255);
Z21:=IF(JC6>=JO6,0,255);
DRAWRECTREL(N1-145,ZZZG6,N1-145,ZZZD6,RGB(Z19,Z20,Z21));
Q19:=IF(JC6>=JO6,255,0);
Q20:=IF(JC6>=JO6,0,255);
Q21:=IF(JC6>=JO6,0,255);
DRAWRECTREL(N1-155,ZZKP6,N1-135,ZZCP6,RGB(Q19,Q20,Q21));
JO7:="FSYY.JO7#DAY";
JC7:="FSYY.JC7#DAY";
JH7:="FSYY.JH7#DAY";
JL7:="FSYY.JL7#DAY";
ZZKP7:=500-(JO7/ZS-1)*1200;
ZZCP7:=500-(JC7/ZS-1)*1200;
ZZZG7:=500-(JH7/ZS-1)*1200;
ZZZD7:=500-(JL7/ZS-1)*1200;
Z22:=IF(JC7>=JO7,255,0);
Z23:=IF(JC7>=JO7,0,255);
Z24:=IF(JC7>=JO7,0,255);
DRAWRECTREL(N1-175,ZZZG7,N1-175,ZZZD7,RGB(Z22,Z23,Z24));
Q22:=IF(JC7>=JO7,255,0);
Q23:=IF(JC7>=JO7,0,255);
Q24:=IF(JC7>=JO7,0,255);
DRAWRECTREL(N1-185,ZZKP7,N1-165,ZZCP7,RGB(Q22,Q23,Q24));
JO8:="FSYY.JO8#DAY";
JC8:="FSYY.JC8#DAY";
JH8:="FSYY.JH8#DAY";
JL8:="FSYY.JL8#DAY";
ZZKP8:=500-(JO8/ZS-1)*1200;
ZZCP8:=500-(JC8/ZS-1)*1200;
ZZZG8:=500-(JH8/ZS-1)*1200;
ZZZD8:=500-(JL8/ZS-1)*1200;
Z25:=IF(JC8>=JO8,255,0);
Z26:=IF(JC8>=JO8,0,255);
Z27:=IF(JC8>=JO8,0,255);
DRAWRECTREL(N1-205,ZZZG8,N1-205,ZZZD8,RGB(Z25,Z26,Z27));
Q25:=IF(JC8>=JO8,255,0);
Q26:=IF(JC8>=JO8,0,255);
Q27:=IF(JC8>=JO8,0,255);
DRAWRECTREL(N1-215,ZZKP8,N1-195,ZZCP8,RGB(Q25,Q26,Q27));
JO9:="FSYY.JO9#DAY";
JC9:="FSYY.JC9#DAY";
JH9:="FSYY.JH9#DAY";
JL9:="FSYY.JL9#DAY";
ZZKP9:=500-(JO9/ZS-1)*1200;
ZZCP9:=500-(JC9/ZS-1)*1200;
ZZZG9:=500-(JH9/ZS-1)*1200;
ZZZD9:=500-(JL9/ZS-1)*1200;
Z28:=IF(JC9>=JO9,255,0);
Z29:=IF(JC9>=JO9,0,255);
Z30:=IF(JC9>=JO9,0,255);
DRAWRECTREL(N1-235,ZZZG9,N1-235,ZZZD9,RGB(Z28,Z29,Z30));
Q28:=IF(JC9>=JO9,255,0);
Q29:=IF(JC9>=JO9,0,255);
Q30:=IF(JC9>=JO9,0,255);
DRAWRECTREL(N1-245,ZZKP9,N1-225,ZZCP9,RGB(Q28,Q29,Q30));
MA5:="FSYY.MA5#DAY";
XMA5:=500-(MA5/ZS-1)*1200;
DRAWRECTREL(N1+28,XMA5,N1+42,XMA5,RGB(255,255,255));
MA10:="FSYY.MA10#DAY";
XMA10:=500-(MA10/ZS-1)*1200;
DRAWRECTREL(N1+18,XMA10,N1+52,XMA10,RGB(250,250,280));
MA20:="FSYY.MA20#DAY";
XMA20:=500-(MA20/ZS-1)*1200;
DRAWRECTREL(N1+10,XMA20,N1+60,XMA20,RGB(0,0,255)),COLORC0C0C0;
MA60:="FSYY.MA60#DAY";
XMA60:=500-(MA60/ZS-1)*1200;
DRAWRECTREL(N1+0,XMA60,N1+70,XMA60,RGB(0,255,0)),COLOR808000;
分时均价线:=SUM(C*V,240)/SUM(V,240),COLORYELLOW,LINETHICK1;
D:=CLOSE,LINETHICK2,COLORWHITE;
十纯%:="FSYY.十纯%#DAY";
五纯%:="FSYY.五纯%#DAY",NODRAW;
一纯%:="FSYY.一纯%#DAY",NODRAW;
三纯%:="FSYY.三纯%#DAY",NODRAW;
DDE:="FSYY.动向#DAY";
DDE3:="FSYY.三日#DAY";
DDE5:="FSYY.五日#DAY";
DDE10:="FSYY.十日#DAY";
大单净额:="FSYY.净买#DAY";
{十纯%:=IF(PERIOD=0 ,"FSYY.十纯%#DAY",DRAWNULL),NODRAW;
五纯%:=IF(PERIOD=0 ,"FSYY.五纯%#DAY",DRAWNULL),NODRAW;
一纯%:=IF(PERIOD=0 ,"FSYY.一纯%#DAY",DRAWNULL),NODRAW;
三纯%:=IF(PERIOD=0 ,"FSYY.三纯%#DAY",DRAWNULL),NODRAW;}
K:=IF((分时均价线-ZS)/ZS*100>0.5,0.5,0);
DRAWTEXT_FIX(十纯%>=0,0.1,1-0.28,0,STRCAT('十日纯量%: ',CON2STR(十纯%,2))),COLOR0000FF;
DRAWTEXT_FIX(十纯%<0,0.1,1-0.28,0,STRCAT('十日纯量%: ',CON2STR(十纯%,2))),COLORFFFF00;
DRAWTEXT_FIX(五纯%>=0,0.1,1-0.23,0,STRCAT('五日纯量%: ',CON2STR(五纯%,2))),COLOR0000FF;
DRAWTEXT_FIX(五纯%<0,0.1,1-0.23,0,STRCAT('五日纯量%: ',CON2STR(五纯%,2))),COLORFFFF00;
DRAWTEXT_FIX(三纯%>=0,0.1,1-0.18,0,STRCAT('三日纯量%: ',CON2STR(三纯%,2))),COLOR0000FF;
DRAWTEXT_FIX(三纯%<0,0.1,1-0.18,0,STRCAT('三日纯量%: ',CON2STR(三纯%,2))),COLORFFFF00;
DRAWTEXT_FIX(一纯%>=0,0.1,1-0.13,0,STRCAT('当日纯量%: ',CON2STR(一纯%,2))),COLOR0000FF;
DRAWTEXT_FIX(一纯%<0,0.1,1-0.13,0,STRCAT('当日纯量%: ',CON2STR(一纯%,2))),COLORFFFF00;
DRAWTEXT_FIX(DDE10>=5,0.6,1-0.28,0,STRCAT('十日飘红: ',CON2STR(DDE10,2))),COLOR0000FF;
DRAWTEXT_FIX(DDE10<5,0.6,1-0.28,0,STRCAT('十日飘红: ',CON2STR(DDE10,2))),COLORFFFF00;
DRAWTEXT_FIX(DDE5>=3,0.6,1-0.23,0,STRCAT('五日飘红: ',CON2STR(DDE5,2))),COLOR0000FF;
DRAWTEXT_FIX(DDE5<3,0.6,1-0.23,0,STRCAT('五日飘红: ',CON2STR(DDE5,2))),COLORFFFF00;
DRAWTEXT_FIX(DDE3>=2,0.6,1-0.18,0,STRCAT('三日飘红: ',CON2STR(DDE3,2))),COLOR0000FF;
DRAWTEXT_FIX(DDE3<2,0.6,1-0.18,0,STRCAT('三日飘红: ',CON2STR(DDE3,2))),COLORFFFF00;
DRAWTEXT_FIX(DDE>0,0.6,1-0.13,0,STRCAT('当日DDE: ',CON2STR(DDE,2))),COLOR0000FF;
DRAWTEXT_FIX(DDE<=0,0.6,1-0.13,0,STRCAT('当日DDE: ',CON2STR(DDE,2))),COLORFFFF00;
DRAWTEXT_FIX(大单净额>0,0.3,1-0.18,0,STRCAT('大单净额: ',CON2STR(大单净额,2))),COLOR0000FF;
DRAWTEXT_FIX(大单净额<=0,0.3,1-0.18,0,STRCAT('大单净额: ',CON2STR(大单净额,2))),COLORFFFF00;
上涨家数:=IF(PERIOD=0 ,"FSYY.上涨家数#DAY",DRAWNULL),NODRAW;
下跌家数:=IF(PERIOD=0 ,"FSYY.下跌家数#DAY",DRAWNULL),NODRAW;
DRAWTEXT_FIX(1,0.100,1-0.06,0,STRCAT('上涨家数:',CON2STR(上涨家数,0))),COLOR0000FF;
DRAWTEXT_FIX(1,0.600,1-0.06,0,STRCAT('下跌家数:',CON2STR(下跌家数,0))),COLOR00FF00;
均价:SUM(V*C,0)/SUM(V,0),COLORYELLOW;
天:EMA(均价,25)/0.9712,LINETHICK2,COLORGREEN;
地:EMA(均价,25)/1.0288,LINETHICK2,COLORGREEN;
IF(地>REF(地,1),地,DRAWNULL),COLORRED,LINETHICK2;
IF(天>REF(天,1),天,DRAWNULL),COLORRED,LINETHICK2;
平衡线1:(均价+天)/2,DOTLINE,COLORYELLOW;
平衡线2:(均价+地)/2,DOTLINE,COLORYELLOW;
SUM(V*C,0)/SUM(V,0),COLORYELLOW;
C,COLORWHITE;
V1:=TIME;
T:=IF(V1<130000,(FLOOR(V1/10000)-9.5)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000)),
(FLOOR(V1/10000)-11)*60+(FLOOR(V1/100)-100*FLOOR(V1/10000))),NODRAW;
XG:HHV(H,60),COLORBLUE,LINETHICK1;
XG1:LLV(L,T),COLORMAGENTA,LINETHICK1;
STICKLINE(FILTER(CROSS(C,REF(XG,1)),10),C*0.99,C,0.1,0),COLORGREEN;
DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10),C*0.99,'上突'),COLORYELLOW;
STICKLINE(FILTER(CROSS(C,REF(XG1,1)),10),C*1.02,C,0.5,0),COLORCYAN;
DRAWTEXT(FILTER(CROSS(C,REF(XG1,1)),10),C*1.02,'下破'),COLORWHITE;
 

最强分时通道主图喜欢的拿走
 

最强分时通道主图喜欢的拿走





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 2009-2010 gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识