当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是MACD加强版选股公式(无源码的请下载附件导入)

MACD加强版选股公式

了一点小修改,写了一个选股公式。不知道对不对,希望大家继续优化!再次提醒大家:指标只是工具,关键靠自己的头脑!在此谢谢原作者提供分享!!!


{MACD加强版副图}

DIF:EMA(CLOSE,5)-EMA(CLOSE,34);
DEA:EMA(DIF,4);
MACD:(DIF-DEA)*2,COLORSTICK;
MACD空中加油:
MACD>=0
AND REF(MACD,1)>=0
AND REF(MACD,2)>=0
AND REF(MACD,3)>=0
AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2)
AND REF(MACD,2)<REF(MACD,3) ;
DRAWICON(MACD空中加油,0.35,1);
STICKLINE(MACD空中加油,0.3,MACD,2,0),COLORYELLOW;
红柱首次放长:=MACD>0 AND REF(MACD,1)<0;
STICKLINE(红柱首次放长,0.3,MACD,2,0),COLORRED;
DRAWICON(红柱首次放长,0.35,1);
绿柱缩短:=MACD<0 AND MACD>REF(MACD ,1) AND REF(MACD ,1)<REF(MACD ,2)
AND REF(MACD ,2)<REF(MACD ,3)
AND REF(MACD ,3)<REF(MACD ,4);
STICKLINE(绿柱缩短,0.1,MACD,2,0),COLORMAGENTA;


下面是副图中出现‘MACD空中加油’符号时选股公式

{MACD加强版 空中加油选股}

DIF:=EMA(CLOSE,5)-EMA(CLOSE,34);
DEA:=EMA(DIF,4);
MACD:=(DIF-DEA)*2;
MACD空中加油:=
MACD>=0
AND REF(MACD,1)>=0
AND REF(MACD,2)>=0
AND REF(MACD,3)>=0
AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2)
AND REF(MACD,2)<REF(MACD,3);

XG:DRAWICON(MACD空中加油,0.35,1);
 

MACD加强版选股公式

 

MACD加强版选股公式

 





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号