当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信自己在用的VOL公式(无源码的请下载附件导入)

通达信自己在用的VOL公式

换手:if(CAPITAL>0,v/CAPITAL*100,v),LINETHICK,PRECISION2;
hs:=换手;
k:=sma((c-llv(l,9))/(hhv(h,9)-llv(l,9))*100,3,1),COLOR00FF00,LINETHICK0,PRECISION2;
d:=sma(k,3,1),COLORFFFFFF,LINETHICK0,PRECISION2;
j:=3*k-2*d;
hlp:=sma(WINNER(c)*100,3,1),COLOR2588FF,LINETHICK0,PRECISION2;


nn:=SYSPARAM(3)-SYSPARAM(2)+1;
hh:=HHV(v,nn);
ll:=LLV(v,nn);
最高:=hh[SYSPARAM(3)];
最低:=ll[SYSPARAM(3)];
RCC:=最高*0.9-(最高-最低)*0.5;
rhl:=rcc;
HLMAX:=MAX(最高,最低);
HLMIN:=MIN(最高,最低);
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
限制显示K线面积:=RANGE(BARPOS,SYSPARAM(3)-250,SYSPARAM(3)+1);
FILLRGN(限制显示K线面积,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,((80-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),color333333;
FILLRGN(限制显示K线面积,((0-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,((25-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),color333333;
FILLRGN(限制显示K线面积 and hlp>80,((hlp-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,((80-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),Color9A5791;
PARTLINE(限制显示K线面积,((25-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),COLOR888888;
PARTLINE(限制显示K线面积,((50-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),COLOR888888;
PARTLINE(限制显示K线面积,((80-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),COLOR888888;

{最佳买入时机}
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);
最佳买入:=(AV + NEWVOL);
STICKLINE(CROSS(最佳买入,0),((85-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,6,0),COLORRED;

{百万测底}
趋势线:= 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORRED,PRECISION0;
准备:IF(趋势线<=5,((65-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),COLORffffff;
VARA2:=LLV(MA(LOW,3),3);
VARA3:=HHV(MA(HIGH,3),3);
KK:=EMA((CLOSE-VARA2)/(VARA3-VARA2)*100,4)*0.7+20,COLORFF00FF,LINETHICK2;
DD:=EMA(0.667*REF(KK,1)+0.333*KK,2)*0.7+20,COLORFFFF00;
KK2:=EMA(ABS(VARA2-CLOSE)/ABS(VARA2-VARA3)*100,4)*0.7+20;
DD2:=EMA(0.667*REF(KK2,1)+0.333*KK2,2)*0.7+20;
提示:IF((KK2-KK)*2.5>35,((75-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),LINETHICK2,COLORff00ff,PRECISION0;


Xxjj:=LLV("kdj.j",2)=LLV("KDJ.j",8);
时机: IF(CROSS("kdj.j",1) and ref(xxjj,1),((90-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,((100-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),LINETHICK2,COLORYELLOW,PRECISION0;
地量买点:=CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0);
STICKLINE(地量买点,((0-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,((20-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl,9,0),COLORff0080,PRECISION0;

SJ:=if(CURRENTTIME>93000 and CURRENTTIME<150000,
if(CURRENTTIME<113000,(TIMETOT0(CURRENTTIME)-34200)/60,
if(CURRENTTIME>130000,(TIMETOT0(CURRENTTIME)-39600)/60,120)),240);
预测额:IF(BARSTATUS=2,(v/SJ*240),v),COLOR00FFFF,LINETHICK;
STICKLINE(BARSTATUS=2,0,预测额,9,1),COLOREEEEFF,LINEDOT;

地量:=IF(CAPITAL=0,AMOUNT=LLV(AMOUNT,34),换手<MA(换手,SUMBARS(V,CAPITAL))/3) ,LINETHICK0;
极地量:if(换手<MA(换手,SUMBARS(VOL,CAPITAL))/4,1,0),LINETHICK0;
连续地量:=COUNT(地量,3)>=3 AND COUNT(极地量,3)>=1;
一字涨板:=c>=ref(c,1)*1.01 and c=o and h=l;一字跌板:=c*1.1>=ref(c,1) and c=o and h=l;
无一字板:=not(一字涨板 or 一字跌板);
STICKLINE(地量 and 无一字板 and (c-ma(c,5))/ma(c,5)*100<0,v,0,8,0),colorff0080;
STICKLINE(地量 and 无一字板 and (c-ma(c,5))/ma(c,5)*100<0,v,0,8,0),color00ffff;
STICKLINE(c>o,v,0,6,1),colorred;
STICKLINE(c<=o,v,0,6,1),colorfff333;
AA:=VOL>=REF(V,1)*1.91 and C>REF(C,1);
AA1:=VOL<REF(LLV(VOL,21),1) and 无一字板;
AA2:=VOL<REF(LLV(VOL,55),1) and 无一字板;
AA3:=ABS(VOL-REF(VOL,1))/REF(VOL,1)<=0.05 and 无一字板;
STICKLINE(AA,0,v,6,0),COLORred;
STICKLINE(AA1,0,v/2,6,0),COLORGREEN;
STICKLINE(AA2,0,v/2,6,0),COLORff00ff;
STICKLINE(AA3,0,v,4,0),COLORWHITE;

地线:hhv(v,60)/6,COLOR00ff00,LINETHICK2,PRECISION0;
PARTLINE(限制显示K线面积,((hlp-HLMN3)*HLMN2/HLMN4+HLMN1)+rhl),color2588ff,LINETHICK1,LINEDOT;
PARTLINE(限制显示K线面积,(("kdj.k"-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL),COLORFFF111;
PARTLINE(限制显示K线面积,(("kdj.d"-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL),COLOR00ff00;
PARTLINE(限制显示K线面积,(("kdj.j"-HLMN3)*HLMN2/HLMN4+HLMN1)+RHL),COLORFF1111;
mv35:ma(v,35),colorffffff,PRECISION0;
mv10:ma(v,10),color00ffff,PRECISION0;
mv5:ma(v,5),colorff00ff,PRECISION0;

 

 

通达信自己在用的VOL公式





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号