当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是凤凰线(无源码的请下载附件导入)

凤凰线

大智慧的改为通达信,方便大家。
凤凰线:凤凰线由蓝、绿、黄、红四种颜色的线柱和凤线(黄色)、凰线(白色)共同组成。凤凰线是对K线形态的进一步变形,因为经过一系列数据模型的演变,因此形态更加流畅,上涨、下跌的形态也更加明显。处于凤线上方的红、黄两色线柱代表资金流入动作明显,当资金持续流入,该指标上会出现红色向上箭头提示投资者买进;反之,处于凰线下方蓝、绿两色表示资金正在流出,若资金持续流出,该指标会发出绿色向下箭头提示投资者卖出。

{凤凰线:凤凰线由蓝、绿、黄、红四种颜色的线柱和凤线(黄色)、凰线(白色)共同组成。凤凰线是对K线形态的进一步变形,因为经过一系列数据模型的演变,因此形态更加流畅,上涨、下跌的形态也更加明显。处于凤线上方的红、黄两色线柱代表资金流入动作明显,当资金持续流入,该指标上会出现红色向上箭头提示投资者买进;反之,处于凰线下方蓝、绿两色表示资金正在流出,若资金持续流出,该指标会发出绿色向下箭头提示投资者卖出。}
{参数N,最小1,最大30,缺省1}
XOPEN:=(REF(O,N)+REF(C,N))/2;
XCLOSE:=CLOSE;
XHIGH:=MAX(HIGH,XOPEN);
XLOW:=MIN(LOW,XOPEN);
VOLALITY:=MA(XHIGH-XLOW,8);
凰线:MA(XCLOSE,5)+VOLALITY/2;
凤线:MA(XCLOSE,5)-VOLALITY/2;
BU:=CROSS(XCLOSE,凰线);
SEL:=CROSS(凤线,XCLOSE);
VAR1:=BARSLAST(BU);
VAR2:=BARSLAST(SEL);
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XCLOSE,XOPEN ,2,0 ),COLORRED;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XHIGH,XCLOSE ,0,0 ),COLORRED;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XOPEN,XLOW ,0,0 ),COLORRED;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XCLOSE,XOPEN ,2,0 ),COLORYELLOW;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XHIGH,XOPEN ,0,0 ),COLORYELLOW;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XCLOSE,XLOW ,0,0 ),COLORYELLOW;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XCLOSE ,XOPEN ,2,0 ),COLORGREEN;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XOPEN ,XHIGH ,0,0 ),COLORGREEN;
STICKLINE(XCLOSE<=XOPEN AND VAR1>VAR2,XCLOSE,XLOW ,0,0 ),COLORGREEN;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XCLOSE ,XOPEN ,2,0 ),COLORBLUE;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XCLOSE,XHIGH ,0,0 ),COLORBLUE;
STICKLINE(XCLOSE>XOPEN AND VAR1>VAR2,XOPEN,XLOW ,0,0 ),COLORBLUE;
DRAWICON(REF(VAR1,1)>VAR2 AND VAR1=0,XLOW,1);
DRAWICON(REF(VAR2,1)>VAR1 AND VAR2=0,XHIGH,2);


 




关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号