当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信成交量买卖图 副图,源码(无源码的请下载附件导入)

通达信成交量买卖图 副图,源码

DRAWTEXT_FIX(1,0.00,0,0,'红买绿卖,粉色高抛低吸,黄色庄进货,白色找底建仓')COLORYELLOW;
VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
成交:VOL,NODRAW;
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
买卖差:=(买盘 + 卖盘);
STICKLINE((VOL > 0),VOL,0,3,1),COLORFFFFFF;
STICKLINE((买卖差 > 0),0,买卖差,3,0),COLOR0000FF;
STICKLINE((买卖差 < 0),0,买卖差,2,0),LINETHICK3,COLOR33FF33;
量比1:=(VOL / MA(VOL,5));
VAR10:=买盘;
VAR20:=卖盘;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
动神:=买盘;
鬼力:=VAR20;
神比:=(动神 / VAR30);
鬼比:=(鬼力 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60)));
VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,动神) + 动神) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,动神) + 动神) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,动神) + 动神) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,鬼力) + 鬼力) / 2);
三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
三日下攻:=MA(VAR50,JY2);
多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,2,1),COLOR0000FF;
空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,2,1),COLOR00FF00;
STICKLINE((鬼力 > 0),鬼力,0,2,0),COLORFF3399;
加仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,2,0),COLOR00FFFF;
DRAWTEXT(加仓,VOL,'加'),COLORYELLOW;
减仓:STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,2,0),COLORFF0000;
DRAWTEXT(减仓,VOL,'减'),COLORGREEN;
洗盘:STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,2,0),COLORFFFFFF;
DRAWTEXT(洗盘,VOL,'洗'),COLORWHITE;
高卖:STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,2,0),COLORFF00FF;
倍数:=1.9;
倍量: VOL>=REF(V,1)*倍数 AND (IF(C<O,C>REF(C,1),1)),COLORYELLOW,NODRAW;
DRAWTEXT(倍量,0-1,'倍'),COLORLIMAGENTA;

通达信成交量买卖图 副图,源码





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号