当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信选股指标公式集(无源码的请下载附件导入)

通达信选股指标公式

{逆势买入}
VAR1B:=DMA(CLOSE,VOL/MA(VOL,4)/4);
VAR2B:=DMA(CLOSE,VOL/MA(VOL,32)/32);
VAR3B:=(CLOSE-VAR1B)/VAR1B*100<-8;
VAR4B:=(VAR1B-VAR2B)/VAR2B*100<-21;
逆势买入:IF(VAR3B AND VAR4B AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.05,45,0),STICK,LINETHICK3,COLORF00FF0;
DRAWTEXT(逆势买入,40,'逆势买入'),COLORF0F000;============================
{龙战四海:99%成功率,选股条件:龙战四海=65}
VAR1C:=REF(OPEN,1)<REF(OPEN,2);
VAR2C:=REF(CLOSE,1)<REF(CLOSE,2);
VAR3C:=REF(LOW,1)<REF(LOW,2);
VAR4C:=OPEN>REF(CLOSE,1) AND OPEN/REF(CLOSE,1)>=1.03;
VAR5C:=CLOSE>OPEN AND CLOSE/OPEN>1.03;
VAR6C:=VAR1C AND VAR2C AND VAR3C AND VAR4C AND VAR5C;
VAR7C:=CLOSE/MA(CLOSE,3)>=1.07 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VAR8C:=REF(CLOSE,1);
VAR9C:=SMA(MAX(CLOSE-VAR8C,0),5,1)/SMA(ABS(CLOSE-VAR8C),5,1)*100;
VARA:=COUNT(VAR9C<20,20)>=1;
VARB:=VAR7C AND VARA;
龙战四海:IF(VARB AND VAR6C,65,0),COLORF0F000;
DRAWTEXT(龙战四海,55,'龙战四海'),COLORF00FF0;
{股价经历了相当长一段时间下跌后,做空能量逐渐消耗。最后在星位跳空下跌,标志着市场最后一线希望破灭,但与此同时行情在绝望之中诞生,伴随第三天股价跳空上涨,一轮触底回升行情就此展开。}
============================
{云梯}
{参数描述: P1(0,100,20)P(0.9,1.1,1.088)P2(1,300,5)}
VAR1D:=REF(INDEXC,1);
VAR2D:=SMA(MAX(INDEXC-VAR1D,0),6,1)/SMA(ABS(INDEXC-VAR1D),6,1)*100;
VAR3D:=COUNT(VAR2D<20,20)>=3 OR VAR2D<=1.088;
VAR4D:=VAR2D>=75 AND VAR2D<=90;
VAR5D:=VAR3D OR VAR4D;
VAR6D:=SUM(VOL/CAPITAL,0)/BARSCOUNT(CLOSE);
VAR7D:=VOL/(CAPITAL*VAR6D);
VAR8D:=MA(VAR7D,5);
VAR9D:=100*VAR6D;
VARA1:=VAR8D-VAR9D;
VARB1:=(HIGH+LOW)/2;
VARC1:=VOL/CAPITAL/SMA(VOL/CAPITAL,25,2);
VARD1:=MA(VARB1*VARC1,25);
云梯:IF(VAR3D AND CLOSE>=REF(CLOSE,1) AND INDEXC>=0.98*REF(INDEXC,1) AND CLOSE<=1.45*LLV(CLOSE,55) AND VARA1>0 AND VARD1>0,30,0),STICK,COLOR00FF00;
DRAWTEXT(云梯,25,'云梯'),COLORWHITE;
============================
{旭日东升 }
VAR1F:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;
VAR2F:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;
VAR3F:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));
旭日东升:IF(VAR1F AND VAR2F AND CROSS(VAR3F,79) AND (OPEN>CLOSE OR OPEN<CLOSE) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)<0.05
AND VOL>MA(VOL,23),40,0),COLOR000999 ;
DRAWTEXT(旭日东升,35,'旭日东升'),COLORF0F000;
============================
{冲灵剑法}
VAR1G:=COST(999999999999999999999999999);
VAR2G:=EMA(CLOSE,5);
VAR3G:=EMA(CLOSE,10);
VAR4G:=CROSS(VAR2G,VAR3G);
VAR5G:=VOL>1.05*MA(VOL,5) AND VOL<5*REF(VOL,1);
VAR6G:=(CLOSE-OPEN)/OPEN;
VAR7G:=(HIGH-CLOSE)/(CLOSE-OPEN);
VAR8G:=(OPEN-LOW)/(CLOSE-OPEN);
VAR9G:=VAR7G<0.8 AND VAR8G<0.8;
VARA2:=VAR6G>0.04;
VARB2:=CROSS(MA(CLOSE,5),MA(CLOSE,10)) OR MA(CLOSE,5)-MA(CLOSE,10)<0 AND ABS(MA(CLOSE,5)-MA(CLOSE,10))/MA(CLOSE,10)<0.02 AND MA(CLOSE,5)-MA(CLOSE,10)>REF(MA(CLOSE,5)-MA(CLOSE,10),1);
VARC2:=VAR4G AND VAR5G AND VAR9G AND VARA2 AND VARB2;
VARD2:=COUNT(VARC2,30);
冲灵剑法:IF(VARC2 AND VARD2=1,80,0),STICK,LINETHICK2,COLORF0F000;
DRAWTEXT(冲灵剑法,70,'冲灵剑法'),COLOR2255FF;
============================
{江恩回调选股}
A1:=HHV(HIGH,50)/LLV(LOW,100)>1.5;
A2:=(HHV(HIGH,50)-LOW)/(HHV(HIGH,50)-LLV(LOW,100));
A3:=(LOW-LLV(LOW,100))/(HHV(HIGH,50)-LLV(LOW,100));
A4:=HHVBARS(HIGH,50)<LLVBARS(LOW,100);
A5:=A1 AND A2>0.5 AND A3>0.3 AND A4;
A6:=COUNT(A5,20)=1;
江恩回调选股:IF(A6 AND A5 ,60,0),STICK,LINETHICK2,COLORF00FF0;
DRAWTEXT(江恩回调选股,50,'江恩回调选'),COLORF0F000;
============================
{炮弹}
{参数描述: N(1,30,15) M(1,50,32) }
VAR1H:=DMA(AMOUNT/VOL/100, VOL/CAPITAL);
VAR2H:=MA(WINNER(HIGH)-WINNER(VAR1H), 15);
VAR3H:=MA(WINNER(LOW)-WINNER(VAR1H),32);
VAR4H:=VAR3H-VAR2H;
火箭:IF(REF(VAR4H,2)<REF(VAR4H,1) AND REF(VAR4H,1)>VAR4H AND VAR4H>0 AND
VAR4H*10>1,80,0),STICK,COLOR00FF00;
DRAWTEXT(火箭,70,'火箭'),COLORF00FF0;
导弹:IF(REF(VAR4H,2)<REF(VAR4H,1) AND REF(VAR4H,1)>VAR4H AND VAR4H>0 AND
VAR4H*10<1 AND VAR4H*10>0.55,45,0),STICK,COLORRED;
DRAWTEXT(导弹,40,'导弹'),COLORYELLOW;
炮弹:IF (REF(VAR4H,2)<REF(VAR4H,1) AND REF(VAR4H,1)>VAR4H AND VAR4H>0 AND
VAR4H*10<=0.55,60,0),STICK,COLORF0F000;
DRAWTEXT(炮弹,55,'炮弹'),COLOR000099;
============================
{波段雄鹰}
VAR1A:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR2A:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
VAR3A:=SMA(SMA(VAR2A,3,1),3,1);
VAR4A:=EMA(VAR3A,5);
VAR5A:=LLV(LOW,26);
VAR6A:=HHV(HIGH,34);
VAR7A:=EMA((CLOSE-VAR5A)/(VAR6A-VAR5A)*4,4)*25;
VAR8A:=(2*C+H+L)/4;
VAR9A:=LLV(LOW,9);
VAR10A:=HHV(HIGH,9);
VAR2W:=100-100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));
MW:= EMA(VAR2W,3);
VAR3W:=EMA(VAR2W,7);
M1:= EMA(VAR3W,5);
MB1:=CROSS(MW,M1) AND M1<20;
MG1:=IF(CROSS(M1,MW) AND REF(MW,1)>80,80 ,0) ;
波段:=EMA((VAR8A-VAR9A)/(VAR10A-VAR9A)*100,9),COLORRED;
B1:=EMA(0.667*REF(波段,1)+0.333*波段,2),COLOR00FF00;
STICKLINE(波段>B1,波段,B1,10,1),COLORRED;
STICKLINE(波段<=B1,波段,B1,10,1),COLOR00FF00;
波段雄鹰顶:IF((BARSLAST(MG1>0)<2),80,100),COLOR00FF00;
波段雄鹰底:IF((MB1),20,0),LINETHICK2,COLORYELLOW;
DRAWTEXT(波段雄鹰底,25,'★'),COLORF00FF0;
DRAWTEXT(波段雄鹰底,15,'波段雄鹰底'),COLORF0F000;
DRAWICON((BARSLAST(MG1>0)<2),80,2);
DRAWTEXT((BARSLAST(MG1>0)<2),90,'波段雄鹰顶');
============================
{百万预警}
VAR1P:=(CLOSE-LLV(LOW,60.135))/(HHV(HIGH,60.135)-LLV(LOW,60))*80;
VAR2P:=SMA(VAR1P,7,1);
VAR3P:=SMA(VAR2P,5,1);
百万预警:IF(CROSS(VAR2P,VAR3P) AND VAR2P<20,85,0),LINETHICK2 , COLOR000999;
DRAWTEXT(CROSS(VAR2P,VAR3P) AND VAR2P<20,75,'百万预警'),COLORF00FF0;
DRAWTEXT(CROSS(VAR2P,VAR3P) AND VAR2P<20,90,'★'),COLORRED;
============================
{漫步青云}
DIFF := EMA(CLOSE,12) - EMA(CLOSE,26);
DEA := EMA(DIFF,27);
DJE1:=DIFF>=0 AND DEA>=0 AND CROSS(DIFF,DEA);
A5A:=MA(CLOSE,5)>MA(CLOSE,10);
V5A:=VOL>MA(VOL,5) AND MA(VOL,5)>MA(VOL,10);
漫步青云:IF(DJE1 AND A5A AND V5A AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1),60,0),COLORF0F000;
DRAWTEXT(漫步青云,50,'漫步青云' ),COLORYELLOW;
{CES}
VAR00:=LWINNER(1,CLOSE);
VAR1:=FORCAST(VAR00,10);
VAR2:=MA(VAR1,3);
VAR3:=MA(VAR2,12);
VAR4:=MA(VAR3,16);
VAR5:=MA(VAR4,31);
VAR6:=MA(VAR5,55);
VAR7:=VAR5; VAR8:=VAR4>VAR2*1.11 AND VAR3>VAR2*1.095;
VAR9:=VAR2>VAR1*0.95;
VAR1H:=INDEXC;
VAR2H:=MA(VAR1H,6);
VAR3H:=MA(VAR1H,24);
VAR4H:=MA(VAR1H,32);
VAR5H:=MA(VAR1H,62);
VAR6H:=MA(VAR1H,105);
VAR7H:=VAR5H; VAR8H:=VAR4H>VAR2H*1.11 AND VAR3H>VAR2H*1.095;
VAR9H:=VAR2H>VAR1H*0.95;
PT:=(IF(H=L AND C=O AND L=C AND C>0 AND REF(H,1)=REF(L,1) AND REF(C,1)=REF(O,1)
AND REF(H,1)=REF(C,1) AND REF(C,1)>0,0,1))>0;
CES:IF((VAR7H AND VAR8H AND VAR9H AND CLOSE/COST(8)<=0.7985
AND (COUNT(C=L,4)<3 OR C>REF(C,1)))AND PT OR
VAR7 AND VAR8 AND VAR9 AND CLOSE/COST(5)<=0.8 AND
((VAR1>OPEN OR VAR1>REF(OPEN,1) OR
REF(VAR1,1))),90,0),STICK,LINETHICK4,COLORRED;
DRAWICON(CES,90,1);
============================
{黑马初选}
黑马初选:IF(VOL/240>REF(VOL,30)*1.2/240*1.5 AND CLOSE>LOW*1.06 AND CLOSE>REF(MA(CLOSE,3),1) AND MA(CLOSE,3)>REF(MA(CLOSE,3),1) AND "KD.K"(9,3,3)<50,50,0),COLORF00FF0;
DRAWICON(黑马初选,60,1);
DRAWTEXT(黑马初选,40,'黑马初选'),COLORF0F000;
============================
{蛟龙出海}
VAR1B:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,15)-LLV(LOW,9))*100;
VAR2B:=SMA(VAR1B,3,1);
VAR3B:=SMA(VAR2B,3,1);
VAR4B:=CLOSE/MA(CLOSE,3)>=1.05 AND MA(VOL,3)/MA(VOL,20)>1.5 AND COUNT(VAR2B<20,20)>=1;
蛟龙出海:IF(VAR4B AND COUNT(VAR4B,5)=1,60,0),COLOR00FF00;
DRAWTEXT(蛟龙出海,50,'蛟龙出海'),COLORRED;
============================
{百万探庄}
VAR1C:=MA(WINNER(CLOSE),9)*100;
百万探庄:IF(CROSS(VAR1C,2.5)*85,80,0),LINETHICK2 , COLORYELLOW,STICK;
DRAWTEXT(百万探庄,70,'百万探庄'),COLORRED;
============================
{组合底部}
CCI:="CCI"(14);
A:=REF(C,1);
RSI:=SMA(MAX(C-A,0),6,1)/SMA(ABS(C-A),6,1)*100;
A1:=C-MA(C,5)/MA(C,5)*100<1;
A2:=C-MA(C,13)/MA(C,13)*100<-10;
A3:=C-MA(C,34)/MA(C,34)*100<-15;
A4:=RSI<18;
A5:=CCI<-120;
组合底部:IF(A1 AND A2 AND A3 AND A4 AND A5,40,0),COLORRED;
DRAWICON(组合底部,43,1);
DRAWTEXT(组合底部,30,'组合底部'),COLORF0F000;
============================
{雨点}
VAR1B:=(HIGH+LOW+OPEN+2*CLOSE)/5;
VAR2B:=REF(VAR1B,1);
VAR3B:=SMA(MAX(VAR1B-VAR2B,0),10,1)/SMA(ABS(VAR1B-VAR2B),10,1)*100;
雨点星星:IF(COUNT(VAR3B<20,5)>=1 AND COUNT(VAR1B=LLV(VAR1B,10),10)>=1
AND CLOSE>OPEN AND REF(CLOSE,1)>REF(OPEN,1) AND VOL>REF(VOL,1),1,0),COLORD480AD;
DRAWTEXT(雨点星星,100,'★'),COLORD480AD;
============================
{草原黑马}
{N(1,100,38) N1(1,100,5) N2(1,100,13)}
VAR1ACLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80,COLORBLUE;
STICKLINE(VAR1A>0,0,100,8,0),COLORFFFCC0;
============================
{底部反转}
VAR1:=MA(CLOSE,26);
VAR2:=VAR1+2*STD(CLOSE,26);
VAR3:=VAR1-2*STD(CLOSE,26);
VAR4:=CLOSE>OPEN;
VAR5:=(HIGH-CLOSE)/OPEN;
VAR6:=(CLOSE-OPEN)/OPEN;
VAR7:=VAR4 AND VAR5/VAR6<0.5;
VAR8:=CROSS(CLOSE,VAR3) AND LLV(VAR3,3)=LLV(VAR3,90) AND VAR7;
底部反转:IF(VAR8 AND REF(BARSLAST(VAR8),1)>10,70,0),LINETHICK3,COLORF0F000;
DRAWTEXT(底部反转,60,'底部反转'),,COLOR1373C0;
DRAWTEXT(底部反转,75,'★'),COLORRED;
============================
{中短底都有}
{P1(1,100,15) P2(1,100,33) P3(10,250,29) P4(10,100,28)}
AA:=(HHV(HIGH,29)/REF(CLOSE,1))>(1+28/100);
BB:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
CC:=BB-BB*15/100;
中短底都有:IF(LOW<CC AND VOL/MA(VOL,5)>1
AND CLOSE/OPEN>=(1+33/10/100 ) AND VOL>MA(VOL,5)* 15/10 AND AA,40,0),STICK ,LINETHICK4,COLORRED;
DRAWTEXT(中短底都有,30,'中短底都有'),COLOR00FF00;
DRAWICON(中短底都有,45,1);
============================
{剑客四,雪飞指标选股}
BIAS1 := (CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2 := HHV((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100,200);
M1:= BIAS1=BIAS2 ;
M2:= V>MA(V,5) ;
M3:= REF(BIAS1,1)<REF(BIAS2,1) ;
M4:=M1 AND M2 AND M3;
指标选股XF:IF(M4,1,0),COLOR0097DE;
DRAWTEXT(指标选股XF,85,'★'),COLOR0097DE;
STICKLINE(VAR1A<=0,VAR1A,100,8,0),COLORFFFCC0;
STICKLINE(VAR1A,VAR1A,0,8,0),COLORGREEN;
B1:= SMA(VAR1A,7,1),;
VAR2A:=SMA(B1,5,1);
E1:= IF(CROSS(B1,VAR2A) AND CROSS(MA(C,5),MA(C,13) AND B1>50) ,VAR2A*2,VAR2A),;
VAR4A:= EMA(CLOSE,8);
VAR5A:= EMA(CLOSE,20);
草原黑马买入:IF(CROSS(MA(CLOSE,1),MA(CLOSE,38)) AND B1-E1>2 AND VAR4A>VAR5A ,60,0),LINETHICK2,COLOR00FF00;
DRAWTEXT(草原黑马买入,50,'草原黑马'),COLORRED;
============================
{紧追感情}
VAR1D:=(CLOSE-LLV(CLOSE,21))/LLV(CLOSE,21)*1000;
VAR2D:=(CLOSE+OPEN)/2;
VAR3D:=(HIGH+LOW)/2;
VAR4D:=IF(CLOSE>REF(CLOSE,1),MAX(VAR2D,VAR3D),MIN(VAR2D,VAR3D));
VAR5D:=SUM(VAR4D*VOL,21)/SUM(VOL,21);
VAR6D:=VOL/CAPITAL*100;
VARAD:=(CLOSE-VAR5D)/VAR5D*100<-16 AND CLOSE/HHV(CLOSE,50)<=0.8 AND CLOSE/LLV(CLOSE,5)<1.2 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>-11 AND VAR6D<=10 AND COUNT(VAR1D>500,60)<1 AND FINANCE(7)<=80000;
紧追感情:IF(VARAD AND COUNT(VARAD,5)>=1,20,0),STICK,LINETHICK3,COLORF00FF0;
DRAWTEXT(紧追感情,25,'▲'),COLORF00FF0;
DRAWTEXT(紧追感情,15,'紧追感情'),COLOR000999;
============================
{强势股}
{N(5,250,20 M(15,100,20)}
VAR1C:=(CLOSE-REF(OPEN,20))/REF(OPEN,20);
VAR2C:=(INDEXC-REF(INDEXO,20))/REF(INDEXO,20);
强势股:IF(VAR1C>0 AND VAR2C>0 AND VAR1C/VAR2C>=20/10 OR VAR1C>VAR2C AND VAR2C=0 OR 0>VAR1C AND VAR1C>VAR2C AND VAR2C/VAR1C>=20/10,1,0),COLORRED;
DRAWTEXT(强势股,10,'▲'),COLORRED;
============================
{魔法1:我调整了参数,成功率59.7%,净利23%}
{参数描述: N(1,100,6)M1(2,40,2)M2(2,40,2)X(0,10,2)}
100;
VAR1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
VAR2:=SMA(VAR1,13,1);
VAR3:=SMA(VAR2,5,1);
VAR4:=3*VAR2-2*VAR3;
魔法1:IF(VAR3<100 AND VAR4>VAR2*1.03 AND VAR2>VAR3*1.01 AND VAR4>REF(VAR4,1)*1.05 AND VAR2>REF(VAR2,1)*1.005 AND VAR3>REF(VAR3,1)*1.005 AND CLOSE>OPEN*(1+2/100) AND VOL>MA(VOL,5)*1.2,50,0),COLORYELLOW;
DRAWTEXT(魔法1,45,'魔法1'),COLOR00FF00;
============================
{抄底}
VAR1A:=(CLOSE-MA(CLOSE,48))/MA(CLOSE,48)*100<-30;
VAR2A:=(CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100<-27;
VAR3A:=VAR1A AND VAR2A;
抄底:IF(VAR3A AND COUNT(VAR3A,2)=1 AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07,85,0),STICK,LINETHICK3,COLORRED;
DRAWTEXT(抄底,85,'★'),COLORYELLOW;
DRAWTEXT(抄底,75,'抄底'),COLORYELLOW;
============================
{收盘价逃顶}
V1:=MA(C,5)=HHV(MA(C,5),20);
V2:=MA(C,5)>MA(C,10);
V3:=MA(V,5)>MA(V,40)*1.01;
V4:=COUNT(MA(C,1)>REF(C,1),2)=2;
收盘价逃顶:IF(V1 AND V2 AND V3 AND V4,90,0),LINETHICK2,COLORBLUE;
DRAWTEXT(收盘价逃顶,80,'收盘价逃顶'),COLOR000999;
============================
{三均线粘合}
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
P1:=ABS(MA1-MA2)+ABS(MA2-MA3);
AA:=P1/C<20/1000 AND MA1>REF(MA1,1) AND MA2>REF(MA2,1) AND MA1<MA3 AND MA2<MA3;
三均线粘合:IF(AA,22,0),LINETHICK2,COLOR000999;
DRAWTEXT(AA,21,'三均线粘合'),COLOR00FF00;
============================
{天胜至尊}
100;
0;
VAR1:=IF(YEAR>2094,0,1) OR IF(YEAR>2093 AND MONTH>=1,0,1);
VAR2:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR3:=(CLOSE-VAR2)/VAR2*100;
VAR4:=REF(VAR3,1)<-40 AND VAR3>REF(VAR3,1) AND REF(VAR3,1)<REF(VAR3,2) AND VAR3-REF(VAR3,1)>2.5;
VAR5:=(CLOSE-OPEN)/OPEN*100;
VAR6:=REF(CLOSE,1);
VAR7:=SMA(MAX(CLOSE-VAR6,0),6,1)/SMA(ABS(CLOSE-VAR6),6,1)*100;
VAR8:=COUNT(VAR7<20,20)>=1;
VAR9:=VAR5>9 AND VAR8;
VARA:=100*WINNER(OPEN);
VARB:=100*WINNER(CLOSE);
VARC:=VARB-VARA;
VARD:=VARC>=30;
VARE:=CLOSE/MA(CLOSE,3)>=1.07 AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
VARF:=REF(CLOSE,1);
VAR10:=SMA(MAX(CLOSE-VARF,0),5,1)/SMA(ABS(CLOSE-VARF),5,1)*100;
VAR11:=COUNT(VAR10<20,20)>=1;
VAR12:=VARE AND VAR11;
VAR13:=MA(CLOSE,4);
VAR14:=MA(CLOSE,10);
VAR15:=MA(CLOSE,20);
VAR16:=MA(CLOSE,25);
VAR17:=COUNT(CROSS(VAR14,VAR15),2)=1;
VAR18:=COUNT(CROSS(VAR13,VAR16),2)=1;
VAR19:=VAR17 AND VAR18;
VAR1A:=VAR12 AND VARD AND VAR19;
VAR1B:=MA(CLOSE,80)-MA(CLOSE,10)/3;
VAR1C:=CLOSE<VAR1B AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3;
天胜至尊:IF(VAR4 OR VAR9 OR VAR1A OR VAR1C*VAR1,80,0),STICK,LINETHICK2,COLORRED;
DRAWTEXT(VAR4 OR VAR9 OR VAR1A OR VAR1C*VAR1,70,'天胜至尊'),COLORYELLOW;
============================
{CN抄底}
VAR1G:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL);
VAR2G:=REF(HIGH,10)/CLOSE>1.35;
抄底: IF((CLOSE-VAR1G)/VAR1G*100<-30 AND VAR2G,70,0),COLORYELLOW;
DRAWTEXT((CLOSE-VAR1G)/VAR1G*100<-30 AND VAR2G,60,'抄底'),COLORF0F000;
============================
{回调必杀}
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RSI3:=SMA(MAX(CLOSE-LC,0),24,1)/SMA(ABS(CLOSE-LC),24,1)*100;
A1 :=CLOSE/MA(CLOSE,3)>=(1+0.07) AND CLOSE=HHV(CLOSE,3) AND MA(VOL,2)/MA(VOL,40)>=3 AND MA(VOL,2)=HHV(MA(VOL,2),3) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
RSI:= SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
A2 :=COUNT(RSI<20,20)>=1;
回调必杀:IF(A1 AND A2,60,0),STICK,COLOR00FF00;
DRAWTEXT(A1 AND A2,50,'回调必杀'),COLORRED;
============================
{千年等一回}
VAR1K:=INDEXC;
VAR2K:=MA(VAR1K,6);
VAR3K:=MA(VAR1K,24);
VAR4K:=MA(VAR1K,32);
VAR5K:=MA(VAR1K,62);
VAR6K:=MA(VAR1K,105);
VAR7K:=VAR5K<REF(VAR5K,1) AND VAR6K<REF(VAR6K,1) AND VAR5K<VAR6K*0.98;
VAR8K:=VAR4K>VAR2K*1.11 AND VAR3K>VAR2K*1.095;
VAR9K:=VAR2K>VAR1K*0.95;
VARAK:=CLOSE/MA(CLOSE,48)*100<73;
VARBK:=CLOSE/MA(CLOSE,50)*100<76;
VARCK:=HIGH>LOW*1.078;
VARDK:=VARCK AND COUNT(VARCK,4)>2;
千年等一回:IF((VARDK AND (VARAK OR VARBK) AND VAR7K AND VAR8K AND VAR9K AND CLOSE/COST(8)<=0.81 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1))),90,0),STICK,LINETHICK5,COLORYELLOW;
DRAWTEXT(千年等一回,85,'千年等一回'),COLOR00FF00;
============================
{惊天动地}
VAR1H:=(CLOSE-LLV(LOW,19))/(HHV(HIGH,19)-LLV(LOW,19))*100;
VAR2H:=SMA(VAR1H,3,1);
VAR3H:=SMA(VAR2H,5,1);
VAR4H:=3*VAR2H-2*VAR3H;
VAR5H:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR6H:=SMA(VAR5H,3,1);
VAR7H:=SMA(VAR6H,3,1);
VAR8H:=3*VAR6H-2*VAR7H;
VAR9H:="BOLL"(26,2);
VARAH:="MACD"(26,12,9);
VARBH:="CYS";
VARCH:=IF(DATE>1300415,0,1);
VARDH:=REF(VARBH,1)<-17.5 AND REF(VARBH,1)>-36 AND CLOSE*VARCH<10 AND CLOSE*VARCH/REF(CLOSE,1)>0.935 AND CROSS(VAR4H,VAR6H);
惊天动地:IF(VARDH/VARBH,50,0),COLOR00FF00;

============================
{强势觅踪}
VAR1J:=VOL/CAPITAL>=0.02 AND NOT(REF(VOL/CAPITAL>=0.5,1)) AND CLOSE/OPEN>1.05 AND
HIGH/LOW<CLOSE/OPEN+0.018;
VAR2J:=CLOSE/REF(OPEN,2)>1.15;
VAR3J:=(REF(CLOSE,2)-LLV(LOW,13))/(HHV(HIGH,13)/1.15-LLV(LOW,13))>0.2;
VAR4J:=VAR1J AND VAR2J AND VAR3J;
强势觅踪:IF(VAR4J AND COUNT(VAR4J,60)=1,45,0),COLORRED;
DRAWTEXT(强势觅踪,35,'强势觅踪'),COLORYELLOW;
============================
{猎杀潜航}
趋势:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),COLORYELLOW;
底部:=7;
猎杀潜航:IF(CROSS(趋势,底部),70,0),STICK,COLORF0F000,LINETHICK3;
DRAWTEXT(猎杀潜航,60,'猎杀潜航'),COLORRED;
============================
{逢底必抄}
B1:=REF(CLOSE,2);
B2:=SMA(MAX(CLOSE-B1,0),7,1)/SMA(ABS(CLOSE-B1),7,1)*100;
逢底必抄:IF(B2<19,30,0),LINETHICK2,COLOR00FF00;
DRAWTEXT(逢底必抄,25,'逢底必抄'),COLORYELLOW;
=====================================

补充
1小金角技巧
即10日均价线与20日均价线走出圆弧底,10日均价线上叉20日均价线,并且20日
均价线也是要勾头向上的,股价在交叉点上方附近,甚至交叉点下方,10日均价
线与20日均价线向上开口角度越陡,后势上涨的潜力越大。
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
YHD:=COUNT(REF(MA10<MA20,3),16)>=15 AND COUNT(MA5>MA10,3)>2;
XG:YHD AND CROSS(MA10,MA20)AND MA20>REF(MA20,1);
2大金角技巧:
就是20日均价线向上,上叉62日均价线,并且62日均价线也是要勾头向上的,这
样20日和62日都是开口向上的,其是底部阳量放大的那些股票,并且开的角度越陡
后期就越猛。
MA20:=MA(C,20);
MA62:=MA(C,62);
V1:=V>REF(V,1);
CROSS(MA20,MA62)AND MA62>REF(MA62,1) AND COUNT(V1,3)>2;
3小金边技巧
10日与20日均价线均向上运行,二者距离相差不大角度越陡越好;股价从10日线
上方跌破10日线,接近20日均价线,最好4日线也跌破10日线;62日与133日均价
线,没有反作用力最好;随后产生的成交阳量越大越好;MACD指标图形为空中加
油技巧最好.小金边技巧第一次出现是最有效的,可重点寻找那些股价回落到小金
边里面,4日线与20日线接近的股票小金边技巧(4死叉10配62)选股。
MA4:=MA(C,4);
MA10:=MA(CLOSE,10);
MA20:=MA(CLOSE,20);
L1:=V>REF(V,1);
V1:=COUNT(CROSS(MA10,MA20),15);
V2:=C<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2);
XJB:V1=1 AND V2 AND MA10>C AND C>MA20 AND SLOPE(MA20,4)>0 AND SLOPE(MA10,3)>0;
XG:REF(XJB,2)=1 AND MA4>REF(MA4,1) AND L1
4大金边技巧:
当股价出现金角以后,股价会经过一段时间的上涨,股价第一次回落,跌破20日
线,跌到20日和62日夹角里就是大金边!
MA20:=MA(C,20);
MA62:=MA(C,62);
V1:=V>REF(V,1);
DJJ:=CROSS(MA20,MA62)AND MA62>REF(MA62,1) AND COUNT(V1,3)>2;
XG:COUNT(DJJ,30)>0 AND C<MA20 AND C>MA62 AND MA62>REF(MA62,1)

5、MACD骑墙技巧:
股价刚上涨时如DIF线已跨上0轴,而MACD线(或称DEA线)即将跨上但还未跨上0轴时,一旦成交放量,则上涨有望加速。
DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
DIF>=0 AND CROSS(DIF,DEA) AND V/MA(V,5)>1.5;
6、半山水库技巧:
当20线上穿60线,并且60线的趋势向上,则该均线粘合点为买入点
MA20:=MA(C,20);
MA60:=MA(C,60);
XG:CROSS(MA20,MA60) AND MA60>REF(MA60,1)
7、隔谷底背离技巧:
当股价第一次下跌到一定程度时,然后反弹拉升,上升到一定程度时,又开始第
二次下跌,并且第二次下跌比第一次更深;同时,第一次下跌时最低点对应的
MACD指标为绿色柱状,而第二次下跌时最低点对应的MACD指标为红色柱状。这样
,同时满足以上四个条件,第二次下跌时的最低点即为买入的最佳点
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=2*(DIFF-DEA), COLORSTICK,LINETHICK2;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1) AND MACD<0);
底背离:REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS
(DIFF,DEA) AND MACD>0;
8海豚张嘴技巧:
20日线上穿62日线,20日线趋势向上;且4日线在经过一个小幅拉高回调盘整后,
于20日,62日粘合;并在交叉点上放量,且超过5日甚至10均量;后市就容易形成
多头排列,快速拉升。
网上已有现成的,下面是两个,请选用
01、
MA62:=MA(CLOSE,62);
MA20:=MA(CLOSE,20);
VAR1:=SLOPE(MA20,3)>0;
VAR2:=ABS(SLOPE(MA62,3))<0.19;
VAR3:=SLOPE(MA62,3)>REF(SLOPE(MA62,3),1);
V1:=MA62<MA20;
V2:=COUNT(CROSS(MA20,MA62),10);
选股:C>MA62 AND C<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND VAR1 AND VAR2 AND VAR3 AND V1 AND V2=1;
02、
A4:=MA(C,4);
A20:=MA(C,20);
A62:=MA(C,62);
CROSS(A20,A62)AND A20>REF(A20,1)AND COUNT(A4/A20>1.05,10)>5 AND ABS(A4/A20-1)<0.02 AND V/MA(V,5)>1.5;


9、金足底技巧
一。何谓“金足底”?
“底”——一定是跌到最低点,此时均线系统通常处于下跌趋势。
“足”——脚下的意思。
“金”——获利的表示。
连接起来就是:在最低点(脚底下的价位)买入的股票能让我们获利。
二。形成特征:
1。经过了一段时间的下跌。
2。下跌导致均线系统走坏,出现破位。
3。一定要在震荡后的第二个底部买进。
三。把握:
1。10日线勾头向上。
2。20日线由下跌走平。
3。成交阳量突破5日均量。
4。当4日线向下时会压制股价的上升,假如发现股价在4日线之上,而4日线由下跌转为向上,即可判断会有上涨。此时,若成交阳量大于5日均量,就该果断买进。
5。当4日线下叉20日线,并折向下时,4日线与10日线粘合时,为好的买点。
6。当4日线向下接近10日线,最好在4日线能够下叉10日线时,去买进股票,因为那时是形成前脚掌的时侯,是最好的买点。
MA4:=MA(C,4);
MA10:=MA(C,10);
MA20:=MA(C,20);
W1:=MA10>REF(MA10,1);
W2:=MA20>=REF(MA20,1);
W3:=V>MA(V,5);
XGMA4<MA20 AND MA4>=REF(MA4,1) AND C>MA4 AND W1 AND W2 AND W3);


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号