当前位置:→ 公式指标网 > 通达信公式 > 正文 

以下是通达信五星推荐副图指标(无源码的请下载附件导入)

通达信五星推荐副图指标

WOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
换手:VOL/CAPITAL*100,POINTDOT;
十日换手:SUM(换手,10);
二十日换手:SUM(换手,20);
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,WOL,0,3,-1),COLORFFFFFF;
VOLUME:VOL,VOLSTICK;
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主买:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;
主卖:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;
STICKLINE(主买>0,0,主买,2,0),COLORRED;
{STICKLINE(主卖>0,主买,VOL,2,1),COLOR00FF80;}
STICKLINE(主买<REF(主买,1)AND 主买>0,0,主买,2,0),COLOR00FFFF;
V5:MA(VOLUME,5),LINETHICK3;
V10:MA(VOLUME,10),LINETHICK3;
V135:MA(VOLUME,135),LINETHICK3;
DRAWICON(十日换手>30,-20000,1);
DRAWICON(十日换手>80,-10000,23);
DRAWTEXT(CURRBARSCOUNT=40,HHV(V,80)*0.9,'10日换手>30出红箭头,>80出红十字');
DRAWICON(二十日换手>30,-40000,2);
DRAWICON(二十日换手>80,-30000,17);
DRAWTEXT(CURRBARSCOUNT=80,HHV(V,80)*0.95,'20日换手>30出绿箭头,>80出桔子'),COLOR00FFFF;

{VOLUME:VOL,VOLSTICK;
}
T:=DYNAINFO(8)>0;
VO:VOL=LLV(VOL,100) AND T;
地量柱:T AND VO,COLORBLUE;
STICKLINE(地量柱,0,V,1,0),COLORBLUE;
DRAWTEXT(地量柱,VOL+3000,'地'),COLORBLUE;
BLZ:=VOL>REF(V,1)*1.9;
BLZ1:=VOL<REF(LLV(VOL,13),1);
BLZ2:=VOL<REF(LLV(VOL,55),1);
STICKLINE(BLZ,0,V,1,0),COLORYELLOW;
倍量柱:BLZ,COLORYELLOW;
DRAWTEXT(倍量柱,VOL+3000,'倍'),COLORYELLOW;
HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>HJZ2 AND C>O;
黄金柱:FILTER(HJZ3,5),STICK,COLORRED,LINETHICK4;
STICKLINE(黄金柱,0,V,1,0),COLORRED;
DRAWTEXT(黄金柱,VOL+12000,'黄'),COLORRED;
捞一把:=COUNT(CLOSE>REF(CLOSE,1),3)=3 AND COUNT(VOL<REF(VOL,1),3)=3;
STICKLINE(捞一把,0,V,1,0),COLORGREEN;
DRAWTEXT(捞一把,VOL+3000,'涨缩'),COLORMAGENTA;
{价涨量缩:捞一把,COLORGREEN;}
FLZ:=V>REF(V,1)*0.98 AND V<REF(V,1)*1.02,LINETHICK0;
STICKLINE(FLZ,0,V,1,0),COLORMAGENTA;
DRAWTEXT(FLZ,VOL+3000,'平'),COLORMAGENTA;
平量柱:FLZ,COLORMAGENTA;
低量柱:=IF(V=LLV(V,10),9,8);
DRAWTEXT(低量柱>8,VOLUME*1.3,'低'),COLORYELLOW;
量柱:V/CAPITAL*100,VOLSTICK;
高量柱:=IF(V=HHV(V,10),3,2);

并肩平量柱:=IF((V/REF(V,1)>0.95 AND V/REF(V,1)<1.05),7,6);
缩量柱:=IF(V<REF(V,1) AND REF(V,1)<REF(V,2) AND REF(V,2)<REF(V,3),25,35);
梯量柱:=IF(V>REF(V,1) AND REF(V,1)>REF(V,2) AND REF(V,2)>REF(V,3),11,10);
DRAWTEXT(倍量柱>0,VOLUME*0.85,'倍');
DRAWTEXT(高量柱>2,VOLUME*0.75,'高');
DRAWTEXT(并肩平量柱>6,VOLUME*0.6,'平');
DRAWTEXT(梯量柱>10,VOLUME*0.55,'梯');
{DRAWTEXT(低量柱>8,量柱*1.01,'低'),COLORYELLOW;}
DRAWTEXT(缩量柱<35,VOLUME*1.01,'缩'),COLORYELLOW;
 

通达信五星推荐副图指标





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 2009-2010 gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识