当前位置:→ 股票公式指标网 > 公式解答 > 正文 

    编写要求:

     

    www.gszx.com.cn网解答:

     网友求助:

    BOLL:MA(CLOSE,20),COLORRED;
    UPPER:BOLL+2*STD(CLOSE,20),COLOR808080 ;
    LOWER:BOLL-2*STD(CLOSE,20),COLORGREEN;
    IF(BOLL<REF(BOLL,1),BOLL,DRAWNULL),COLORBLUE;
    涨家数:INDEXADV,COLOR0000DD,NODRAW;
    跌家数:INDEXDEC,COLOR00DD00,NODRAW;
    TT:=240/FROMOPEN;
    比:=TT;
    J12:=(HIGH - ((HIGH - LOW) / 3));
    J23:=(LOW + ((HIGH - LOW) / 3));
    AAA:=CONST(HHV(H,90));
    BBB:=CONST(LLV(L,100));
    DRAWKLINE(H,O,L,C);
    JRH:=HHV(C,2);
    JRL:=LLV(C,2);
    YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
    VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
    VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
    VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);
    VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD);
    红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;
    离场:=IF(红色持股,JRL,DRAWNULL);
    明离场价:=离场,COLORFF99FF,NODRAW;
    今离场价:=REF(离场,1)COLOR0000FF,NODRAW;
    青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW;
    进:=IF(青色观望,JRH,DRAWNULL);
    明进场价:=进,COLOR33AACC,NODRAW;
    今进场价:=REF(明进场价,1),COLORFF0000,NODRAW;
    黄色底买:VAR19,COLOR33AACC,NODRAW;
    洋红离场:VAR1A,COLORMAGENTA,NODRAW;
    急跌关注:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORWHITE,NODRAW;
    STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF;
    STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00;
    STICKLINE(C>=O,L,H,0,0),COLOR0000CC;
    STICKLINE(C<O,L,H,0,0),COLOR999900;
    STICKLINE(1,C,O,3.5,0),COLOR858500;
    STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
    STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055;
    STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088;
    STICKLINE(红色持股,CLOSE,O,1.5,0),{COLOR0000AA}COLORRED;
    STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC;
    STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE;
    STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500;
    STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800;
    STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00;
    STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00;
    STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00;
    CO:=(C-O);
    STICKLINE(急跌关注,O,C-CO/2,2.8,0),COLOR555555;
    STICKLINE(急跌关注,O,C-CO/2,2,0),COLOR888888;
    STICKLINE(急跌关注,O,C-CO/2,1.5,0),COLORAAAAAA;
    STICKLINE(急跌关注,O,C-CO/2,1,0),COLORCCCCCC;
    STICKLINE(急跌关注,O,C-CO/2,0.5,0),COLOREEEEEE;
    STICKLINE(黄色底买,O,O+CO/3,2.8,0),COLOR335555;
    STICKLINE(黄色底买,O,O+CO/3,2,0),COLOR338888;
    STICKLINE(黄色底买,O,O+CO/3,1.5,0),COLOR33AAAA;
    STICKLINE(黄色底买,O,O+CO/3,1,0),COLOR33CCCC;
    STICKLINE(黄色底买,O,O+CO/3,0,0),COLOR33EEEE;
    {DRAWTEXT(短买,REF(CLOSE,1),'<B'),COLOR33FFCC;}
    STICKLINE(洋红离场,O,O+CO/3,2.8,0),COLOR550055;
    STICKLINE(洋红离场,O,O+CO/3,2,0),COLOR880088;
    STICKLINE(洋红离场,O,O+CO/3,1.5,0),COLORAA00AA;
    STICKLINE(洋红离场,O,O+CO/3,1,0),COLORCC00CC;
    STICKLINE(洋红离场,O,O+CO/3,0.5,0),COLOREE00EE;
    DRAWICON(CROSS(C,BOLL),L,7);
    DRAWTEXT(CROSS(C,LOWER),L,1),COLORYELLOW;
     
     
    解答如下:
    VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
    VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));
    VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));
    VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));
    ((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1);

     

    互动内容:
    昵称: 验证码:验证码 

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号