当前位置:→ 股票公式指标网 > 公式解答 > 正文 

    编写要求:

     

    股旁www.gszx.com.cn 网友求助:

    帮写个在MACD二次翻红时标注出天数的公式
     
    解答如下:
    DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIFF,9);
    MACD:=2*(DIFF-DEA);
    FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);
    FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;
    FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);
    FH4:=FH1 AND FH2 AND ABS((DIFF-DEA)/C)<0.018;
    FH5:=FH1 AND FH2 AND MACD<0.10;
    AA:FH3 OR FH4 OR FH5;
    BARSLAST(AA)+1,LINETHICK0;

     

    互动内容:
    昵称: 验证码:验证码 

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号